Files with non-ASCII names upload empty

RESOLVED DUPLICATE of bug 213628

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 213628
13 years ago
4 years ago

People

(Reporter: Duncan, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Files with names containing non-ASCII chars are uploaded empty.

Test case is Fedora Core 3 uploading a name in ISO-8859-1 to a site which
expects that.

This is not (quite) a duplicate of #273225.  That bug is about breaking the file
names.  In this case, the name is sent correctly, but the file content is
missing (probably because name handling is broken somewhere on the way to
opening the file).

Reproducible: Always

Steps to Reproduce:
1. Create a file with an 8-bit LATIN1 name (eg "My-file-รก.txt")
2. Attempt to upload it to somewhere with an <input type="file"> which expects
and serves content in ISO-8859-1 or ISO-8859-15.
3. Observe that the receiving site knows the correct name, but thinks you sent
an empty file.

Actual Results:  
Ethereal TCP dump shows Firefox POSTs form data including correct filename, but
omits the content of the file. 

Expected Results:  
Should send the content as well as the name.

Probably depends on #162361

This is a new bug in fairly recent versions of the browser (not present in
Mozilla 1.7.3 or early 'Firebird'-era builds.

Comment 1

13 years ago
bug 273225, bug 162361 (for better reference)
Whiteboard: DUPEME
Version: unspecified → 1.0 Branch

Comment 2

13 years ago
Duping to similar bug 213628

*** This bug has been marked as a duplicate of 213628 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.