Cannot upload a file, if the filename contains any character/symbol in non-default codepage.

RESOLVED DUPLICATE of bug 66041

Status

()

Core
Internationalization
RESOLVED DUPLICATE of bug 66041
13 years ago
11 years ago

People

(Reporter: Rodion, Assigned: smontagu)

Tracking

({pp})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041204
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a6) Gecko/20041204

If you have a file with the name in Unicode (for example the name with cyrillic
symbols and german umlauts in the same time) and you want to upload it somewhere
by means of <INPUT FILE>, it doesn't work.

All symbols, that are not in default Windows codepage (see infra), are converted
to another symbols. For example if your default codepage ist "Russian", you lose
dots from the umlauts (ö->o, ü->u). Then in <INPUT FILE> field we will have the
filename which is not same as original filename in OS filesystem.

Of couse, wenn we submit the form, Mozilla cannot find the file and send nothing.

* - By "default codepage" I mean the codepage, which can be changed in Windows
XP here: "Control Panel/Regional options/Advanced/Language for non-Unicode..."

Reproducible: Always
Steps to Reproduce:
1. Take any form with <INPUT FILE> tag
2. Make a file with symbols from several codepages. (For example abc_абв_öäü.txt)
3. Try to upload this file.
Actual Results:  
Mozilla show in <INPUT FILE> fields something like this "abc_???_öäü.txt" or
"abc_абв_oau.txt" and upload nothing, because the name is incorrect.
yeah, mozilla does not currently use unicode apis
Assignee: general → smontagu
Component: General → Internationalization
Depends on: 162361
Product: Mozilla Application Suite → Core
QA Contact: general → amyy
Version: unspecified → Trunk
*** Bug 273906 has been marked as a duplicate of this bug. ***
Keywords: pp

Updated

13 years ago
Summary: Cannot upload a file, if the filename consists any symbol in non-default codepage. → Cannot upload a file, if the filename contains any character/symbol in non-default codepage.

Comment 3

13 years ago
*** Bug 278218 has been marked as a duplicate of this bug. ***
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 5

12 years ago
Still reproducible in Firefox 1.5 Beta 1:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Comment 6

12 years ago
This bug is a big problem when uploading soundfiles to
http://commons.wikimedia.org The naming scheme is xx-word.ogg where xx is the
ISO 639 code and word is the pronounced word. We have had bad problems uploading
Farsi  (Persian) and had to use Internet Explorer to do this.
Blocks: 303852

Comment 7

12 years ago
I have the same problem with japanese members who want to upload files having kanji, hiragana or katakana in their name.

Comment 8

11 years ago
Duplicate of bug 66041?

Comment 9

11 years ago

*** This bug has been marked as a duplicate of 66041 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.