Text overlaps right float

RESOLVED DUPLICATE of bug 25888

Status

()

RESOLVED DUPLICATE of bug 25888
14 years ago
3 years ago

People

(Reporter: jw_00000, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL; rv:1.7.5) Gecko/20041202 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL; rv:1.7.5) Gecko/20041202 Firefox/1.0

At http://jw.clawz.com/sublayers.html, you see layers in layers. The borders of
the layers are colored. At the first example, all sublayers are in the toplayer.
In the second and third example, the toplayer doesn't contains any text, only
the other layers. You see a yellow line where the toplayer starts. The text
after the toplayers stands in the toplayer. Take a look at the source!

Reproducible: Always

Steps to Reproduce:
(Look at the example at http://jw.clawz.com/sublayers.html)


Expected Results:  
The text after the toplayer should be placed after the toplayer.
(Reporter)

Comment 1

14 years ago
Created attachment 172157 [details]
Open this file to see the problem

Same file as given URL
(Reporter)

Updated

14 years ago
Summary: Layers (<div>s) in layers aren't coorectly displayed → Layers (<div>s) in layers aren't correctly displayed

Comment 2

14 years ago
Example 2 is rendered correctly. You removed all normal flow content from
the yellow box so its height is zero, that's why "Text after toplayer" floats
up next to the 2nd float:left. This is correct layout.

Example 3 suffers from the same problem, but I think there is a layout bug
there, the text "Text after toplayer" should stay clear of the right float
but it overlaps it.
Assignee: firefox → nobody
Component: General → Layout: Floats
Keywords: testcase
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout.floats
Summary: Layers (<div>s) in layers aren't correctly displayed → Text overlaps right float
Version: unspecified → Trunk

Comment 3

14 years ago
Created attachment 172172 [details]
Testcase

The text should not overlap the right float here?
Attachment #172157 - Attachment is obsolete: true

Updated

14 years ago
Depends on: 41412

Comment 4

14 years ago
Here is another case that involves overlapping. This time floating dive overlaps
with pre block if you make windo too narrow. IMHO if the div reaches the pre
there should appear scrollbar for the whole body. MSIE does it that way.

Comment 5

14 years ago
Created attachment 175116 [details]
pre overlapping with floating div

The real-life example is at http://www.ee.pw.edu.pl/~stelmacl/xystray/. I've
worked around the problem by setting min-width for the whole body at 750px. Yet
this is not a good way.
This was fixed a long time ago, probably by...
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 25888
You need to log in before you can comment on or make changes to this bug.