[FLOAT] text overlapping top edge of pushed-down float

RESOLVED FIXED in mozilla1.9.2a1

Status

()

Core
Layout
P3
major
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: emk, Assigned: dbaron)

Tracking

(Blocks: 2 bugs, {css1, helpwanted, testcase})

Trunk
mozilla1.9.2a1
css1, helpwanted, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CSS1-5.5.25][Hixie-P2] (high profile: css1 test suite) relnote-devel, URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Steps to reproduce:
1. Launch Mozilla.
2. Navigate to the following attachment.

Actual result:
Fourth line of the text overlap with the right floater.

Expected result:
text should not overlap with floats.

Observed on:
2000060220 nightly build on Windows 2000.
(Reporter)

Comment 1

17 years ago
Created attachment 9568 [details]
testcase

Comment 2

17 years ago
Reassiging to Kevin for bug triage.
Assignee: clayton → kmcclusk
Steve, could you look at this? Unless clip is set on views for the floaters they
will display their contents. 
Assignee: kmcclusk → buster
(Assignee)

Comment 4

17 years ago
(This bug will probably reappear once Steve checks in his float percentage width 
fix today (the testcase depends on that bug being fixed.)

This looks bad.  Nominating nsbeta3 because it's a standards-compliance issue, 
and it probably will affect some real web pages (especially as more pages start 
using CSS floats for layout).
Keywords: css1, nsbeta3
Summary: text should not overlap with floats → [FLOAT]text overlapping top edge of pushed-down float
As per meeting with ChrisD today, taking QA.
Keywords: correctness
QA Contact: petersen → py8ieh=bugzilla
Created attachment 12408 [details]
HTML 4 Strict test case
David: The first testcase demonstrates a bug in the quirks mode "don't push
floats down" code that causes overlaps, so you are probably correct; we should
disable that quirk as much as possible.

The new testcase gets around this problem and demonstrates the issue very well.
Note that this bug shows up on a WaSP test page. (However, this is probably one
of our less dramatic float errors...)
Keywords: testcase
Whiteboard: hit during nsbeta2 standards compliance testing

Comment 8

17 years ago
Denied beta3: too many float bugs to fix them all for beta3
Whiteboard: hit during nsbeta2 standards compliance testing → hit during nsbeta2 standards compliance testing [nsbeta3-]
Target Milestone: --- → Future
This will make lots of pages look bad, and it makes it unsafe to use floats
around text, which is the main use of floats. 
Severity: normal → major
Keywords: 4xp, relnote
Summary: [FLOAT]text overlapping top edge of pushed-down float → [FLOAT] text overlapping top edge of pushed-down float
Whiteboard: hit during nsbeta2 standards compliance testing [nsbeta3-] → [nsbeta3-] hit during nsbeta2 standards compliance testing
I know we still do not have enough resources to get this fixed. However:

Removing [nsbeta3-] to put this floater bug (and 3 others) back onto the 
developer radar, as per suggestion by Gerardo.
Keywords: helpwanted
Whiteboard: [nsbeta3-] hit during nsbeta2 standards compliance testing → (beta3 minus per triaging) hit during nsbeta2 standards compliance testing

Comment 11

17 years ago
changed (beta3 minus per triaging) to [nsbeta3-] so searches work correctly
Status: NEW → ASSIGNED
Whiteboard: (beta3 minus per triaging) hit during nsbeta2 standards compliance testing → [beta3-] hit during nsbeta2 standards compliance testing

Updated

17 years ago
Whiteboard: [beta3-] hit during nsbeta2 standards compliance testing → [beta3-] relnote-devel hit during nsbeta2 standards compliance testing
Keywords: nsbeta3 → mozilla0.9, nsbeta1
Whiteboard: [beta3-] relnote-devel hit during nsbeta2 standards compliance testing → [Hixie-P2] (high profile: css1 test suite) relnote-devel
Blocks: 78094
(Assignee)

Comment 12

16 years ago
This may be a duplicate of bug 25888.

Updated

16 years ago
OS: Windows 2000 → All
*** Bug 59811 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

16 years ago
I'm pretty sure this has the same cause as bug 25888 -- see my 2001-09-17 13:56
comment on bug 86947.
Build reassigning Buster's bugs to Marc.
Assignee: buster → attinasi
Status: ASSIGNED → NEW

Updated

16 years ago
Blocks: 104166

Updated

16 years ago
Blocks: 71668

Updated

15 years ago
Keywords: mozilla1.0+

Comment 16

15 years ago
It would be nice to fix this, but for Mozilla 1.0 we are already way overloaded
just with crashers and dataloss bugs. 
Status: NEW → ASSIGNED
Keywords: nsbeta1-
Whiteboard: [Hixie-P2] (high profile: css1 test suite) relnote-devel → [CSS1-5.5.25][Hixie-P2] (high profile: css1 test suite) relnote-devel

Comment 17

15 years ago
Confirmed using FizzillaCFM/2002070913. Setting Platform=All.
Hardware: PC → All
(Assignee)

Comment 18

14 years ago
Marking dependency on bug 25888, but not duplicate, since this is a more
complicated variant of the problem that might not be fixed by any fix to bug
25888 (although it should be fixed by the *right* fix).
Depends on: 25888
bug 260095 is a duplicate of this bug. Can someone please mark it as such?
*** Bug 260095 has been marked as a duplicate of this bug. ***
*** Bug 251139 has been marked as a duplicate of this bug. ***
Blocks: 271371

Updated

13 years ago
Assignee: attinasi → nobody
Status: ASSIGNED → NEW
Keywords: 4xp, mozilla1.0+, nsbeta1-, relnote
QA Contact: ian → core.layout

Updated

13 years ago
Blocks: 279466

Comment 22

12 years ago
Created attachment 180508 [details]
AnotherCase

Another example that demonstrates the same problem but in little different
situation.
*** Bug 305169 has been marked as a duplicate of this bug. ***
Blocks: 345369
*** Bug 347859 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Duplicate of this bug: 381988

Updated

9 years ago
Blocks: 458386

Comment 26

7 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
and
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20100128 Minefield/3.7a1pre
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 27

7 years ago
Yes, this was fixed by the parts of bug 25888 that landed, in particular by http://hg.mozilla.org/mozilla-central/rev/be75e40365ce .
Assignee: nobody → dbaron
Resolution: WORKSFORME → FIXED
Target Milestone: Future → mozilla1.9.2a1
(Assignee)

Updated

7 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.