Bugzilla generates HTML with invisible text

RESOLVED DUPLICATE of bug 272456

Status

()

RESOLVED DUPLICATE of bug 272456
14 years ago
9 years ago

People

(Reporter: stokestack, Assigned: myk)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Bugzilla

Bugzilla's Web interface (I assume that's the crux of the problem) sets the
background color to white but does not set the text color to black.  In fact, it
doesn't usually set the text color at all.  When the text color isn't set, the
user's OS will draw the text in the system-default window-text color; that color
might be white.  White text on a white background makes it hard to read bug reports.

Reproducible: Always

Steps to Reproduce:
1. Right-click on your Windows desktop to pull up the Display Properties.
2. Go the the Appearance tab and, in the "color scheme" listbox, pick "High
contrast black."  It's not the most attractive (it's designed for people with
impaired vision), but it'll demonstrate the problem.
3. Browse a bug database through Bugzilla, or go to this form I'm filling out
right now (URL above).

Actual Results:  
Bugzilla's Web interface to a bug database presented mostly blank pages.  Field
labels were all invisible, making it impossible to use forms.

Expected Results:  
Either not set the colors at all (which allows the users' preferences to dictate
screen appearance), or set the text color to something that's visible against
the white/yellow background.

The same problem was just fixed in Firefox's own UI.  The bug number on that is
222799.

If you want to view a screen shot of the problem, check it out at

http://GetAmbitious.com/probs/bugzillaprob.gif
(Reporter)

Comment 1

14 years ago
Created attachment 172284 [details]
screen shot of the reported problem

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 272456 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.