Animated GIF, backgrnd fill vs leave-as-is

VERIFIED DUPLICATE of bug 22607

Status

P2
normal
VERIFIED DUPLICATE of bug 22607
20 years ago
10 years ago

People

(Reporter: michael.j.lowe, Assigned: pnunn)

Tracking

Trunk
Future
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

20 years ago
Cited gif image is not displayed correctly.  Two rectangular blocks of the image
are not visible in most animated frames.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

20 years ago
Yep. I can see it. The frames that ask for the
'backgrd' fill instead of 'leave as is' fill for the
transparent areas seem to be the trouble.

This is a bug. If you would like to know of a work around
until the fix can be checked in, you could change the 'background' fill
to 'leave as is" and the gif displays well...except for one
frame that needs to clean up a portion of the animating orbit.

Updated

20 years ago
QA Contact: 1698
Summary: Animated gif not correctly displaying → Animated GIF not correctly displaying

Comment 2

20 years ago
Setting all current Open/Normal to M4.

Updated

20 years ago
Target Milestone: M4 → M5

Comment 3

20 years ago
pnunn's not here for the m4 endgame. moving to m5
(Assignee)

Updated

20 years ago
Target Milestone: M5 → M6
(Assignee)

Updated

20 years ago
Summary: Animated GIF not correctly displaying → Animated GIF, backgrnd fill vs leave-as-is
(Assignee)

Comment 4

20 years ago
*** Bug 4349 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Target Milestone: M6 → M8
(Assignee)

Updated

20 years ago
Target Milestone: M8 → M11
(Assignee)

Comment 5

20 years ago
Latering.
(Reporter)

Comment 6

19 years ago
Created attachment 1510 [details]
problematic gif image
(Assignee)

Updated

19 years ago
Target Milestone: M11 → M15

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → LATER

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: LATER → ---

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE

Comment 7

19 years ago
*** This bug has been marked as a duplicate of 12977 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Rubber-stamping as duplicate.

Comment 9

19 years ago
Re-opening; this was marked as duplicate of 12977, but is still occuring even 
though 12977 is fixed.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 10

19 years ago
I think this should be fixed. 
It worked in 4.x. 

I don't see anything that could cause this bug to show up,
but I have a feeling a bug was fixed somewhere else that uncovered
this one.

I'm testing a fix now.
-P
(Assignee)

Comment 11

19 years ago
fix not good.
Moving bug to m16.
(Assignee)

Updated

19 years ago
Target Milestone: M15 → M16
(Assignee)

Updated

19 years ago
Target Milestone: M16 → M17

Comment 12

19 years ago
Moving to m18
Target Milestone: M17 → M18

Comment 13

19 years ago
Created attachment 9457 [details]
Probably this image suffer of the same rendering bug

Comment 14

19 years ago
Well, if you look at the 06/01/00 GIF attachment you can see an error appearing
on the 3rd frame ("JBuilder Trial 3.5") at the right side of the picture of the
monitor. The GIF uses the "Leave as is" option on the first control header, but
in all the following frames the delay headers specify remove by "background".

It's also strange enough that the GIF paint only one time the monitor border (in
the 1st frame). In the following frames (the 2nd and the 3rd for example) should
paint only a rectangular box inside the monitor picture (where no rendering
errors seems to appear).

Comment 15

19 years ago
Let me also say something *maybe* has to do with a bad handling of the PNG image
trasparency. It sports some areas with the same behaviour of PNG not completely
transparent areas.
It courious that this behaviour disabbear if the first GIF frame is complitly
opaque.
(Assignee)

Updated

18 years ago
Target Milestone: M18 → Future
(Assignee)

Comment 16

18 years ago
duplicate of 22607 (which has better info on it.)
-pn

*** This bug has been marked as a duplicate of 22607 ***
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 17

18 years ago
vrfy dupe of well written and commented bug 22607.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.