Spacer GIF at ty.com displays as garbage or thin grey line

VERIFIED DUPLICATE of bug 2805

Status

()

P3
normal
VERIFIED DUPLICATE of bug 2805
20 years ago
20 years ago

People

(Reporter: cpratt, Assigned: pnunn)

Tracking

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
The simplified HTML code at http://schist/ty/index.html was taken from ty.com
(don't try that at home - they have about thirty lines of blank space between
each line of code). Basically, there is a spacer GIF image there (spacer3.gif)
that displays differently depending on where it is on the page. It looks fine
under IE and Nav 4.51. You can download that GIF directly from
http://schist/ty/spacer3.gif if you'd like to have a look at it.
(Assignee)

Updated

20 years ago
Target Milestone: M5
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Target Milestone: M5 → M6
(Assignee)

Comment 1

20 years ago
<IMG SRC="spacer3.gif" WIDTH="30" HEIGHT="10" ALIGN="BOTTOM"NATURALSIZEFLAG="0">
<IMG SRC="spacer3.gif" WIDTH="55" HEIGHT="1" ALIGN="BOTTOM" NATURALSIZEFLAG="3">

I must be missing something here. The images have width and height tags
to specify different sizes. It looks right to me. Could you explain more
about the image is displayed differently than expected?
-pnunn
(Reporter)

Comment 2

20 years ago
Looking at http://schist/ty in the 1999042908 build, it displays as a blackish
rectangle in apprunner, but displays (correctly?) as, well, nothing under
Communicator 4.6. If you view the image itself in 4.6, it's transparent / clear;
if you download and view it using the Apple QuickTime 3 Image Viewer, it's also
clear. That's the problem I'm seeing. Give me a holler if you'd like - my cube's
close to yours, you're welcome to stop by...
(Assignee)

Comment 3

20 years ago
Thanks for the clarification.
I know whats going on now. The gif, spacer3.gif, was specified
as transparent. But there is another setting that specifies
what the transparency is filled with. The general recommendation
is that the transparency be filled with 'background'. This gif specified the
transparency be filled with 'nothing'.

Something has changed between 4.x and the current code in determining
what 'nothing' is. For example, gecko may decide the default bkground, ie
'nothing' is the background specified in the prefs, but 4.x used what
ever the background color was specified for the document body.

I'll track it down.
-pn
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

20 years ago
*** This bug has been marked as a duplicate of 2805 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 5

20 years ago
Rubber-stamping Verified as duplicate.
You need to log in before you can comment on or make changes to this bug.