Closed Bug 280665 Opened 18 years ago Closed 18 years ago

SOCKS proxy server connection timeout hard-coded

Categories

(Core :: Networking, defect)

1.0 Branch
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 280661

People

(Reporter: snabb, Unassigned)

Details

User-Agent:       Opera/7.54 (X11; FreeBSD i386; U)  [en]
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.5) Gecko/20050109

I am using Mozilla in a non-typical network which requires using a SOCKS server 
which is located behind a high-latency network connection. Unfortunately the 
connection timeout of the SOCKS server conenction is currently hard-coded (ugly!
) in the source code to be 10 seconds. This means that my connection to the 
SOCKS server always times out (unless I patch it in source code before 
compiling).

My suggestion is to make this configurable in about:config. It should be very 
easy to fix for anyone who knows Mozilla configuration mechanism (I don't).


Reproducible: Always

Steps to Reproduce:
1. use Mozilla with high-latency SOCKS server (connection latency > 10 s)
2. try connecting to any web site
3.

Actual Results:  
The connection to the SOCKS server times out virtually always.


Expected Results:  
I should be able to configure the timeout to accomodate my network connection 
timeout requirements.

I am currently using the following source code patch, which pinpoints the hard-
coded timeout setting. Unfortunately I always forget to apply the patch when 
upgrading Mozilla, which means that I always have to compile twice :).

--- mozilla/netwerk/socket/base/nsSOCKSIOLayer.cpp.dist Tue Feb  1 15:55:51 2005
+++ mozilla/netwerk/socket/base/nsSOCKSIOLayer.cpp      Tue Feb  1 15:56:13 2005
@@ -534,11 +534,11 @@
     // uses blocking network calls, the app can appear to hang for a maximum
     // of this time if the user presses the STOP button during the SOCKS
     // connection negotiation. Note that this value only applies to the 
     // connecting to the SOCKS server: once the SOCKS connection has been
     // established, the value is not used anywhere else.
-    PRIntervalTime connectWait = PR_SecondsToInterval(10);
+    PRIntervalTime connectWait = PR_SecondsToInterval(60);
 
     // Connect to the proxy server.
     status = fd->lower->methods->connect(fd->lower, &proxyAddr, connectWait);
     
     if (PR_SUCCESS != status) {
oops, accidentally hit reload button in the wrong place and caused a duplicate..
.


*** This bug has been marked as a duplicate of 20661 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 280661 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
V/dupe
Status: RESOLVED → VERIFIED
Component: General → Networking
Product: Mozilla Application Suite → Core
QA Contact: general → benc
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.