Last Comment Bug 281483 - Decomposed, accented unicode characters are not displayed as a single character
: Decomposed, accented unicode characters are not displayed as a single character
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: ---
Assigned To: Simon Montagu :smontagu
: Yuying Long
: Makoto Kato [:m_kato]
Mentors:
http://blogs.msdn.com/michkap/archive...
: 398400 (view as bug list)
Depends on: uniscribe
Blocks: 359774
  Show dependency treegraph
 
Reported: 2005-02-08 02:23 PST by Dean Harding
Modified: 2007-10-04 09:39 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
This is how the text looks in Mozilla (4.25 KB, image/png)
2005-02-08 02:24 PST, Dean Harding
no flags Details
This is how the text looks in Firefox (3.10 KB, image/png)
2005-02-08 02:26 PST, Dean Harding
no flags Details
This is how the text looks in IE (3.48 KB, image/png)
2005-02-08 02:27 PST, Dean Harding
no flags Details
testcase extracted from the URL (2.54 KB, text/html)
2007-06-04 08:25 PDT, Simon Montagu :smontagu
no flags Details

Description Dean Harding 2005-02-08 02:23:07 PST
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; Maxthon; .NET CLR 1.1.4322; .NET CLR 2.0.40607)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050207

If you look at the page at 
http://weblogs.asp.net/michkap/archive/2005/02/07/368570.aspx, it had the 
string "àáâãäå" in different non-normalized forms (i.e. some characters 
composed, some decomposed).

All the strings look the same in IE on Windows, but both Mozilla and Firefox 
display the strings incorrectly (though differently, for some reason).

Reproducible: Always

Steps to Reproduce:
1. Open the url http://weblogs.asp.net/michkap/archive/2005/02/07/368570.aspx
2. Have a look under the text "static void Main()..." for the various non-
normalized form of the string "àáâãäå"
3. On Mozilla and Firefox, the string all look different, even though they're 
supposed to look the same.

Actual Results:  
Different forms of the string "àáâãäå" look different.

Expected Results:  
Different forms of the string "àáâãäå" should look the same.
Comment 1 Dean Harding 2005-02-08 02:24:53 PST
Created attachment 173717 [details]
This is how the text looks in Mozilla

This is how the text looks in Mozilla.	Notice how all the decomposed combining
characters display separate to the base character.
Comment 2 Dean Harding 2005-02-08 02:26:25 PST
Created attachment 173718 [details]
This is how the text looks in Firefox

This is how the text looks in Firefox.	Notice how it seems to do a "better"
job than Mozilla - it composes some characters properly, but others are not
composed, and still others have no or the wrong accent!
Comment 3 Dean Harding 2005-02-08 02:27:05 PST
Created attachment 173719 [details]
This is how the text looks in IE

Notice how all the strings look the same.  This is how it *should* be.
Comment 4 Dean Harding 2005-02-08 02:30:09 PST
To display the strings in my original post, you'll have to change the encoding 
of this page to UTF-8 - I'm not sure why Bugzilla is returning ISO-8859-1... :-
)
Comment 5 Simon Montagu :smontagu 2005-02-08 23:53:23 PST
By the way, which version of Mozilla are you using, and on what Windows version?
I don't see any difference between Mozilla trunk and Firefox 1.0, both on
Windows XP.
Comment 6 Dean Harding 2005-02-09 11:54:36 PST
I used the nightly build of Mozilla, from a couple of days ago.  But just the 
latest release of Firefox (i.e. not a nightly build).  On Windows XP SP2.

I didn't try a nightly build of Firefox, so I don't mind if we assume that's 
the "real" problem...
Comment 7 Simon Montagu :smontagu 2007-06-04 08:25:13 PDT
Created attachment 267149 [details]
testcase extracted from the URL
Comment 8 Jason Weathered 2007-09-25 04:20:39 PDT
This bug does not appear to be Windows specific as I am seeing the same thing with  decomposed (NFD) Unicode strings with the above text attachment on Mac OS 10.4.10 with Firefox 2.0.0.7.
Comment 9 Simon Montagu :smontagu 2007-09-25 06:53:40 PDT
In current trunk I no longer see the bug on either Windows or Mac, and for Linux it is covered by bug 197649, so I am marking this WORKSFORME.
Comment 10 Simon Montagu :smontagu 2007-10-04 09:39:02 PDT
*** Bug 398400 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.