UTF-8 modifier glyph misplaced

RESOLVED DUPLICATE of bug 281483

Status

()

Core
Layout: Text
--
major
RESOLVED DUPLICATE of bug 281483
10 years ago
10 years ago

People

(Reporter: Baptiste Fouques, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

The unicode standard allow to write extended latin charactere multiple way: say for e_acute : é and é

In firefox Windows UTF-8 , the e + acute modifier way render badly, the acute accent is seen over Next charactere (rather than previous one)

Reproducible: Always

Steps to Reproduce:
1. look at a page using UTF-8 modifier latin character

for exemple with the french déjà word 
Actual Results:  
see "de'ja`"

Expected Results:  
déjà

It seems that it is not a font problem (as the glyph are placed, thouch misplaced).

IE render randomly in previous or next charactere
UTF-8 console apps render correctly

Updated

10 years ago
Component: General → Layout: Fonts and Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: unspecified → 1.8 Branch
(Reporter)

Comment 1

10 years ago
Seem to be solved on Firefox 3.0a

(page http://bat.fr.eu.org/blog/2007/10/02/contourner-cest-tricher-sans-toucher-20-000fr/ look right with Minefield)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007100113 Minefield/3.0a9pre

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 281483
You need to log in before you can comment on or make changes to this bug.