Global notifications for completed downloads

RESOLVED FIXED

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Brian Schack, Assigned: sdwilsh)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 StumbleUpon/1.999
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 StumbleUpon/1.999

When a download is completed on the Macintosh, Firefox should post a Growl
notification. Firefox Mac OS X does not have the download completion
notifications that Firefox for Windows does. If you register the notifications,
then the UI for turning it on and off and customizing it is in Growl.

You might be cautious about implementing platform-specific features, but
implementing the notifications in AppleScript (for example) looks simple to an
outsider, and they could go a long way towards making Mac users feel special.

- Growl (http://growl.info/)
(http://www.drunkenblog.com/drunkenblog-archives/000341.html)
- Growl is licensed under a BSD-style license
(http://growl.info/documentation/Growl-Main-License.txt).
- Documentation (http://growl.info/documentation/)
- Implementing Growl in Carbon applications
(http://growl.info/documentation/implementing-growl.php?lang=carbon)
- Self-proclaimed hack that does this
(http://www.mrchucho.net/index.php/archives/2004/12/27/firefox-and-growl/)

Thank you.

Reproducible: Always

Steps to Reproduce:
I don't know if we'd add core code to support a third-party OS-specific
function.  That seems a tad bloaty, not to mention I don't know if we can use
AppleScript yet.
(Reporter)

Comment 2

13 years ago
In case there was some confusion, Growl supports lots of languages besides AppleScript.
We're not going to mess with third party apps; any sort of dock notification is
a better way to go.
(Reporter)

Comment 4

13 years ago
This would not make Firefox bloated:
1) It can be implemented without any Firefox UI.
2) It's not slow.

Comment 5

13 years ago
If we could do this via an extension that would work, but from what I've seen 
the only extension types are via javascript, which limits this functionality 
very much.

(In reply to comment #3)
> We're not going to mess with third party apps; any sort of dock notification 
is
> a better way to go.

Comment 6

13 years ago
I've implemented an extension that interfaces with Growl. It's sub-optimal
because, apparently, NSIProcess.run won't accept being passed arguments on Mac
OS X. Otherwise, we could simply pass "Download Complete" and the filename to
growlnotify.

So, the extension is ready -- we just need that bug fixed!

(In reply to comment #5)
> If we could do this via an extension that would work, but from what I've seen 
> the only extension types are via javascript, which limits this functionality 
> very much.


Comment 7

13 years ago
Sorry to comment twice. I'm new to this tracker,heh.

The reason why a dock notification is not enough is that dock notifications are 
quite annoying, whereas Growl notifications are very controllable by the user. 
Please try Growl with GrowlSafari, as it would be comparable to what the person 
in this ticket is requesting.


(In reply to comment #3)
> We're not going to mess with third party apps; any sort of dock notification 
is
> a better way to go.

Comment 8

12 years ago
It is possible I think to implement Growl in  Firefox by using an xpi extension
that calls Growls through its terminal growlnotify plug-in. 

http://growl.info/documentation/growlnotify.php

Updated

12 years ago
Blocks: 303476
fwiw, Growl's become a more and more prominent OS X add on, and there seem to be more applications for Mac that support it. Worth re-evaluating?

Updated

11 years ago
Depends on: 362685
Also note bug 308552, bug 332637, and bug 362685.

Updated

11 years ago
QA Contact: ali → download.manager
(Assignee)

Comment 11

11 years ago
Created attachment 257044 [details] [diff] [review]
v1.0

This can't be checked in until the bug this depends on is checked in.  Also, the downloadIcon.png file from toolkit/themes/winstripe/downloads to toolkit/themes/pinstripe/mozapps/downloads
Assignee: bugs → comrade693+bmo
Status: NEW → ASSIGNED
Attachment #257044 - Flags: review?(mano)
Comment on attachment 257044 [details] [diff] [review]
v1.0

You'll need mconnor's approval to land this.
Attachment #257044 - Flags: review?(mano) → review+
(Assignee)

Comment 13

10 years ago
> This can't be checked in until the bug this depends on is checked in.

I lied.  After thinking about this I realized it will behave the same as if Growl wasn't installed with the other bug landing.
(Assignee)

Updated

10 years ago
Attachment #257044 - Flags: ui-review?(mconnor)
(Assignee)

Comment 14

10 years ago
Created attachment 261564 [details] [diff] [review]
v1.1

As per discussion with mconnor on irc.
Attachment #257044 - Attachment is obsolete: true
Attachment #261564 - Flags: review?(mano)
Attachment #257044 - Flags: ui-review?(mconnor)
(Assignee)

Updated

10 years ago
OS: Mac OS X → All
Hardware: Macintosh → All
Summary: Growl global notifications for completed downloads → Global notifications for completed downloads
Version: unspecified → Trunk
Comment on attachment 261564 [details] [diff] [review]
v1.1

r=mano.
Attachment #261564 - Flags: review?(mano) → review+
Comment on attachment 261564 [details] [diff] [review]
v1.1

ui-r=mconnor
Attachment #261564 - Flags: ui-review+
(Assignee)

Comment 17

10 years ago
Please note that whoever checks this in will also have to pull the winstripe file into the proper location in pinstripe:
http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/mozapps/downloads/downloadIcon.png
Whiteboard: [checkin needed]
(Assignee)

Comment 18

10 years ago
Checking in browser/app/profile/firefox.js;
/cvsroot/mozilla/browser/app/profile/firefox.js,v  <--  firefox.js
new revision: 1.175; previous revision: 1.174
done
Checking in toolkit/themes/pinstripe/mozapps/jar.mn;
/cvsroot/mozilla/toolkit/themes/pinstripe/mozapps/jar.mn,v  <--  jar.mn
new revision: 1.17; previous revision: 1.16
done
RCS file: /cvsroot/mozilla/toolkit/themes/pinstripe/mozapps/downloads/downloadIcon.png,v
done
Checking in toolkit/themes/pinstripe/mozapps/downloads/downloadIcon.png;
/cvsroot/mozilla/toolkit/themes/pinstripe/mozapps/downloads/downloadIcon.png,v  <--  downloadIcon.png
initial revision: 1.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Whiteboard: [checkin needed]
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.