Last Comment Bug 282195 - Click+holding below scroll elevator, then moving cursor down, doesn't result in additional scrolling
: Click+holding below scroll elevator, then moving cursor down, doesn't result ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Windows XP
: -- minor (vote)
: ---
Assigned To: neil@parkwaycc.co.uk
: John Morrison
Mentors:
: 234300 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-13 22:35 PST by Dean Tessman
Modified: 2005-02-16 17:52 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Minimum patch (2.59 KB, patch)
2005-02-14 09:21 PST, neil@parkwaycc.co.uk
roc: review+
roc: superreview+
asa: approval1.8b+
Details | Diff | Splinter Review

Description Dean Tessman 2005-02-13 22:35:14 PST
Windows-only bug, spun off from bug 153946.  caillon fixed this for OS X and
Linux, but I'm still seeing it on Windows.  Maybe the NS_MOUSE_MOVE event isn't
getting through.
Comment 1 neil@parkwaycc.co.uk 2005-02-14 07:37:41 PST
caillon only fixed it for the case where you move the mouse while scrolling.
(And you keep it scrolling you have to keep the mouse over the slider!)
Once it stops scrolling it won't restart.
Comment 2 neil@parkwaycc.co.uk 2005-02-14 08:22:36 PST
Worse still, mousing over the thumb cancels the repeat too :-(
Comment 3 neil@parkwaycc.co.uk 2005-02-14 09:21:57 PST
Created attachment 174300 [details] [diff] [review]
Minimum patch

This is the minimum amount of work to fix the bug. By capturing the mouse we
can delay clearing the mChange flag until the mouse is released, thereby
allowing us to resume the repeat if the mouse is moved back over the slider.
Notes:
* Rename the functions because we're not just dragging the thumb?
* Make mChange a smaller data type?
* Inline HandleRelease?
Comment 4 Christopher Aillon (sabbatical, not receiving bugmail) 2005-02-14 10:35:49 PST
Neil, I think you're actually fixing bug 234300, not this bug.
Comment 5 Dean Tessman 2005-02-14 10:48:30 PST
Aha!  That's the bug I was looking for.  Dupe that against this one, since we've
got a patch here?
Comment 6 Asa Dotzler [:asa] 2005-02-15 22:19:06 PST
Comment on attachment 174300 [details] [diff] [review]
Minimum patch

a=asa for checkin to 1.8b
Comment 7 neil@parkwaycc.co.uk 2005-02-16 01:30:40 PST
Fix checked in.
Comment 8 R.K.Aa. 2005-02-16 17:52:11 PST
*** Bug 234300 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.