Add a warning that the link clicked on does not match what appears in the message (reduce phishing)

RESOLVED DUPLICATE of bug 279191

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 279191
14 years ago
14 years ago

People

(Reporter: Kevin Ar18, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050118 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050118 Firefox/1.0+

As you are aware, one phishing mehod (among many) that is used in email is to
show one URL in the e-mail, but when you click on the link, it takes you to
another site.

People who are very careful might hover their mouse over the link to see what
the address really is.  This method may often help solve this particular
phishing method.  However, I was thinking, what if we automated this process
somewhat?

For example, when the user clicks on a link, Thunderbird would compare the URL
that the user sees to what URL they are actually being redirected to.  If both
are a valid URL (or close to valid), but take you to different pages/sites, then
the user would receive a warning message notifying that this could be a phishing
scam.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 174389 [details]
Example

Here's an example dialog.
(Assignee)

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 279191 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.