Add pop-under window blocking

RESOLVED DUPLICATE of bug 282931

Status

()

RESOLVED DUPLICATE of bug 282931
14 years ago
14 years ago

People

(Reporter: rene.rheaume, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050117 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050117 Firefox/1.0

Now that many browsers block pop-up windows mainly used for ads, advertizers now
use pop-under windows to suck up bandwidth. As Firefox is touted to make web
surfing not annoying and safe, it should have pop-under blocking as well.

It seems that using the combination of AdBlock and Tabbrowser Preferences works
around the problem.

Note that I have not experienced myself those pop-unders, maybe beacause i Have
both extensions installed. I got in touch while reading my regular sites and
boards. This bug also concerns the Application Suite.

http://forum.micro.info/viewtopic.php?t=49534 [fr_CA]
http://www.theinquirer.net/?article=21364

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Go to http://www.warp2search.net/

Actual Results:  
Get pop-under windows :-(

Expected Results:  
No forsaken pop-under window should appear

Comment 1

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050128 Firefox/1.0
(Ubuntu) (Ubuntu package 1.0+dfsg.1-2ubuntu5)

I disabled adblock and couldn't reproduce.

Do you have flash installed as I notice the site has flash and I am wondering if
it is this that is triggering the advert.

Comment 2

14 years ago
Reporter, pop-unders are basically the same as pop-ups, except that they've made
sure that the window appears below any other window. You can prevent that with
Options -> Web-Features -> Javascript Option, but then it would appear as a
regualr pop-up. See bug 277816.

What people are reporting is that advertisers are finding new ways to display
pup-ups (or pop-unders), and this has been filed many times before. We don't
need a separate methode for pop-unders.

Comment 3

14 years ago
The only difference between a popup and a popunder is whether the opening script
calls window.blur() on the new window after it's open (or window.focus() on the
original window). The distinction is not relevant to the popup blocker.
warp2search.net is just another client of the fastclick script. See especially
bug 282931 comment 6.

*** This bug has been marked as a duplicate of 282931 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.