Invalid combining character sequences display incorrectly

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
14 years ago
11 years ago

People

(Reporter: samphan, Assigned: prabhat.hegde)

Tracking

(Blocks 1 bug, {intl})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20050206 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20050206 Firefox/1.0

Backgrounds :-
8<-- Unicode 4.0 - 5.13 Rendering Nonspacing Marks -->8
Several methods are available to deal with an unknown composed character
sequence that is outside of a fixed, renderable set. One method (Show Hidden)
indicates the inability to draw the sequence by drawing the base character first
and then rendering the nonspacing mark as an individual unit—with the nonspacing
mark positioned on a dotted circle.

8<-- Developing OpenType Fonts for Thai Script - Invalid Combining Marks -->8
Combining marks and signs that appear in text not in conjunction with a valid
consonant base are considered invalid. Uniscribe displays these marks using the
fallback rendering mechanism defined in the Unicode Standard (section 5.13,
'Rendering Non-Spacing Marks' of the Unicode Standard 3.1), i.e. positioned on a
dotted circle. 
8<----------------------------------------->8

Reproducible: Always

Steps to Reproduce:
Invalid combining character sequences are combining character sequences that
couldn't be displayed correctly, e.g. in Thai กีี = gor-gai + sara-ii + sara-ii
(there're actually two sara-ii after gor-gai, you may see them as a black box).
Using traditional true-type Thai font, we can't display the second sara-ii
stacking on top on the first sara-ii (there's no *high* sara-ii glyph). Thus,
the second sara-ii is invalid and must be displayed on a dotted circle. That is,
the right way to display the sequence is kor-kai + sara-ii + dotted-circle +
sara-ii (kind of กีoี). Otherwise, the users will not notice that there are two
sara-ii after the gor-gai.


Expected Results:  
Displaying each combining character in an invalid combining character sequence
individually on a dotted circle help users identify the error and see each
component of the error clearly.

Please look at the attached html file to see another example. See also related
bug 143321 non-base level char can't be displayed alone(without base char).
Reporter

Comment 1

14 years ago
I also show how to display it correctly (on dotted-circles) but you may need to
have the right font to see the dotted-circles ◌.
Reporter

Updated

14 years ago
Summary: Invalid combining characer sequences display incorrectly → Invalid combining character sequences display incorrectly
Reporter

Updated

14 years ago
Blocks: thai
Reporter

Updated

14 years ago
Keywords: intl
For Linux, this should already be fixed with Pango rendering. The text under "Wrong" is already rendered correctly.
Still have this problem with 2008021104 on Mac OS X 10.5.2
It looks like the behavior in this bug does really depends on the native renderer
(e.g. Pango on Linux, ATSUI on Mac) ... does it ?

Will this makes it difficult to get fixed ? (technical-wise, policy-wise)
... say, or should it actually be rendered the way it is, to make it consistent with other native apps ? (= not a bug)

(I personally preferred the invalid sequences to be explicitly shown,
 but still like to asking for more info/opinions)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Firefox 3 Beta 3 on Windows renders text in "Wrong" section incorrectly (not show the invalid sequences).

Comment 6

11 years ago
The problem still remains on Trunk nightly build

Tested on Mac OS X 10.5.2 with Minefield build 2008030111
BugAThon <s>Bangkok</s> Thailand

as stated in comment #4

this is font-dependent and os-dependent,
Firefox works consistent with native apps,
we decided that this is not a bug, won't fix.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX

Updated

11 years ago
Component: Layout: CTL → Layout: Text
QA Contact: arthit → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.