"Sent items" local folder gets deadlocked with no apparent reason

RESOLVED DUPLICATE of bug 275707

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 275707
13 years ago
13 years ago

People

(Reporter: Emmanuel Blot, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

After an email has been sent (using SMTP) from a IMAP-based account (at least, I
do not have POP accounts to double check), a copy of the sent email is copied
into the *local* "Sent Items" folder.

On a regular basis, the "Sent Items" folder keeps locked (for exclusive access
?), and the email is never copied into this folder. The "Copying email to Sent
Items folder" progress dialog keeps being displayed forever, until it is
cancelled by the user - the email copy never reaches the 'sent items' folder in
this case.

Once this bug has shown itself once, every other sent emails suffer from the
same issue; which seems to prove that the "Sent Items" local folder never gets
released (deadlock).


Reproducible: Sometimes

Steps to Reproduce:

Actual Results:  
Sent items do not get copied into the local 'sent items' folder

Expected Results:  
The expected behaviour is to get the sent email copied into the local 'sent
items' folder.


The only workaround is to close Thunderbird application, and to restart it.

I'm unable to find a 100% reproducible sequence to make this bug shows up. It
occurs about once a day on my machines. (NTFS partition, with over 1GB free
space, error free [checked with XP tool])

This bug exists since I use Thunderbird (0.6 or so). I already tried to delete
the whole 'Sent items' folder (from the OS: file deletion). It did not resolve
the issue.

Comment 1

13 years ago
Is this a duplicate of 275707?
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 275707 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.