MLK: nsDirectoryService::Set()

VERIFIED DUPLICATE of bug 25584

Status

()

P3
major
VERIFIED DUPLICATE of bug 25584
19 years ago
19 years ago

People

(Reporter: bruce, Assigned: dougt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When running './mozilla -help' under Purify, I see 2 nsLocalFile's leak.

nsDirectoryService::Get() -> nsDirectoryService::Set() -> nsLocalFile::Clone()

Where should the 'result' of ourFile->Clone(&cloneFile); in 
nsDirectoryService::Set() get freed?
(Reporter)

Comment 1

19 years ago
Actually, where does cloneFile even get used?
(Assignee)

Comment 2

19 years ago
nice find, but dup

*** This bug has been marked as a duplicate of 25584 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
Marking Verified as a dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.