Java doesn't work on Linux

VERIFIED DUPLICATE of bug 49451

Status

Core Graveyard
Java: OJI
P3
normal
VERIFIED DUPLICATE of bug 49451
18 years ago
7 years ago

People

(Reporter: roberts, Assigned: drapeau)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-] [no linux/unix JRE include support for OJI], URL)

(Reporter)

Description

18 years ago
From Bug Helper:
User-Agent: Mozilla/4.7 [en] (X11; I; Linux 2.2.14-15mdk i686)
BuildID:    2000021715
The applet on this page does not start
Reproducible: Always
Steps to Reproduce:
1.Just go to the page. A java applet should start
2.
3.
Actual Results:  Nothing happens
Mozilla does not currently support Java in nightly builds. Or so I think, and am 
assured by #mozilla :-)

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
My mistake. OJI is now on in all builds, so Java should work if you have an 
OJI-compliant JVM. So, the question for roberts@tsasa.lanl.gov is:

Do you have an OJI-compliant JVM installed? Do other Java applets work?

Gerv
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

18 years ago
Misfiled, belongs in OJI.
Assignee: akhil.arora → drapeau
Component: Java-Implemented Plugins → OJI
QA Contact: rajendra.pallath → paw
(Assignee)

Comment 4

18 years ago
Gerv, your original comment is correct, but I'll explain a little bit more
explicitly here.  The OJI module is fine, but current Java Plug-Ins don't work 
because they were built to previous Mozilla API's.  Mozilla API's have been 
changing over the past months, and another recent change broke compatibility 
with the JDK 1.3 Java Plug-In (that plug-in was working with Mozilla's M12 
milestone build).  We are working with the Sun JDK folks to patch the Java 
Plug-In one more time to get it to work with current Mozilla builds, so that we 
can have a working Java VM for Mozilla Beta 1.  We're hoping that Mozilla API's 
upon which Java Plug-In relies will freeze after Beta 1, but we're not sure yet 
whether that will happen.

So, technically speaking, OJI works, but there is currently no working Java 
Plug-In due to recent API changes in other Mozilla modules.

I'll update this bug when we have a working JVM.  Meanwhile, the Linux 
1.2.2-based Java Plug-In will not work, either, since it was obviously based on 
an even earlier Mozilla API.

We are awaiting an OJI-compliant Java Plug-In for Linux from somebody; Sun is 
the likely candidate to port the Plug-In to current Mozilla API's.  This will 
not likely be ready for M14, so I'm pushing this bug off to M16, in the hope 
that Sun (or somebody else...hey, all you great Linux developers there, listen 
up!) will produce a Java Plug-In for any Linux JVM.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: M16
drapeau@eng.sun.com - thanks for that clarification :-)

Gerv
BTW, Do you know when the new JVM is due?

Gerv
(Assignee)

Comment 7

18 years ago
Nope, I don't have definite info.  The last I heard, and this was a little while 
ago, was that we could expect the Java Plug-In working in the second quarter of 
this calendar year.
As you know, the JDK 1.2.2 for Linux is out now.  But the Java Plug-In needs to 
be ported to work with current Mozilla builds and JDK 1.2.2; that's why it's not 
out now, when the 1.2.2 JDK.
drapeau@eng.sun.com - does this bug need to remain open, given that all it 
really says is "Java doesn't work"?

Gerv
(Assignee)

Comment 9

18 years ago
Okay, I just went to the site and the applet worked just fine for me.  I'm
going to mark this bug FIXED, will leave QA to verify, and will put the onus
on the original bug reporter to re-open the bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 10

18 years ago
George, java has never worked on Linux, so I am going to reopen this. Then we 
can deal with this once we have a working jvm.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

18 years ago
Whoa, my mistake.  Silly me.  I wish the Summary said "Java doesn't work on 
Linux."  My fault.
Status: REOPENED → ASSIGNED
Target Milestone: M16 → M20
Your wish is my command :-)

Gerv
Summary: Java app doesn't start → Java doesn't work on Linux

Comment 13

18 years ago
There are now two working JVMs for Linux: one from sun (java.sun.com/jdc)
and one from alphaworks (don't remember the link). 
I had no luck with IBM's implementation, and now i'm downloading
sun's JDK to test it with mozilla. Is there anyone working on this on mozilla
side?
(Assignee)

Comment 14

18 years ago
Yep, my group is trying to help the Sun JDK group get the Linux port of the
Java Plug-In working.  The problem is that the JDK for Unix platforms doesn't
have built-in support for an OJI-compliant Java Plug-In, and Sun has been
resource-constrained to date.  We're hoping to get some sort of Solaris and
Linux Java Plug-In working and integrated into the Netscape 6 Preview Release
2 and near-future Mozilla builds, but it's not there yet.

I'll update this bug when there's more progress.  In the mean time, I know that
Sun's JDK 1.3 for Linux does *not* yet support OJI, but it will.  I have not
heard anything from IBM on this, but would love to hear some status from them.

Adding Mike Kaply on this in case he can add any useful comments.  Mike, if you 
don't want to be cc'd on this, go ahead and remove yourself and accept my 
apologies.  If you know of somebody who can speak to OJI support in IBM's JDK 
1.3 for Linux, I'd love to speak with him/her.

Comment 15

18 years ago
I have downloaded j2re-1_3_0-beta-linux.tar.gz from JDC, but alas,
no liboji.so
Any ideas on what to try, or may be that's what drapeau meant by 
his previous comment, that it is still not there?
(Assignee)

Comment 16

18 years ago
Yep, that's what I meant by my earlier comment.  :-)

No OJI support in this release just yet.  It's coming.

Comment 17

18 years ago
qa: shrir
QA Contact: paw → shrir
pardon da spam, adding self to cc list. :-)
(Reporter)

Comment 19

18 years ago
Ok, guys: When? The rest of the browser is starting to work well enough that one
could almost begin to imagine tossing NS4.73 into the scrap pile, if only there
was a working Java for Mozilla.

Rpt: When?

--Doug
(Assignee)

Comment 20

18 years ago
Updating this milestone optimistically: the guy at Sun is still working on
changes to the Java Plugin code for Solaris.  It's decrepit and hasn't had
anybody on it until recently.  He's trying to make it work for both Solaris and
Linux.  I should have a better ETA by the end of this week.
Target Milestone: M20 → M17

Comment 21

18 years ago
When I enable Java on NS 4.7, and access certain sites, NS just 
disappears. If I disable Java and access the same site there is no problem.
I use Slackware Linux.

John Culleton
john@carr.org

Comment 22

18 years ago
John Culleton: This is bug reporting for the mozilla project.
Keywords: nsbeta2
Whiteboard: [no linux/unix JRE include support for OJI]

Comment 23

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2. If you have a fix, please 
renominate.
Whiteboard: [no linux/unix JRE include support for OJI] → [nsbeta2-] [no linux/unix JRE include support for OJI]

Comment 24

18 years ago
sorry, add to cc list

Comment 25

18 years ago
Adding to cc list.
(Reporter)

Comment 26

18 years ago
Not critical to beta2? It's the only damn major feature now needed to allow most
of us Linux people to switch from Netscape. Linux Netscape crashes with Java.
Period. It's unusable for Java apps, always has been.

I guess I don't understand the priorities here.

--Doug
(Assignee)

Comment 27

18 years ago
Doug Roberts: I'm the engineering manager for Java integration into Mozilla and 
Netscape 6.  The reason that this bug is minus'd as "not critical for Beta 2" is 
 because the lack of Java support in the Linux port isn't a strong enough reason 
to hold back the Beta 2 release.  Also, Netscape isn't doing its own development 
 of Java Plug-In for Linux --- Sun is working on one --- so Netscape is in a 
position of either receiving a working Java Plug-In or not.  I agree with 
Netscape: it's not feasible to hold up the release date of Beta 2 on all 
platforms just for Java on one platform with no firm ETA.
If you want to complain about the lack of Java support on Linux, complain to 
Larry Abrahams, the Director of JDK Engineering at Sun.
(Reporter)

Comment 28

18 years ago
Thanks for the clarification, and the suggestion. A politely-phrased request to
up the Linux Java support sent to Larry Abrahams at Sun might not be a bad idea,
so I'll do it.

--Doug

Comment 29

18 years ago
Any news on the IBM JDK front ? Maybe they will be more responsive than Sun since:

a) Linux is in some ways a competitor to Solaris, so Sun _may_ be stalling
deliberately. (I say may, I am not accusing them of anything).

b) IBM are starting to support Java and Linux in a big way (having recently
released Visual Age for Linux).

(Assignee)

Comment 30

18 years ago
No news on the IBM JDK front.  IBM hasn't contacted me about their OJI support.
 I wish they would.  :-(

Meanwhile, I'd like to address your point about them possibly being more
responsive than Sun.  I apologize on behalf of Sun for Sun not being more
responsive about Java support on Linux.  However, Sun is not deliberately
stalling.  The reason there is no Linux support for an OJI-compliant Java
Plug-In is because the group at Sun (in the Java Software division) responsible
has been grossly under-staffed since before December.  My group at Sun (in
another division but working with Java Software) has taken on porting the Java
Plug-In to Solaris, but my group has suffered attrition as well, leaving the
Unix port of Java Plug-In (JPI) unstaffed.  Only recently has Java Software
gotten staffing for JPI work on Unix (Solaris and Linux both), but the new staff
doesn't start until Monday, and it will be at least two weeks more until that
person starts actual work on the code.  The staffing situation for JPI has been
horrible, but it has been addressed by the director of JDK Engineering.

Meanwhile, I have had one of my engineers work on the JPI code to get it working
on Linux.  Our hope was to get *something* working for Netscape 6 Preview
Release 2, which is coming very soon now.  We did not make the deadline, but I
have a working prototype of Java on Linux in Mozilla today on my Linux box.  We
will try to turn those bits into an XPInstall file that can be downloaded when
you try to visit a page that has an applet in it.  At least that way, you can
get Preview Release 2 and later get the Linux Java bits when they're ready for
playing with.

I just wanted to point out that the lack of Java support on Linux from Sun is
because of the specific staffing problems in the Java Plug-In area.  The JDK for
Linux is available for early access; it's the glue code (OJI Plug-In) that's not
in good shape.  That will change in a serious way in the next four weeks.

Comment 31

18 years ago
With the new "4.x plugin support on linux" do the Java Plugins for 4x work
correctly?

-Brian

Comment 32

18 years ago
My name is Doug Rothert, and I am the team lead for the Java Plugin work
being done within IBM. In a similar way as our counterparts in Sun, the
staffing and turnover during the last year and a half has been 
problematic. At one point the team essentially shrank to myself, and 
only part time at that.

Given the resources constraints in the past, we focused on supporting the
Java Plugin on I.E. and Netscape 4.x, and making sure that those plugins
were a standard component of the IBM JDK 1.22 and 1.3. In December we
finished JDK 1.22 for AIX and Win32 with Netscape 4.x plugin support. 
In June we finished JDK 1.3 for Intel Linux, AIX, and Win32 with Netscape 4.x
plugin support. The upcoming JDK 1.3 for OS/2 will also have Netscape 
4.x plugin support, and will be released relatively soon. Its important
to understand that each of these products involved considerable time 
and effort and was considered a prereq to begining serious work on
the Mozilla Java Plugin. 

You can download all of the JVMs and report problems with the Netscape 4.x
plugins at http://www.ibm.com/java/jdk/

At this point in time, we have some additional resource to work on the
Mozilla plugin. For the last few weeks a single developer has been focused
exclusively on the Linux Mozilla Java Plugin, and attempting to make it
functional. He will continue to work on this until this task is completed, 
and I am assisting him when possible. We are also attempting to bring a
developer up to speed on the Win32 Mozilla Plugin, as the source base
is almost completely different. AIX and OS/2 are also being looked at,
although they will likely be based on the Linux port. As you can see from
this rough plan, the Linux plugin is the gating factor in getting the other
ports started and has the highest priority of the Mozilla ports. 

I have e-mailed drapeau@eng.sun.com on Monday (8/7/00) with more details
on our staffing, our priorities, and our technical questions in attempting
to get this code to work. I eagerly await his response so that we can make
the Mozilla Plugin on Linux a success. 

-Doug Rothert
(Reporter)

Comment 33

18 years ago
Nothing like a little friendly competition, er, collaboration between Sun & IBM
to speed the process up.

;-}

--Doug (Roberts)

Comment 34

18 years ago
We already have Linux OJI plug-in for IBM and another for Kaffe; IBM works ok 
with few bugs, Kaffe barely works... needs help.  The right engineers to talk 
to about these are james.ketrenos@intel.com and rusty.lynch@intel.com

Comment 35

18 years ago
dup of bug 49451

*** This bug has been marked as a duplicate of 49451 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 36

18 years ago
verifying duplicate.

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.