Closed Bug 49451 Opened 20 years ago Closed 20 years ago

land java support for linux

Categories

(Core Graveyard :: Java: OJI, defect, P2)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 53907

People

(Reporter: chofmann, Assigned: drapeau)

References

Details

(Whiteboard: [dogfood+] [nsbeta3++][PDTP2])

george has something in the works for nsbeta3.  lets use this bug
to track the work that needs to happen for landing it in daily builds,
and to make sure general testing happens after landing.

> > "Randall J. Parr" wrote:
> > [....]
> > > BUT THERE IS ONE BIG ROACH IN MY DOGFOOD
> > >
> > > NO JAVA
> > >
> > > I can't use M17/NS6PR2 on a regular basis without Java support; there
> > > are just too many sites that use Java.

George Dreapau wrote:

>"Chris Hofmann" <chofmann@netscape.com> wrote:
>Date: Thu, 17 Aug 2000 15:35:19 -0700
>
>It may be there on linux in netscape beta3 / m19, right?...

That's what we're working for.  We blew it for PR 2 (it was my goal to get Java
on
Linux for PR 2, but I missed the train).  We'll have something there.

>
>George, can we talk about this in the news groups?...

Yep, you betcha.  Go for it.  The deal is: a small number of people
are checking out the first prototype that's not yet ready for wider
public consumption, There will be a Linux binary for PR 3.  We'll 
see about making it available earlier than
that, so that Mozilla folks can get their hands on it.  
Ideally, this will be as an XPI.
Keywords: dogfood, nsbeta3
This is related to bug 28461 "Java doesn't work on Linux" (with lots of votes)
(and bug 15071 "Java applet not loading on Linux/Mac OS").
George - when you have a linux jvm ready in xpi form send it my way and Samir
and I can get it into the mozilla installer, or even if it's not xpi form we can
probably make it into one.

cc'ing sgehani
granrose et al: okay, will do.  Am sending lots of internal email at Sun about
this.  I'm gone next week on vacation; your contact person on this can be Ed
Burns (edburns@eng.sun.com).  Don't know what target milestone to assign this,
but I'm guessing "M19" is the closest to PR 3.
Status: NEW → ASSIGNED
Target Milestone: --- → M19
Putting on [dogfood+] radar since it is blocking daily testing.  We need this in 
ASAP to get going in QA on this.
Whiteboard: [dogfood+]
i just know you meant to say ``netscape'' installer, right jon? =D
sorry, add to CC
*** Bug 28461 has been marked as a duplicate of this bug. ***
Working on this.  Still awaiting deliverable from Java Software so we can
package and give to Netscape for QA (as well as Sun-internal QA).  Expect to
make it for NSBeta3.
Whiteboard: [dogfood+] → [dogfood+] [nsbeta3+]
*** Bug 50947 has been marked as a duplicate of this bug. ***
This is an OJI bug.
Component: Java-Implemented Plugins → OJI
leaf and I have the 9/5 linux jdk in house and it looks good (yahoo freecell
works great in it at least...).  we're still investigating what we can strip out
of the jre to make it smaller (currently about 15 Mb if I recall correctly)
before packaging, and have to decide the best way to deliver it (probably as an
.xpi for the installer build rather than doubling the size of the tarball and
forcing everyone to download it).
raise to P2 - major functionality.
Priority: P3 → P2
Jon,
It sounds like the Linux JRE will be hosted on lithium but the jre.xpi will be 
included in both mozilla and commercial installers.  Correct?

I'll need the location of the JRE file(s) on lithium.  Then I'll need the green 
signal from leaf and yourself to add this to the Linux delivery scripts.  
Finally, I'll need an nsbeta3+ bug to check the delivery changes in against 
-- maybe this one.
actually, i'm trying to get the shelf set up so we can have these kinds of third
party components checked into the ns/ tree, so rather than sticking it on
lithium, i'd like it on the shelf.

We won't be able to send out the jre.xpi (or whatever we call it) with mozilla
bits (because we won't be getting the source, and it doesn't really aid us with
development, like talkback does), but certainly with the netscape commercial
bits, once we get the details worked out.
Is there somewhere where interested parties can download it now for use with
mozilla, if they want to try it out?  Or will this be commercial-only?
my understanding is that this can't be made ``public'' until it has passed the
suite of certification tests and an ``official'' release is made.

Once it's ``officially'' released, i'll try and get permission to redistribute
as an xpi *somewhere* (though most probably not on mozilla.org).
Not to be inflamatory, but is this at _all_ what windows went through to get
java support?  Or is linux special?  Just curious.
Something similar, though earlier, because of OJI compliance achieved earlier on
windows in the JVM.

You'll notice that mozilla.org is not hosting any windows jvm, either.
Leaf, the canonical place for these should be 

http://home.netscape.com/plugins/jvm.html

Talk to Netcenter's Rafael Ebron about this.  I'm working on upgrading the page 
to use the javascript way of downloading XPI.
that *reeks* of awesomeness! Thanks, ed; i can get some sleep at night now =)
The j2sdk/jre 1.3 release candidate 1 for Linux is now available for download
from Sun. Does this include the requisite JRE fixes? If yes, what
Mozilla/Netscape6 version is required? If yes, could knowledgeable person post
the what and how to the appropriate newsgroup? Finally, does/will the IBM 1.3
for Linux incorporate these fixes or must the Sun jre be used? Thanks, Anxious
in Madison
Okay, I'll give this a shot, Randall J. Parr.  If I get a chance to post this to 
a newsgroup today, I will.  But in case I don't get to it (chance of me not 
getting to it this week: about 90%; sorry), please feel free to quote me here in 
 your own posting to the n.p.m.{oji,java} newsgroup(s).

The J2SE v. 1.3 Release Candidate 1 (RC1)will *not* work with current Mozilla 
builds.  The Linux and Solaris OJI-compliant Java Plug-In work was done after
RC1.  No ETA yet about when the OJI-compliant JRE/JDK will be posted to 
java.sun.com, but in any case, the bits have already been made available to 
Netscape.  They will be made available in two forms: 1) as part of the install 
package (i.e., when you download N6 PR 3, you'll have the option of downloading 
Java 2 support); 2) on the auto-download-the-JVM page, which lets you install 
the browser with no Java support, and when you go to a page that requires Java 
support, the browser will automatically retrieve the Java XPI package from 
Netcenter.

It's too late for JDK 1.3 to support Netscape6/Mozilla, so Sun is kindly doing 
a rapid-turnaround 1.3.1 release explicitly for Netscape6/Mozilla.  This is 
causing some turmoil inside Sun, since the full JCK test cycle must be run for 
each JDK release, which takes time and a good deal of QA resources.  Anyway, 
Netscape will be getting early access to these good Java bits.

My best understanding about the IBM JRE 1.3 is that it, too, does *not* support 
Mozilla yet, but will soon (IBM engineers are currently working hard on it).  As 
a Java licensee, IBM will have access to the source that Sun will use for its 
OJI-compliant Java Plug-in support; same with HP.

Please let me know if this is unclear, or if there's anything else I can do to 
help explain something.
Incidentally: I've now seen the copy inside netscape, and it works in optimized
builds (way cool!  not fast, but it's awesome to see any java in mozilla!) but
it doesn't work in debug builds -- it tells me I need the plugin downloader (and
doesn't tell me where to get it).  Is this a known problem, and is it covered by
this bug?
The issue is that XPCOM interfaces changes between Debug/Release build. Thus, 
since the Linux plug-in built in Release mode, the XPCOM interfaces in debug 
version of Netscape 6 will have a different vtable layout, and accessing the 
release mode plug-in will crash. Since Netscape 6 will catch exception like this 
and move on, so it just catch the error and assumes the OJI plug-in is not 
there. This is a problem of the nature of Release/Debug mode of all the XPCOM 
interfaces in general, and we won't be able to fix it, unless Netscape removes 
all the debugging related methods from the interfaces, so the Release/Debug mode 
of all interfaces will look the same.
As for the plugin downloader plugin, there is a bug about not having one on
linux, http://bugzilla.mozilla.org/show_bug.cgi?id=48483 .
PDT agrees P2
Whiteboard: [dogfood+] [nsbeta3+] → [dogfood+] [nsbeta3+][PDTP2]
By the way, will you guys be fixing the outstanding problem that Netscape 4.x
has, <a
href='http://www.mozilla.org/unix/using-x-with-mozilla-threads.html'>discussed
here</a>,
where Java network communication/class loading/drawing can cause Netscape to
lock?
Adding dependancy to bug 53907 to desperately get attention for the dependant
bug before we miss the train on this (again).

Another case of "We HAVE the bits, but we can't seem to get them in the right
place by the right time."
Depends on: 53907
Is this really a dup of bug 53907? Sounds kinda the same to me, so marking 
nsbeta3++ on this one too. If someone with a clue wants to dup it, that's fine.
Whiteboard: [dogfood+] [nsbeta3+][PDTP2] → [dogfood+] [nsbeta3++][PDTP2]
Oops, my bad.  Yes, this is a dup of bug 53907.  I am closing this bug as a dup; 
it was opened initially to track submission of Java bits for Linux.  The 53907 
bug has better instructions; this bug has mostly talkin' on it.  :-)


*** This bug has been marked as a duplicate of 53907 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.