Auto-Update to version 1.0.1 steals focus from other applications

RESOLVED DUPLICATE of bug 257789

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 257789
13 years ago
9 years ago

People

(Reporter: James Schend, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When auto-updating from Firefox 1.0.0 to 1.0.1, the patch can be downloaded into
the background.  However, when the patch starts installing it thrusts itself not
only in front of all Firefox windows, but all open windows stealing focus from
other applications.  In addition, since this happened while I was typing
quickly, I *may* have hit a button in a dialog without knowing which one.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox 1.0.0, wait for auto-update to notify you
2. Begin download of update.
3. Place download window in the background behind Firefox windows and other
application windows
Actual Results:  
Auto-updater stole focus from the front-most application.

Expected Results:  
If the auto-updater is placed in the background, it should stay in the
background until the user manually focuses on it.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 257789 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.