support delegated use of imap shared folders

RESOLVED FIXED in Thunderbird2.0

Status

--
enhancement
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

({fixed1.8})

Trunk
Thunderbird2.0
fixed1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Assignee)

Description

14 years ago
This is an enterprise feature, in which a user may delegate access to their
folders to someone else, typically an admin. The user gives the admin shared
access to their private folders. When the admin works with messages in the
shared folders, we want the From: address to be the users, not the admins. This
is controlled by a hidden pref, mail.imap.delegateOtherUsersFolders, defaulted
to false.

As part of this, we want to show the Sender: header when it's not the same as
the From: header, so that a recipient gets a hint that the e-mail was handled by
a delegate. This also helps with spoofing, with servers that fill in the sender:
header. That's controlled by the pref mailnews.headers.showSender, defaulted to
false (but we might want to change that default)

The custom identity method on folders could be used for things like
per-newsgroup identities.
(Assignee)

Comment 1

14 years ago
Created attachment 176920 [details] [diff] [review]
proposed fix
Attachment #176920 - Flags: superreview?(mscott)
(Assignee)

Comment 2

14 years ago
review ping - I think the sender header stuff we might want to turn on by
default...along with changing the places we display "Sender" to "From"

Comment 3

14 years ago
Comment on attachment 176920 [details] [diff] [review]
proposed fix

1) if we show a sender header by default, then the changes to
msgHdrViewOverlay/xul.js will probably look a little different. Let's ditch the
pref and try it that way for a little bit on the trunk until I can get a better
feel for how often this comes up. 

2) If we are in the collapsed header view, I don't think we should be squeezing
this header in there. I'd ditch the collapsedsenderbox. The collapsed view is
intended for the bare miniumum of information (subject, date and from)

3) Why wouldn't we always want to set delegateOtherUsersFolders to true? Can we
lose the pref here and always conjure up the Sent By identity when working on a
delegated folder?

4) bump the IID in nsIMsgFolder

5) This customized identity is going to show up in our multiple identities list
from the account manager. Is that ok? And it looks like we create it and add it
to the account every time we call GetCustomIdentity? Is this going to lead to
lots of duplicate entries?
(Assignee)

Comment 4

14 years ago
Re 1, yeah, I think we probably should get rid of the pref.
Re 2, I'll do that.
Re 3, the behaviour turned on by this pref will be very surprising for normal
users of shared folders as opposed to users who are sharing folders specifically
to delegate, so I don't think we want this to be defaulted to on.

We only create the custom identity if we can't find it...but yeah, it will show
up  in the identity list (which is OK for users who want to turn this on for
delegation)

(Assignee)

Comment 5

14 years ago
Created attachment 181385 [details] [diff] [review]
just the sender: header part of fix
Attachment #176920 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #181385 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #181385 - Flags: superreview?(mscott) → superreview+

Updated

14 years ago
Target Milestone: --- → Thunderbird1.1

Comment 6

14 years ago
*** Bug 221054 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
(In reply to comment #5)
>Created an attachment (id=181385)
>just the sender: header part of fix
As a reminder that I mentioned on AIM that the line that got inadvertently
deleted was originally "var index = 0;" and belongs outside of the while loop.

Updated

14 years ago
Attachment #176920 - Flags: superreview?(mscott)

Updated

14 years ago
Flags: blocking-aviary1.1?
Severity: normal → enhancement
OS: Windows 2000 → All
Hardware: PC → All

Comment 8

14 years ago
clearing nomination since the bug is already in the approved 1.1 milestone bucket.
Flags: blocking-aviary1.1?
(Assignee)

Comment 9

14 years ago
Comment on attachment 181385 [details] [diff] [review]
just the sender: header part of fix

this patch displays the sender header if it's different than the from header.
We'd like to get feedback on this.
Attachment #181385 - Flags: approval-aviary1.1a?

Comment 10

14 years ago
Comment on attachment 181385 [details] [diff] [review]
just the sender: header part of fix

a=chofmann
Attachment #181385 - Flags: approval-aviary1.1a? → approval-aviary1.1a+
(Assignee)

Comment 11

14 years ago
the sender part of the patch has been checked in...
(Assignee)

Comment 12

14 years ago
moving the rest of this fix out past 1.1
Target Milestone: Thunderbird1.1 → Thunderbird1.5
(Assignee)

Updated

13 years ago
Target Milestone: Thunderbird1.5 → Thunderbird2.0

Updated

13 years ago
Blocks: 308988

Comment 13

13 years ago
Created attachment 198174 [details] [diff] [review]
headerValue instead of value patch v1.1

This patch:
* Changes header.value to header.headerValue which does actually get created
* Compares mailbox to mailbox rather than mailbox to headerValue
Attachment #198174 - Flags: review?(bienvenu)

Updated

13 years ago
Attachment #198174 - Flags: review?(bienvenu)

Comment 14

13 years ago
Created attachment 198175 [details] [diff] [review]
else if headerValue patch v1.1a (Checked in branch and trunk)

Changes since v1.1:
* Changed sender if statement to an else if
Attachment #198174 - Attachment is obsolete: true
Attachment #198175 - Flags: review?(bienvenu)
(Assignee)

Updated

13 years ago
Attachment #198175 - Flags: review?(bienvenu) → review+

Comment 15

13 years ago
Comment on attachment 198175 [details] [diff] [review]
else if headerValue patch v1.1a (Checked in branch and trunk)

Not sure if an sr= is required or not but might as well. I'm also guessing this
will be needed on the branch so requesting a= too as it makes the sender header
feature work as it should do. Patch should be fairly low risk.
Attachment #198175 - Flags: superreview?(mscott)
Attachment #198175 - Flags: approval1.8b5?

Comment 16

13 years ago
Comment on attachment 198175 [details] [diff] [review]
else if headerValue patch v1.1a (Checked in branch and trunk)

do we need similar changes in thunderbird?
Attachment #198175 - Flags: superreview?(mscott)
Attachment #198175 - Flags: superreview+
Attachment #198175 - Flags: approval1.8b5?
Attachment #198175 - Flags: approval1.8b5+

Comment 17

13 years ago
Comment on attachment 198175 [details] [diff] [review]
else if headerValue patch v1.1a (Checked in branch and trunk)

This is for Thunderbird btw, the mailnews equivalent is bug 308988

Checking in (trunk)
msgHdrViewOverlay.js;
new revision: 1.59; previous revision: 1.58
done
Checking in (branch)
msgHdrViewOverlay.js;
new revision: 1.56.2.1; previous revision: 1.56
done
Attachment #198175 - Attachment description: else if headerValue patch v1.1a → else if headerValue patch v1.1a (Checked in branch and trunk)

Updated

13 years ago
Keywords: fixed1.8

Comment 18

13 years ago
Additional changes were made in the patch on bug 308988 for trunk to really fix sender being shown if it is different to from

Comment 19

13 years ago
Any reason this bug should remain open?
(Assignee)

Comment 20

12 years ago
marking fixed - mainly by the patches in  bug 308988
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

12 years ago
Created attachment 246693 [details] [diff] [review]
part not checked in

this adds support for per-folder custom identity - and the automatic creation thereof for other user's imap folders, when a special pref is set.
Attachment #246693 - Flags: superreview?(mscott)

Updated

12 years ago
Attachment #246693 - Flags: superreview?(mscott) → superreview+
You need to log in before you can comment on or make changes to this bug.