timeout when connecting to the pop3 servers with a proxy

RESOLVED DUPLICATE of bug 122752

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 122752
13 years ago
13 years ago

People

(Reporter: Jian ZHOU, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Timeout when connecting to the pop3 servers with a proxy:

I am using Thunderbird 1.0 under Windows XP sp2.

My computer is within a LAN of a university. I have to access the POP3 mail
servers(pop.tom.com) through a socks 5 or a http proxy. When I set up my mail
account(pop3) ,and define a socks proxy in Thunderbird(have also tried a http
proxy), and then click the "Get Mail" button, nothing happens accept the hint
message "connecting to pop.tom.com..." in the statusbar. No error message at
all, and no requirement for password.

I create a log file of Thunderbird, it seems a timeout problems:

0[2c46a8]: mail.pop3_response_timeout=45
0[2c46a8]: mail.pop3_response_timeout=45
0[2c46a8]: OnResponseTimeout: username=godzhou
0[2c46a8]: OnResponseTimeout: username=godzhou (my username of the mail server)

I also tried to increase the mail.pop3_response_timeout to 300, and have no effect.

Another mail client(Foxmail, which also uses the same socks 5 proxy) is used and
works well. So, I am sure that the addresses of mail server and the proxy server
are both correct in Thunderbird.

Then I attempt to set up another pop3 mail account. This mail server is within
the same LAN of my computer, and I can access it directly. Thunderbird works
well for this account.

Reproducible: Always

Steps to Reproduce:
1.set up a pop3 mail account 
2.define a socks 5 proxy (or a http proxy)
3.click the "Get Mail" button
Actual Results:  
The hint message "connecting to pop.tom.com..." appears in the statusbar, and
disappears later. No error messages, and no requirement for password. And of
course no new messages at all(although there are many new mails on the server). 

Expected Results:  
It should require me the password of my email account and says there are xxx new
mails, and then receive mails one by one.

So, I am not sure that if it is a bug of Thunderbird or a problem of my proxy? Or 

something else?

Thanks.

Jian
Do you need to enter user/password at your SOCKS5 proxy to use it ?
If yes: Please mark this bug as dupe of bug 122752
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Do you need to enter user/password at your SOCKS5 proxy to use it ?
> If yes: Please mark this bug as dupe of bug 122752

Thank you.

That's the key! It works when I run Thunderbird from SocksCap.

I thought Thunderbird would ask me for the username/password of socks proxy.

Jian

*** This bug has been marked as a duplicate of 122752 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.