News group server username/passwords are not saved

RESOLVED DUPLICATE of bug 435306

Status

--
major
RESOLVED DUPLICATE of bug 435306
14 years ago
6 years ago

People

(Reporter: mazdak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.6 (KHTML, like Gecko) Safari/125.12
Build Identifier: version 1.0 (20041206)

When the news group server (NNTP) prompts for a username and password, even though the checkbox 
is for storing the passwords is checked, the settings are not retained. Every time time I connect to the 
news server it asks for the username/password (twice) again.

Reproducible: Always

Steps to Reproduce:
1. Connect to a news (NNTP) server that requires login (try with SSL)
2. Enter username and check "save password" checkbox, do the same for password
3. Close Thunderbird. Open and try to connect to the same server again... it asks for the username/
password again.
Actual Results:  
Username and password were asked for again. It was not saved by password manager

Expected Results:  
I should not have to enter my username/password every time I connect to the NNTP server.

Comment 1

14 years ago
This used to work on Win XP SP2, until I installed the first big patch to
Firefox/T-Bird.  Since then, the behavior is exactly as described here.

Comment 2

14 years ago
Confirm this happens on Win ME and TB 1.0.2 official build nearly every other
day when TB performs initial POP and NNTP server quiries during startup.  Access
two groups on a private NNTP server (news_annexcafe_com) that are restricted to
server staff, so require use of this function. It has been unreliable since the
0.1a builds.

Comment 3

13 years ago
(In reply to comment #0)

I had 1.5 for OS X and just upgraded to 1.6 and the problem occurs for me, as
well. I tried the pref.js tweaks mentioned in the knowledge base, even though it
wasn't for an identical problem, just in case. But it didn't help/
QA Contact: account-manager
Does this problem still exist in TB 2.0.0.*, trunk TB, or related versions of SM? If not, I will resolve this bug in 3 weeks as INCO.
Assignee: mscott → nobody
Whiteboard: closeme 2008-05-22

Comment 5

11 years ago
Behavior noted in Comment #2 is no longer true.  What now happens with 2.0.0.12 is, on a news connection fail with the server the PWM pops up with Userid/PW for one additional try; then PWM purges if the retry fails. This is what I see on Vista Win32. For news, the connection problem I see frequently is "Server is too busy" from my ISP's two leased connections to Newshosting.Com.

Would be less impact on user experience if PWM improved retention with a user checkoff confirming the popup is valid.  Would a count down loop be useful, so a form of three strikes rule is applied?

It seems that this behavior was added in bug 286628 from cvsblame. Therefore, if we think that the behavior of deleting the password after the second try is no longer a good idea, then this should be duped to bug 286628 and that bug openned.

Comment 7

11 years ago
I agree that Bug 286628 should be reopened for more work.  This bug is a dupe.  I was CC on that bug till after David B. landed the patch for NNTP.  

If you reopen Bug 286628 I will comment on it, other wise I believe the user experience will be better if the PWM improves persistence.  Personally I do not want my authentication purged.  An idea is to add another button to the popup dialog labeled "Retry" and two digit text boxs for user auto-retry selections.  Much like how modem dialers work, where time interval and number are user options.
A default of two tries at 20 second intervals is a starting point. Could be included in the initial setting of the ID and PW.  
Expanding scope -> bug 435306
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: closeme 2008-05-22
Duplicate of bug: 435306
You need to log in before you can comment on or make changes to this bug.