enh: Lock sort order of mailbox (always return to preset order)

RESOLVED DUPLICATE of bug 837546

Status

--
enhancement
RESOLVED DUPLICATE of bug 837546
14 years ago
5 years ago

People

(Reporter: sander+bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050314 Firefox/1.0.2
Build Identifier: 1.02 RC 

I have my mailbox sort order set to Order Received, Descending. 
When I accidentally click on the "Subject" header instead of on the first email
in the list, I have to click View, Sort by, Order Received, View, Sort by,
Descending. 
In order to save me from this work I would like an option to either lock the
sort order, or to always return to the preset sort order (e.g. by switching
between mailboxes).

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
I too find this annoying, I am constantly having to re-sort in descending order 
it appears this feature has been coded just either not enabled or not
documented, probably the later.
their is a bit of a discussion on mozillazine about it
http://forums.mozillazine.org/viewtopic.php?p=1568481#1568481

Comment 2

12 years ago
YES! reverse sort order only when clicking on sorted column. I had hoped this would be changed with TB. Apparently I am not alone.
QA Contact: front-end

Comment 3

12 years ago
Rereading my comment it seems a little cryptic. Just to adstruct my view:
My "standard" sorting is "received"; "descending", a logical choice.
Occasionally I click "Sender" or "Recipient" when I attempt to reorganize my mail. When I then revert to my "Date" column TB happily reverts the previous sort in that column, which was, apparently, not my intention at all.

Please reprogram TB such that sort order is only reverted when you have this column already as the active sort column.
Assignee: mscott → nobody

Comment 4

9 years ago
After accidentally clicking a column header when aiming for the most recent message in my inbox for the thousandth time (I know, bad mouse aim--user error), I decided to hop onto Bugzilla to request this enhancement.  I am glad to see it's already logged.

I'd like a way to simply lock the header bar entirely.  Perhaps this is an option that can be added to the drop-down menu available at the right of the header, positioned right above the "Restore Defaults" option.

By lock the header entirely I mean:

1. Clicking anywhere in the header (except the icon at the right that opens the drop-down menu cited above) does nothing.
2. Even clicking on column edges does nothing (no accidental column re-size or click-to-drag effect).

As with Sander Goudswaard in comment #1, I use "Received Descending" as my preferred sort order.  When targeting the top-most message, I often accidentally click a column header and unintentionally change the sort order.

Comment 5

9 years ago
I normally have my inbox threaded and sorted by Date, with newest at the top.  And I am not sure if this is mythology, but I think I also have it set so that it is the date of the most recent message in the thread rather than the first message.  When I accidentally click on the Subject column header, to put it back, I do:

 - click the thread icon, which puts most recent at bottom
 - click thread icon again to get most recent at top
 - change View to Unread
 - click the date header, which puts most recent at bottom
 - click data header again to get most recent at top
 - change View back to All

This is with Thunderbird 2.0.0.24

Comment 6

8 years ago
Any movement on this one?

I would so greatly appreciate the ability to lock the header row.  The frustration of accidentally clicking on a header column resulting in the messages being re-sorted is far greater than it should be.  It's irrational, I know, but I suppose it's a pet peeve.

Comment 7

8 years ago
This is something that would be good for an extension. I doubt we'd put it in the core product. Perhaps Brian has other ideas for mitigating this.
see bug 837546, which has more recent context.
duping forward
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 837546
You need to log in before you can comment on or make changes to this bug.