When page contains dynamic ads, the URL field displays ads URL instead of site URL

RESOLVED FIXED in Camino0.9

Status

Camino Graveyard
Location Bar & Autocomplete
P2
major
RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: Monica, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino0.9
PowerPC
Mac OS X

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       [Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O) Gecko/20040906 Camino/0.8+]
Build Identifier: [Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O) Gecko/20040906 Camino/0.8+]

This occurs on sites that have ads of the google ads type. From the site I
linked, try clicking on a permalink, you'll get taken to that page, the URL of
that page will be briefly displayed in the location bar, after which, it will be
replaced by a different URL starting with "ads.splinder.com". Everything goes
back to normal if you click on a different open tab, then go back to that tab -
the correct URL will be displayed.

The exact same thing happens with all sites hosted on blogspot, and also with
any other site hosted on its own domain, as long as they're using that kind of
"dynamic" ads.


Reproducible: Always

Steps to Reproduce:
1. Visit URL given above as demonstration.
2. Click on one of the "permalink" links below each entry. You will be taken to
the page with that entry.

Actual Results:  
When that page loads, the URL in the location bar will quickly change from the
URL of that page, to an URL from the dynamic ads used in the page.
The page can be still bookmarked with the correct URL (even when dragging the
URL to the toolbar, the bookmarked URL will be the correct site and page URL,
not the ads URL being displayed). But the URL displayed will be the ads URL, not
the site URL, so aside from being confusing, it makes it impossible to copy it
and paste it in an email message or text document.
The only "workaround" is to click on another tab, or open a new tab if you don't
have any other tabs open already, then go back to that tab with the page
containing dynamic ads. The location bar will now display the URL correctly and
you will be able to copy it correctly.

Expected Results:  
The URL displayed in the location field should always be that site and that page
URL, not the URL from any dynamic ads or other elements in the page.
(Assignee)

Comment 1

13 years ago
this is a dupe.
Whiteboard: DUPEME
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> this is a dupe.

I hadn't found anything in the archive because I was searching "url field" -
then I realised I should check "location bar" and just came across this:
https://bugzilla.mozilla.org/show_bug.cgi?id=285648

"When a page has a subframe, Camino will display the subframe's URL in the
location bar instead of the main page's.  NYTimes.com is a good example. 
Instead of http://www.nytimes.com, the location bar shows
http://ad.doubleclick.net/adi/N3016.nytimes.comSD6440/B1495671.6;sz=88x60;ord=2005.03.10.22.06.34?"

That is exactly what I meant (I had noticed that only with ads, probably because
they use < iframe >). 

Sorry for the duplicate!
(Assignee)

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 285648 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Is this really a dupe? It's using Camino 0.8 and not a nightly.

Comment 5

13 years ago
Not a dup, since this was reported with 0.8
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

13 years ago
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → Camino0.9
(Assignee)

Comment 6

13 years ago
User-Agent:       [Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O)
Gecko/20040906 Camino/0.8+]

this says "nightly" to me, not 0.8. sorry.
(Assignee)

Comment 7

13 years ago
though i guess the "2004" should have given it away. oh well.

Comment 8

13 years ago
This did have the same cause as bug 285648.
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

13 years ago
i can't verify if this is fixed on the branch, i can't sign in. where else can i
reproduce it?

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.