Camino displays subframe's URL in location bar

RESOLVED FIXED in Camino0.9

Status

defect
P1
critical
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: pgauriar, Assigned: sfraser_bugs)

Tracking

unspecified
Camino0.9
PowerPC
macOS

Details

(Whiteboard: patch)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
When a page has a subframe, Camino will display the subframe's URL in the
location bar instead of the main page's.  NYTimes.com is a good example. 
Instead of http://www.nytimes.com, the location bar shows
http://ad.doubleclick.net/adi/N3016.nytimes.comSD6440/B1495671.6;sz=88x60;ord=2005.03.10.22.06.34?

This started showing up in the 20050309 nightly.
can someone take a look at the checkins from that day and narrow it down? this
has happened before when someone forgot about embedding layers when making changes.
Keywords: regression
Target Milestone: --- → Camino0.9
(Assignee)

Comment 2

14 years ago
The most likely candidate looks like bug 284993.
*** Bug 285682 has been marked as a duplicate of this bug. ***
Partial Workaround: switch to another tab, then go back to the first tab. The
proper URL will reappear (though this doesn't fix the missing favicon).

cl

Comment 5

14 years ago
Also, sometimes there will simply be no URL in the URL bar. I have my home page
set to slashdot and when I start the browser, after slashdot has loaded there
will  be nothing in the URL bar.

Comment 6

14 years ago
*** Bug 263695 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 286414 has been marked as a duplicate of this bug. ***
*** Bug 286716 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

14 years ago
This is a very serious bug; a site could spoof another site by using a small
iframe with the url of the site they want to show in the url bar.
Severity: normal → critical
Priority: -- → P1
(Assignee)

Comment 10

14 years ago
jst: this looks like a regression from your change in bug 284993.
(Assignee)

Comment 11

14 years ago
Taking.
Assignee: pinkerton → sfraser_bugs
(Assignee)

Comment 12

14 years ago
I think what happened is that jst's patch may have changed the order in which
we get OnLocationChange for the page vs. subframes. But the real bug is that we
need to filter the OnLocationChange at the browser listener level.
Attachment #177942 - Flags: review?(pinkerton)
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
Whiteboard: patch
(Assignee)

Comment 13

14 years ago
I checked this in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
is this something that should go on the branch? would it fix similar issues that
are reported on 0.8?
this needs to go on the branch
Blocks: 279168
Keywords: regression

Updated

14 years ago
Attachment #177942 - Flags: review?(pinkerton)
*** Bug 286414 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.