Last Comment Bug 287634 - [es-MX] Spanish (Mexico): Firefox
: [es-MX] Spanish (Mexico): Firefox
Status: RESOLVED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Localization Registration Bugs
:
Mentors:
Depends on:
Blocks: 450233
  Show dependency treegraph
 
Reported: 2005-03-24 17:06 PST by Alejandro Serrano Gonzalez
Modified: 2011-07-25 22:45 PDT (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Firefox 3.1b1pre es-MX language pack (117.60 KB, application/x-xpinstall)
2008-09-09 00:52 PDT, Alexandru Szasz
no flags Details
Firefox 3.1b1pre es-MX language pack v2 (123.42 KB, application/x-xpinstall)
2009-02-04 22:47 PST, Ricardo Meza
no flags Details
Firefox es-MX source (147.31 KB, application/gzip)
2009-02-05 10:35 PST, Ricardo Meza
l10n: review+
Details

Description Alejandro Serrano Gonzalez 2005-03-24 17:06:04 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.7) Gecko/20040616

Product: Mozilla Firefox
Language + country: es-MX
Contact:
Alejandro Serrano González
alejandrosg@gmail.com
http://mozmex.ismx.net

Reproducible: Always
Comment 1 Pavel Franc - Mozilla.cz 2005-05-24 05:01:04 PDT
In order to commit Spanish (Mexico) localization of Firefox you need to apply
for CVS account - see bug 263726 as an example. And you should also provide your
localization files to review.
Comment 2 Axel Hecht 2005-06-30 09:56:16 PDT
Could we get a status update on this locale? We're going to branch for 1.1 late
next week and would like to handle new locales for 1.1 by then.
Comment 3 Gervase Markham [:gerv] 2007-09-19 02:17:34 PDT
On behalf of the Mozilla Project, I'd like to apologise for the delay in processing this request. We very much appreciate offers of help in localization.

If anyone reading this is still interested in helping to translate one or more Mozilla products into the language that this bug is about, please add a new comment to this bug to confirm your interest, saying again which products you would like to localize e.g., Firefox, Thunderbird. We will then make the necessary arrangements.
Comment 4 Ricardo Meza 2007-10-06 12:00:46 PDT
Hi, I'm interested in helping to translate Mozilla Firefox to the Mexico Spanish. So, tell me how to do it, tks. :)
Comment 5 Gervase Markham [:gerv] 2007-10-11 00:43:01 PDT
Great :-) You need to read this wiki page:
http://wiki.mozilla.org/L10n:Starting_a_localization

Create yourself a wiki page for your localisation, which registers you as the team for that language. Then, follow the instructions on the wiki to produce a language pack you can distribute through addons.mozilla.org. Once you have reached that stage, we can consider your pack for official status - although I should warn you that this is a separate process with its own complexities. Still, the community will still be able to get your pack from addons.mozilla.org in the meantime.

If you have read carefully and find the documentation isn't good enough in any way, please let us know and we will improve it.

Gerv
Comment 6 Ricardo Meza 2007-10-13 06:18:20 PDT
Hello, thanks for your comments, I will be reading the documents that you have recommended me about translating Mozilla products. Then I come back to see you, thank you very much.
Comment 7 Ricardo Meza 2007-10-23 23:01:11 PDT
Hi, I have not found any translation team for Firefox es-MX, I read that I can begin a new project for this purpose, do I have to give high somewhere? Can I start a channel communication referred in "L10n: Starting a localization" in a Google Group to start to get help from other volunteers, perhaps friends of the university where I study?
Comment 8 Ricardo Meza 2007-11-09 12:54:10 PST
Hi, the request for a new project registration on SourceForge for this localization has been done.

I downloaded the files needed to start the localization through Mozilla Translation, I hope to have the xpi soon.
Comment 9 chris hofmann 2007-11-17 08:32:43 PST
Hi Ricardo,

I'm working on try to recruit people that are also interested in creating an es-MX version.  I think others will join this effort soon. There is some information about a conference that I attended in Puerto Vallarta where there were several people that were interested in contributing. 

http://www.mozilla-hispano.org/

Have you been able to make any progress yet?   I'd really like to see a community of people get involved in this work and that we host the project on Mozilla.

One idea would be to create an additional form at this site
http://www.mozilla-hispano.org/foro/viewforum.php?f=7
Maybe ricardo can help with that.

There are some tools that would allow us to leverage the work done in the es-ES and es-AR versions of firefox, and then make changes from that starting point.
We also need to get some people thinking about what search options and RSS news feeds make most sense for Firefox users in Mexico.

-chofmann
Comment 10 chris hofmann 2007-11-17 08:38:00 PST
here is a link to some work I did to compare the existing es-ES and es-AR versions.  It would be good to get some folks reviewing the differences and deciding which translation makes more sense, or if a new translation is needed for some of these strings to best serve users in Mexico

http://l10n.mozilla.org/~chofmann/l10n/tree/l10n/es-ES-AR.txt

-chofmann
Comment 11 chris hofmann 2007-11-17 08:59:27 PST
On the idea of using the Spain version or the Argentina version as a starting point for the Mexican version Axel has put together a guide that could help this work.  That document is at http://developer.mozilla.org/en/docs/Creating_en-X-dude

Some substitutions will be made to swap in a Spainish version as the base version and then create es-MX.

Anyone have thoughts on if es-ES or es-AR might be the best starting point for the es-MX version?

I can help create that localization tree if needed, once we figure out the best starting point.
 
Comment 12 Axel Hecht [:Pike] 2007-11-17 10:37:30 PST
Creating en-X-dude has nothing to do with es-MX, not even remotely.

I want to get a clear understanding what needs to be done from a language point-of-view, I'm not going to go with any kind of "I hacked a tree, take this".
Comment 13 chris hofmann 2007-11-17 15:31:16 PST
>  I'm not going to go with any kind of "I hacked a tree, take this".

no one is suggesting that.

> I want to get a clear understanding what needs to be done from a language point-of-view

we should provide some guidance on what is required for this or examples of other locales have done this.

> Creating en-X-dude has nothing to do with es-MX, not even remotely.

this simply allows folks to get a es-ES translation set up under a es-MX build tree, for some experimentation and prototyping.  

I agree, there are no decisions made here yet, but we should set people up to start with some experimentation that could be later turned into language pack or checked into CVS.


Comment 14 martin 2007-11-17 17:23:53 PST
I can't believe I hadn't noticed Firefox lacks an es-mx language version.
I'm more than willing to help in any way that I can.
Comment 15 [:rickiees] Ricardo Palomares 2007-11-18 10:57:14 PST
(In reply to comment #9)
> 
> Have you been able to make any progress yet?   I'd really like to see a
> community of people get involved in this work and that we host the project on
> Mozilla.
> 
> One idea would be to create an additional form at this site
> http://www.mozilla-hispano.org/foro/viewforum.php?f=7
> Maybe ricardo can help with that.


I think I'm that Ricardo. :-) Chris, I've forwarded your petition to the people managing the forums. We'll post back when a decission has been made.

Comment 16 [:rickiees] Ricardo Palomares 2007-11-18 11:04:34 PST
(In reply to comment #12)
> I want to get a clear understanding what needs to be done from a language
> point-of-view, I'm not going to go with any kind of "I hacked a tree, take
> this".
> 

(In reply to comment #12)
> I want to get a clear understanding what needs to be done from a language
> point-of-view, I'm not going to go with any kind of "I hacked a tree, take
> this".


Just for the record, when I joined others to take over the task of translating
Mozilla Suite 1.0 to es-ES, we started with the existing 0.9 translation. We
needed to add new strings and review the existing ones, and we did it by going
thru each and every file in the translation (we did it with MT, which could
ease a bit the task, but that's not important). I'd say that starting from
"something", even if that was not exactly what we wanted es-ES to be, was
useful and saved effort.

So I wouldn't dare to recommend es-MX folks to start from scratch when two es-*
localizations already exist.

JMTC
Comment 17 Ricardo Meza 2007-11-18 17:27:17 PST
Hello everybody, the last few days I have been researching the requirements for establishing a new Localization, of course I have reviewed the documentation of Mozilla, the tutorial "Creating en-X-dude", the documentation of the project NAVE and the Argentina project, by the time I have been a little busy with some university exams.

The project on SourceForge to promote our project has been approved, now I have been reading the documentation to use the SourceForge services (web, shells, ssh, etc.).

The goal is to create a wiki for the translation of Mozilla products for Mexico, also including the possible indigenous languages and dialects translation teams. I am putting in contact with some indigenous organizations who are interested.

At the moment I'm creating my SSH key to have access to the web hosting service of SourceForge, then I will seek the instructions for creating the wiki there and finally I'll start with the translation, I am convinced that I need the help of someone specializing in knowledge of Spanish Mexico, I'm looking for the person who wants to cooperate.

It's a lot of work but I think that after taking the wiki I can get more help, thanks to Chris Hofmann and others for their comments, you probably already noticed that I did not manage well the English language, I'm helping with the translation tool of Google XD

> here is a link to some work I did to compare the existing es-ES and es-AR
> versions.  It would be good to get some folks reviewing the differences and
> deciding which translation makes more sense, or if a new translation is needed
> for some of these strings to best serve users in Mexico

I already reviewed the document that compares the both translations Spain and Argentina, is excellent and it will help us.

> Have you been able to make any progress yet? I'd really like to see a
> Community of people get involved in this work and that we host the project on > Mozilla. "

As I did not see how to create the wiki project on the Mozilla's Site and following the recommendation of the page "Crating a new localization" in the section "Starting a new team" (Http://developer.mozilla.org/en/docs/Create_a_new_localization) I had to decide to host the project at SourceForge.

By the way Chris, if you recommend me to host the project on the Mozilla's Site just tell me the instructions.

Tank you very much.
Comment 18 Axel Hecht [:Pike] 2007-11-19 02:25:42 PST
For wiki pages, feel free to use wiki.mozilla.org. You'll need to create an account for that, but that's just like any other wiki account.
Depending on what Ricardo Palomares thinks, it sounds like the wiki pages on http://www.mozilla-hispano.org/documentacion/Portada might be a good place, too.

For discussions, I'd start off in the traduccion forum on mozilla-hispano, http://www.mozilla-hispano.org/foro/viewforum.php?f=7&sid=7f3a1d6fb2effb44600ec573b138c3ae. That seems to be the right spot to discuss on Spanish about Spanish, in particular about choices like which of the current es-* you'd base on, and if anything you found in the one you'd base in is actually a bug or real difference.

Technically, ex-MX should hopefully be based on what I call "l10n-fork", I hope, see bug 403215. That has a dependency on l10n-merge, which I'm currently hacking on.
Comment 19 Rubén Martín [:Nukeador] 2007-11-19 07:07:12 PST
The wiki of Mozilla Hispano is used for support documentation only, maybe this could change in the future.

We have talked about the forum thing and we won't have any problem to create this subforum if finally there is an es-MX locale.
Comment 20 Ricardo Meza 2007-11-23 08:21:52 PST
Hi Nukeador, If you really want and you have the time to help us to build the location of es-MX I´ll really appreciate that.
If you create a subforum for the es-MX localization I'll see you there. Thanks.
Comment 21 Rubén Martín [:Nukeador] 2007-11-23 10:05:01 PST
Ricardo, I'm sending you an email to talk about the forum :)
Comment 22 Carlos Zenteno 2007-12-05 09:50:52 PST
I would also like to help in the establishment/translation for es-MX localization of Firefox (and later Thunderbird).
Comment 23 Ricardo Meza 2007-12-05 10:24:34 PST
Hi Carlos Zenteno, I'm sending you an email to talk about the localization for es-MX :-)
Comment 24 Ricardo Meza 2008-05-09 09:42:03 PDT
Hi everybody!

I've been working **** creating a website (http://mozilla-mexico.sf.net) to unite the Mozilla Mexican community and we have received great support from them.
So, my attention on localizing Firefox was interrupted for a while but, I'm back to the work, I have a copy of the es-es glossary and my MozillaTranslator installed so, in a few days I hope make the first language pack of the es-mx translation.

Greetings :-)
Comment 25 chris hofmann 2008-05-09 11:50:13 PDT
cool!
Comment 26 Ricardo Meza 2008-08-11 17:50:00 PDT
Hi everybody.

I'm happy to announce the creation of the first es-MX language pack. It can be downloaded through the Mozilla Addons web site[1].

What should happen to go to the next stage of the es-MX localization?

[1]https://addons.mozilla.org/es-ES/firefox/addon/8343
Comment 27 Ricardo Meza 2008-08-14 22:32:21 PDT
Alexandru Szasz help me to create a l10n CVS account request bug[1]

Anyone want to support me?

Thanks in advance.

[1]https://bugzilla.mozilla.org/show_bug.cgi?id=287634
Comment 28 Guillermo López :willyaranda (probably SLOW response) 2008-08-15 01:37:26 PDT
I think that Ricardo or me (I prefer Ricardo) could support you on the bug 450233, but I say, Ricardo is more experienced on this things.

Regards!
Comment 29 Ricardo Meza 2008-08-15 09:44:00 PDT
Hi willyaranda.

Thank for you support. RickyES (es-ES) is commenting on bug 450233.

Greetings.
Comment 30 Axel Hecht [:Pike] 2008-08-15 10:00:18 PDT
For the further process, we'll need a source for es-MX to review, and I'd like to learn a bit more about the differences of that wrt to the other two Spanish versions.

See https://wiki.mozilla.org/L10n:Becoming_an_Official_Localization#Preparation and ongoing for more information on the process here, too.
Comment 31 Ricardo Meza 2008-08-16 15:18:41 PDT
According to the "Mozilla Wiki Preparation article" I'll try to provide to you the data requested:

What you want to release.
-Mozilla Firefox
Who you are.
-My name: Ricardo Meza
-Name of my peers: Xavier Baez, Jesus Christian Cruz
-Teams page: http://mozilla-mexico.sf.net

Building blocks
-Translations: I started the translation from the es-ES files, so, I
did finish it in a very short time, of course there are differences
between this locales.
-Technical/Engineering/Testing: I create a language pack from your
tutorial "creating en-X-dude" using the es-ES files.
-Community development: I start the Mozilla Mexico community precisely
to be a point of union of the mexican localization.
-Business relationship: The Mexican Internet Association (http://amipci.org.mx) contact to me to start a cooperation relationship, the members of this association are the representatives of the industry and government of Mexico.
-Webdev and graphics designers: Actually I was the designer and developer of our site including the image of the Firefox 3 Release partys (http://mozilla-mexico.sourceforge.net/?page_id=10) by the way there is an contest to get from the Mozilla community designers the Mozilla Mexico logotype (http://mozilla-mexico.sourceforge.net/?page_id=6)

Landing in CVS:
bug 450233

Reviews:
Until today we have 219 downloads and 42 votes (5/5)
https://addons.mozilla.org/es-ES/firefox/addon/8343

Localization source:
Attached to this bug.

I hope this information help.
Comment 32 Ricardo Meza 2008-08-16 15:24:52 PDT
Localization source:
http://rapidshare.com/files/137844192/localization.tar.bz2.html
Comment 33 Guillermo López :willyaranda (probably SLOW response) 2008-08-16 15:37:43 PDT
Ricardo, I think it's better to upload here the .tar file with the es-MX localization, instead of having it on a external server.
Comment 34 Ricardo Meza 2008-08-16 15:44:19 PDT
Yes you right but, when I tried to do it I get this message:

"The file you are trying to attach is 612 kilobytes (KB) in size. Non-patch attachments cannot be more than 512 KB.
We recommend that you store your attachment elsewhere on the web, and then insert the URL to it in a comment, or in the URL field for this bug.
Alternately, if your attachment is an image, you could convert it to a compressible format like JPG or PNG and try again."
Comment 35 Axel Hecht [:Pike] 2008-08-17 10:23:42 PDT
I suspect that you're including a dictionary in extensions/spellcheck, just don't include that in the tarball and you should be fine.
Comment 36 Ricardo Meza 2008-08-17 15:14:23 PDT
No, there's not such 'spellcheck' in the extensions directory.

You can see a list of the 'extensions' directory's/files here:
http://ricardomeza.org/docs/mozilla/directory_extensions

... and a full list of the es-MX tarball directory's/files:
http://ricardomeza.org/docs/mozilla/directory_extensions

Thanks.
Comment 37 Ricardo Meza 2008-08-17 15:16:46 PDT
Sorry, the last link is incorrect, this is the good one:
http://ricardomeza.org/docs/mozilla/directory
Comment 38 Alexandro Colorado 2008-08-26 21:08:59 PDT
Added to the issue.
Comment 39 Alexandru Szasz 2008-09-09 00:52:58 PDT
Created attachment 337618 [details]
Firefox 3.1b1pre es-MX language pack

Here's a little bit of help for Ricardo.

Attached is the language pack resulted from his translation. This was tested a bit by me with the following build:

ftp://ftp.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-win32/1220937472/firefox-3.1b1pre.en-US.win32.installer.exe

I don't know if a patch would help considering there is no es-MX repo in l10n-central.
Comment 40 juan becerra [:juanb] 2008-12-23 15:52:34 PST
I have been taking a look at the latest es-MX xpi that can be found here: https://l10n.mozilla.org/narro/narro_project_list.php?l=es-MX

Using a nightly Fx3.1b3pre build. So far it looks OK. I will continue a more thorough test of the build, looking mainly for anything missing.
Comment 41 Ricardo Meza 2009-02-04 22:47:19 PST
Created attachment 360666 [details]
 Firefox 3.1b1pre es-MX language pack v2

Firefox 3.1b1pre es-MX language pack, second revision.
Comment 42 Ricardo Meza 2009-02-04 22:49:27 PST
I just upload the last version of the language pack, it's the second file uploaded.
Comment 43 Axel Hecht [:Pike] 2009-02-05 01:47:53 PST
Sorry, but we need a source for your localization, not a language pack.
Comment 44 Ricardo Meza 2009-02-05 10:35:23 PST
Created attachment 360753 [details]
Firefox es-MX source

Firefox es-MX source exported from Narro
Comment 45 Axel Hecht [:Pike] 2009-03-10 09:01:49 PDT
Comment on attachment 360753 [details]
Firefox es-MX source

r=me, sorry for the lag. Loads of new bugs coming up.
Comment 46 Axel Hecht [:Pike] 2009-03-10 17:14:19 PDT
Stuff I did on my initial commit:

I removed a flock of obsolete files, and I fixed a XML parsing error in plugins, there was something like <!ENTITY foo "stuff with "plugins" gone awkward">, I changed the inner quotation marks to &quot;, as XML likes it.

Please don't revert those changes without someone looking at a corresponding patch.

http://l10n.mozilla.org/dashboard/?locale=es-MX shows the status of your locale
for fx31x and fx32x, the repositories of immediate interest for you towards
Firefox 3.1 (which we'll rebrand to 3.5 soon) are
http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/es-MX/ and the mozilla-1.9.1
repo, check out https://developer.mozilla.org/en/L10n_on_Mercurial for details.

Please follow the communication around localizing Mozilla applications on .l10n, details on how to join are on http://www.mozilla.org/community/developer-forums.html#dev-l10n. In particular that's the place to watch out for announcements and to ask for help.
Comment 47 Guillermo E. Lopez 2011-07-25 22:20:49 PDT
Any news on the es-MX localization? Chris?
Comment 48 Pascal Chevrel:pascalc 2011-07-25 22:25:46 PDT
Guillermo, the localization in es-MX is done, you can download it on mozilla.com:
http://www.mozilla.com/es-MX/firefox/
Comment 49 Guillermo E. Lopez 2011-07-25 22:30:13 PDT
I see, but why when I go to www.firefox.com the website sets by default the es-ES download instead of the es-MX? I guess that if the website is offering me a download in Spanish then it knows because of my IP address that I'm located in Mexico, not Spain.
Comment 50 Pascal Chevrel:pascalc 2011-07-25 22:41:48 PDT
no, it will offer you the same locale you are browsing currently with if it is available, that means that you probably are surfing currently with an es-ES browser sending es-ES http accept-lang headers (the browser tells the website "show me pages in es-ES if you have them". You should put "es-MX" as your first locale in your browser preferences. In Firefox it is something you can change in Options/Content
Comment 51 Guillermo E. Lopez 2011-07-25 22:45:03 PDT
True and VERY useful Pascal, thanks!

Note You need to log in before you can comment on or make changes to this bug.