CPU rush occurs when connection is lost

RESOLVED DUPLICATE of bug 213637

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 213637
14 years ago
13 years ago

People

(Reporter: mnlannerfalcon, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

My system utilizes a wireless network in order to access the Internet.  However,
we have experienced periods where the router frequently drops connections with
computers.  Ordinarily, I wouldn't mention this except that Firefox has this
nasty habit of eating up ALL of the CPU whenever the connection is lost.  I have
the latest released build, but this problem has existed on every version, as
well as Netscape 7.2.  This problem has occurred on my mom's laptop as well, so
I know it is not limited to my system.  She is also using the latest build.
As a note, I am marking this as a critical issue because although the program is
still running, the lag is so terrible that it is literally impossible to recover
the data or bookmark your open pages.  The only workaround that currently exists
is the SessionSaver extension, but it will not retain any data typed in forms or
pages that require a login.

System specs:
Windows XP Professional SP2
1GB of Internal RAM
AMD Athlon XP 2400+
Firefox 1.0.2 (default) w/ numerous extensions (list will be included if requested)
Netscape 7.2 (default for mail)
Ad-Muncher (for popup blocking)
Linksys USB Wireless Adapter (links to a D-Link router currently)

Reproducible: Always

Steps to Reproduce:
1. Establish a simple wireless network in a typical workgroup environment
(either via a router or Windows PC).
2. Connect via an adapter (USB or PCI) to the wireless network.  Windows doesn't
have to manage the connection for the bug to work.
3. Open Firefox and browse to any website.  It doesn't matter where so long as
it's using the wireless connection.
4. Open Task Manager.  Much easier to do it now than when your CPU starts racing.
5. Open Network Connections (WinXP and above) and disable your wireless adapter.
 Alternatively, you can right-click on the icon in the system tray and disable
it from there.
6. Switch to Task Manager.  The CPU usage rate for firefox.exe should be around
90-99%.  If Netscape is also running, they'll compete for the CPU.  Rather fun
to watch, but quickly becomes annoying if you're trying to work on something.
Actual Results:  
Immediately after the connection was lost, Firefox and Netscape began racing the
CPU.  Restoring the connection did not amend the issue, and closing either
program did not guarantee termination of the respective processes.  In most
cases, Task Manager must be used to close the programs.

Expected Results:  
The program should either automatically switch to offline mode when no
connection is detected, or it should at least prevent itself from hogging the
CPU.  Since Netscape suffers from this as well, perhaps the problem lies in the
Gecko core?

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 240759 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
Can somebody explain the logic of calling this a dup of 240759? I don't see anything in that bug that would explain this behavior, especially if it's fixed in the 1.7 branch but occuring in FF 1.5. Please see my further comments in bug 327050.

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 271636 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 213637 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.