Message saved in Drafts folder open via "Edit as New" context menu item saves a new draft

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: funTomas, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Summary says it all. Anyway, if a message, saved as a draft is opened through
the contextual menu item "Edit As New", such opened message when saved again,
creates a new message in the Drafts folder instead of updating the original one.
Is that intentional behaviour? If yes, the contextual menu item shoudl be
renamed since it's quite confusing, misleading, IMO.

Reproducible: Always

Steps to Reproduce:
1. Create a new messate and save (Ctrl+S or via File menu)
2. Highlight the message within the Drafts folder, right click and choose "Edit
As  New"
3. Change something and save something.


Actual Results:  
4. Ooops, a new message added to the Drafts folder as not expected...;-)

Expected Results:  
The same as achived when opened via double clicking of a message within the
Drafts folder, ie. updating tho original message in that folder.

I hope it's clear.

Comment 1

14 years ago
> Is that intentional behaviour? If yes, the contextual menu item shoudl be
> renamed since it's quite confusing, misleading, IMO.

Yes, intentional:  "Edit as New" means "start a new message, initialized with 
this message's recipients and text."  The menu text is not misleading when shown 
for any message other than a draft, and behaves consistently when used on a 
draft.  The text is terse -- necessarily, as it's a menu item -- but it's a 
useful function (even for a draft).

If you want to just continue editing the draft, there is no context menu item 
for that -- you either double-click the message, or select it and click the 
"Edit Draft" button.

Based only on that, this bug would be Invalid.  However, I agree there is a 
potential for confusion here, altho relatively minor.  One approach to 
clarifying the meaning here would be to have an "Edit draft" item on the context 
menu; this would make clear that "Edit as New" does not mean editing the draft.

This would require a nontrivial change to support different context menus 
depending on the type of folder containing the message (or, perhaps, depending 
on the header flags indicating that the message is a draft).  Such a change 
would support even more niceties -- for instance, there's no need for Reply to a 
draft, so that item could simply not be shown in the menu.
On my system (in both TB and suite) if you open the original message via edit as
draft or double click it still saves a new message in drafts.  I don't recall if
it always behaved that way.(In reply to comment #1)
> > Is that intentional behaviour? If yes, the contextual menu item shoudl be
> > renamed since it's quite confusing, misleading, IMO.
> 
> Yes, intentional:  "Edit as New" means "start a new message, initialized with 
> this message's recipients and text."  The menu text is not misleading when shown 
> for any message other than a draft, and behaves consistently when used on a 
> draft.  The text is terse -- necessarily, as it's a menu item -- but it's a 
> useful function (even for a draft).
> 
> If you want to just continue editing the draft, there is no context menu item 
> for that -- you either double-click the message, or select it and click the 
> "Edit Draft" button.
> 
> Based only on that, this bug would be Invalid.  However, I agree there is a 
> potential for confusion here, altho relatively minor.  One approach to 
> clarifying the meaning here would be to have an "Edit draft" item on the context 
> menu; this would make clear that "Edit as New" does not mean editing the draft.

On my system (in both TB and suite nightlies) if you open the original message
via edit as draft or double click it still saves a new message in drafts.  I
don't recall that it always behaved that way. Mike?

 
> This would require a nontrivial change to support different context menus 
> depending on the type of folder containing the message (or, perhaps, depending 
> on the header flags indicating that the message is a draft).  Such a change 
> would support even more niceties -- for instance, there's no need for Reply to a 
> draft, so that item could simply not be shown in the menu.

Strictly speaking, to be more user friendly the context menu should provide
every (or most) operation that is valid for a message, especially if it is a
"special" message, no? 

Also, if user has the message header area "minimized", as I typically do for
reasons of space, "edit draft" is not presented.

Comment 3

14 years ago
i have always understood the behavior reported in this bug to be expected
behavior, as reported in Comment #1 by Mike Cowperthwaite, because there are
times i want to create a new message out of the old draft, and there are other
times i want to continue editing the same draft.

the behavior reported by the bug was the behavior i experienced in all of the
latest releases.

UNFORTUNATELY, it appears that the behavior is now as the bug-reporter desires
in the nightly builds (at least on mac):  for both double-clicking and "Edit
Message as New", when the user saves a message, the old message is replaced in
the Drafts, whereas for "Edit Message as New", it should still continue to save
a new copy in the Drafts folder.

i plan to submit another bug with a new and appropriate summary (since i
personally think this bug should be closed as "not a bug -> expected behavior),
but this seems related, and i was wonder if someone was attempting to "fix" this
bug (even though it's "unconfirmed" still).

Comment 4

14 years ago
(In reply to comment #3)
> UNFORTUNATELY, it appears that the behavior is now as the bug-reporter desires
> in the nightly builds (at least on mac):  for both double-clicking and "Edit
> Message as New", when the user saves a message, the old message is replaced in
> the Drafts, whereas for "Edit Message as New", it should still continue to
> save a new copy in the Drafts folder.

I see that also with TB 1.0+0621.  Have you opened the new bug yet?

Comment 5

14 years ago
actually, it appears that someone else created another bug for this before i
needed to submit one:  https://bugzilla.mozilla.org/show_bug.cgi?id=292568 . 
you can see there is already a link in my comments in that bug back to this one.

Comment 6

14 years ago
still clobbering old messages and resulting in data loss as of nightly TB build
version 1.6a1 (20050902).

i've voted for this bug, but it hasn't even been moved off of UNCONFIRMED, nor
has it been changed to reflect that it is not PC-only, and is not Windows XP only.

as a bug resulting in data-loss, it seems that "minor" is way to low for the
priority of this bug.

all i want is the old behavior back.  in other words, there was a purposeful
change in the code that took place in the recent (but no longer quite so recent)
past that causes this loss of data.  the further we get from that point, the
harder it will be to fix this.

Comment 7

14 years ago
(In reply to comment #6)
> still clobbering old messages and resulting in data loss as of nightly TB
> build version 1.6a1 (20050902).

Are you talking about *this* bug, or about bug 292568?  The problem in *this* 
bug does not seem to be that big of a problem to me; it certainly doesn't 
involve any dataloss.

Comment 8

14 years ago
you're right, it's the deletion of the old message that results in dataloss.  i
forgot there were two separate bugs.  in its original form, i believe this one
is "not a bug".

Comment 9

14 years ago
I would recommend to resolve this bug as INVALID. "Edit as New" is clearly to
create a new msg, hence a new saved copy.

Comment 10

13 years ago
Is fixed with bug 317396, see bug 317396 comment 9 (for TB 1.5). But other people see it different and want this changed back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 11

13 years ago
(In reply to comment #7)
> Are you talking about *this* bug, or about bug 292568?  The problem in *this* 
> bug does not seem to be that big of a problem to me; it certainly doesn't 
> involve any dataloss.

btw, while this bug is "fixed" with regard to the behavior that the original reporter cited, this new "fixed" behavior *does* result in dataloss.  in other words, if i have a draft that i want to leave the way it was, "Edit Message as New..." should have the emphasis on *"New"* .  because what happens with things the way they are currently is that if the "New" message is changed drastically, the old Draft is loss ... hence, dataloss.

i still feel that double-clicking on a draft performs the function that the original reporter desires, and that "Edit Message as New..." should leave the old message alone, *wherever* it resides, Drafts folder or otherwise.

and i find it a shame that this code was changed in the not too distant past, when thunderbird was ostensibly doing the right thing previously.

Comment 12

13 years ago
(In reply to comment #11)

I will file a new bug to restore the old behaviour, i.e. Edit as new a draft and save the new one does NOT delete the original msg. I'll cc you. 
You need to log in before you can comment on or make changes to this bug.