Closed Bug 28823 Opened 20 years ago Closed 19 years ago

" & < > and © are not parsed correctly

Categories

(Core :: HTML: Parser, defect, P4)

x86
Windows NT
defect

Tracking

()

VERIFIED WONTFIX
Future

People

(Reporter: emk, Assigned: rickg)

References

()

Details

(Keywords: testcase)

Steps to reproduce:
1. Launch Mozilla.
2. Navigate to http://www.os.rim.or.jp/~yuu/charrefhelp2.html
   (This is Japanese page. However, all you have to do is to see
    inside a table)

Actual result:
Mozilla treats &LT; as "<", &AMP; as "&", and so on.

Expected result:
At least in standard mode, &LT; should not be parsed as "<", &AMP; 
should not parsed as "&", and so on.

More information:
SGML declaration for HTML 4 contains the following declaration:

NAMECASE ENTITY NO

This means that entity names are case sensitive.
&LT; is not same as &lt;.

I'm using latest build using cvs.
I'm included to mark this wontfix for two reasons: 
1. we operate the same as IE and nav4x (which both render uppercase entities)
2. there are far bigger problems to address
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX
If this is a HTML 4 compliance issue how can it be WONTFIX?
I have to say it seems rather weird to do some entity parsing case-sensitively
and some case-insensitively.  I agree that this bug perhaps should be fixed in
strict mode, but it's not very serious.  I'm reopening it (and P3->P4) with the
suggestion that it be resolved LATER or REMIND or be assigned to
nobody@mozilla.org (or whereever unowned bugs go these days), mainly because I
agree that an HTML 4.0 compliance issue shouldn't be marked WONTFIX.
Status: RESOLVED → REOPENED
Priority: P3 → P4
Resolution: WONTFIX → ---
Summary: &QUOT; &AMP; &LT; &GT; and &COPY; are not parsed correctly → {html4}&QUOT; &AMP; &LT; &GT; and &COPY; are not parsed correctly
English version arrived. (Thanks, yuu Morita!)
Changing URL.
We are not shipping our Strict DTD for beta1, so compatibility with IE and nav 
is all we can do. I'll mark this remind for our STRICT DTD.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → REMIND
Reminding, this the strict DTD is here.

This is a low priority HTML correctness issue.
Blocks: html4.01
Status: RESOLVED → REOPENED
Resolution: REMIND → ---
Summary: {html4}&QUOT; &AMP; &LT; &GT; and &COPY; are not parsed correctly → &QUOT; &AMP; &LT; &GT; and &COPY; are not parsed correctly
Low priority bug. Moving to the FUTURE list.
Target Milestone: --- → Future
Marking wont fix -- we've decided to remove strictDTD handling.
Status: REOPENED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → WONTFIX
updated qa contact.
QA Contact: janc → bsharma
QA Contact: bsharma → moied
As per rickg's comments making verified. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.