vertical scroll bar keeps scrolling just by moving mouse up and down

RESOLVED DUPLICATE of bug 48037

Status

()

--
minor
RESOLVED DUPLICATE of bug 48037
14 years ago
14 years ago

People

(Reporter: nielstr, Assigned: bugs)

Tracking

({helpwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When using the vertical scroll bar by left-clicking and dragging it, you can
cause the mouse to "stick" by also right-clicking the scroll bar and releasing
the right-click, point to the border so the resize cursor appears, then release
the left button from the initial left-click.  The vertical scroll bar will now
scroll as the mouse moves up and down within proximity to the scroll bar.

I actually kind of like using this bug as a feature, though!  hehe

Reading through the other bug report summaries, it appears that bug # 287959 and
280405 appear to be related to this issue.  However, there wasn't enough info to
be sure.

Reproducible: Always

Steps to Reproduce:
1. Left-click the vertical scroll bar and hold it down (starting the drag operation)
2. Right-click and release the vertical scroll bar while still holding down the
left button
3. Move the mouse to the border of the window so that the resize cursor appears
4. Now release the left mouse button and the scroll bar will follow the cursor
as you move it, so long as the cursor is within close proximity of the scroll
bar and not outside of the form boundaries.

Actual Results:  
I can scroll a web page verticall just by moving my mouse up and down without
any buttons.  To release the scrolling state, simply just left-click again.

Expected Results:  
Use this as a feature when you right-click on the scroll bar .. hehe.  Call it a
sticky scroll bar.  I think the real problem is in the right-clicking of the
scroll bar shouldn't "release" some scrolling state so that the other events
don't occur when you mouse-over them.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050329
Firefox/1.0+

I also see this happen when i do the steps you outlined. I tried to do this with
MSIE, but could not reporduce it there. I would consider this isolated to Firefox.


Changes:
-Adding CC to keep track of this bug.
-Adding keyword "helpwanted" This is for "Bugs or features which require coding
assistance to fix or implement."
-Changing Component to "OS Integration" for two reasons. For a bug to be
confirmed it has to be placed in a more specific category. Second, OS
Integration is described as follows, "Areas where Firefox integrates with the
host desktop environment." This will also change the QA contact individual.
-Changing status to NEW to confirm this unexpected occurance and that it is a
flaw/perk of Firefox that needs to be dealt with (either by fixing or being made
public).

Thank you, Richard Nielsen, for submitting this report. If you have any other
comments to make about this issue, please feel free to add them as this report
and it's respective issue is processed.

Note to QA technician: The bogs refered to in the original report are unrelated.
 287959 is constant, everyday use. 280405 is an issue with the multi-function
middle mouse button.
Assignee: firefox → bugs
Status: UNCONFIRMED → NEW
Component: General → OS Integration
Ever confirmed: true
Keywords: helpwanted
QA Contact: general → os-integration

*** This bug has been marked as a duplicate of 48037 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.