Closed Bug 288393 Opened 20 years ago Closed 20 years ago

Changing a password (outside of tbird) results in repeated login failures, triggering server lockouts when applicable

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 249240

People

(Reporter: jack, Assigned: mscott)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: 20050317

I have had this problem using an SSL IMAP server, and a config that allows
multiple cached connections (the default).  When I change my password, which is
part of an NT domain, the next time I log in to the IMAP server, thunderbird
simultaneously starts several connections, and I get the same error message,
"Login to server A.B.C.D failed." 4 times in a row.  (I click "OK", and it pops
up again).

As it happens, somewhere along the line, I set my "Maximum number of server
connections to cache" to 3, and I get this error message 4 times.

In case it helps or matters, this all I know about the IMAP server software.
* OK Microsoft Exchange IMAP4rev1 server version 5.5.2653.23 (hostname removed)
ready


Reproducible: Sometimes

Steps to Reproduce:
1. Have an IMAP account / configure thunderbird / use it many times 
2. Save your password, encrypted with a master password
3. Do not change thunderbird's default setting for connections to cache
4. Quit Thunderbird
5. Change your password with an external application
6. Start Thunderbird, and initiate the retrieval of messages, if necessary


Actual Results:  
I get the same error message,
"Login to server A.B.C.D failed."
 several times in a row.

Expected Results:  
Thunderbird shouldn't initiate additional connections to the server until there
has been a successful authentication in the previous one.

I don't honestly know if there is a delay in the response from the server during
authentication, or perhaps there is a buggy response from server. . .  Some
security people (morons) think it's a good idea to withhold critical diagnostic
information for reasons that are unknowable (i.e. ****), and I would hate to
think that the IMAP server (which I have no control over) is configured in such
a way, stranger things have happend.  This is something that I would expect from
the same kind of reactionary psychopath who would lock an account after a meager
three authentication failures, though.
Sorry for the spam - I apparently didnt look hard enough the first time.

*** This bug has been marked as a duplicate of 249240 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.