Feedback of the current charset used by libmime

VERIFIED FIXED

Status

MailNews Core
MIME
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: nhottanscp, Assigned: nhottanscp)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Assignee)

Description

18 years ago
When libmime decide a main body charset to use, the charset name to be feed 
backed to the user by putting a mark on the charset menu item.

First we need a way to notify the used charset to webshell from libmime. There 
is a related bug (5938), I will initially assign this bug to mscott.
After that is implemented, libmime can notify the main body charset to webshell.
The UE part (menu check mark) to be done by i18n. Please reassign to nhotta 
then.
(Assignee)

Updated

18 years ago
Summary: Feedback of the current charset used by libmime → FEATURE] Feedback of the current charset used by libmime
(Assignee)

Updated

18 years ago
Summary: FEATURE] Feedback of the current charset used by libmime → [FEATURE] Feedback of the current charset used by libmime

Updated

18 years ago
Blocks: 33977

Comment 1

18 years ago
Seems like this should be "IN" for beta2.  Yes?
Target Milestone: --- → M16

Comment 2

18 years ago
Yes. This is in the spec for Intl Messenger.
Assigned myselsf as QA contact since this is in
Intl area.
QA Contact: lchiang → momoi

Updated

18 years ago
Blocks: 14744

Comment 3

18 years ago
A question about the proposed UI: if we stuff the libmime charset into the
charset menu, how will the user know what the per-folder charset is? Aren't we
losing an important piece of information by reusing the UI?

It also seems strange that the libmime charset is read-only (user can't change
it without changing the message contents), but we're displaying it in read/write
UI of a menu. WHat happens when you change the menu setting?
(Assignee)

Comment 4

18 years ago
A folder charset to be specified as a folder property (bug 32714). Since libmime 
honors the charset in the message, usually the user does not have to worry about 
the folder charset but we may want feedback like showing it in the window title.
A folder charset to be used for messages with no charset labels or the user 
wants to force to set a charset to that folder (i.e. ignore the message labels 
and always use the force charset for that folder).
A charset menu is used for per message override (bug 5938). For the message with 
wrong charset message, the user can override it by the menu. To do so, the user 
wants to see what the current interpretation by libmime before changing it to 
something else.
(Assignee)

Comment 5

18 years ago
Putting beta2 for i18n beta2 criteria items. Contact bobj for question.
Keywords: beta2
(Assignee)

Updated

18 years ago
Blocks: 35851

Updated

18 years ago
Keywords: nsbeta2

Updated

18 years ago
Whiteboard: [nsbeta2+][5/16]

Comment 6

18 years ago
Putting on [nsbeta2+] radar for 5/16 work

Updated

18 years ago
Blocks: 38645

Comment 7

18 years ago
Putting on [nsbeta2-] radar. Removing [5/16]. Missed the Netscape 6 feature 
train.  Please set to MFuture.
Whiteboard: [nsbeta2+][5/16] → [nsbeta2-]
(Assignee)

Comment 8

18 years ago
this means no check marks for the menu

Comment 9

18 years ago
We need to provide user feedback, otherwise this this would be a horrible
usability problem.  The charset menu will most likely be used when a user
cannot read the current message.  Without knowing what mail is currently using
for the message charset, it will be difficult for the user to determine if
it is using the wrong charset and which one to change it to.
Whiteboard: [nsbeta2-]

Comment 10

18 years ago
What is the scope/impact of taking this now?  Putting on [NEED INFO] radar.
Whiteboard: [NEED INFO]

Comment 11

18 years ago
I think it would take me about 2 days to implement a solution for this. Is this
what you are looking for when you ask for NEED INFO?

Comment 12

18 years ago
[nsbeta2+] will take fix by [6/22]
Whiteboard: [NEED INFO] → [nsbeta2+] [6/22] [NEED INFO]

Comment 13

18 years ago
I wanted to comment on phil's comment. Currently the code uses the charset menu
to change the folder charset.  If you haven't already, then you need to take
this out if you want the charset menu to reflect the message's charset.
(Assignee)

Comment 14

18 years ago
Scott, you are right. We are keeping it for debugging purpose because we have 
not had the folder charset UI.
Scott (mscott), could you remove it when you check in for this bug?

Comment 15

18 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.

Comment 16

18 years ago
Cleaning up status whiteboard and marking beta2 minus (6/22 has passed)

Whiteboard: [nsbeta2+] [6/22] [NEED INFO] → [nsbeta2-]

Comment 17

18 years ago
Re-nominating nsbeta2. Removed "[FEATURE]" from Summary and assigned to nhotta.

This is really a bug not a feature as indicated in the summary.  This old
bug (filed in Feb.) was erroneously marked a "[FEATURE]" on the basis that
libmime had no way to provide feedback on the message charset.

The character coding menu exists in the browser, message send and message
view windows. But in the message view window it fails to provide feedback
(check mark).

This is a critical usability issue.  The charset menu will most likely be
used when a user cannot read the current message.  Without the check mark
there is no way to provide feedback on the charset being used and assist
the user to take action to correctly view the message. 

Determining the charset during message viewing is different (from the 
browsing) in that the charset does NOT correspond to the displayed HTML
(which is internally generated for messages).  Instead the charset of the
actual message (parsed by libmime) is needed. The fix is to modify libmime
to pass on the charset info, so it can be reflected in the menu. 

Since mscott is doomed, the proposal is to have mscott give a brain dump
to nhotta who will take ownership for fixing this bug.  Earlier (6/2/2000),
mscott estimated 2 days for this.
Assignee: mscott → nhotta
Whiteboard: [nsbeta2-]
Target Milestone: M16 → ---

Comment 18

18 years ago
Forgot to remove "[FEATURE]"...
Summary: [FEATURE] Feedback of the current charset used by libmime → Feedback of the current charset used by libmime

Updated

18 years ago
Blocks: 43915
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 19

18 years ago
*** Bug 43915 has been marked as a duplicate of this bug. ***

Comment 20

18 years ago
Putting on [nsbeta2+] radar.
Whiteboard: [nsbeta2+]
(Assignee)

Comment 21

18 years ago
Backend code is done and to be reviewed by mscott.
For the JS code, I need a help from Cata to make charset menu to work for 
messenger.
(Assignee)

Comment 22

18 years ago
There is a remaining problem in charset menu. Currently, there is no way to add 
a charset to a cache for mail view charset menu (bug 45172). So cannot put a 
check mark since a menu item cannot be added.
Cata estimated a half day for that. When his code is ready, I can test with my 
changes and check in since it's actually a part of this bug.
Depends on: 45172

Updated

18 years ago
Depends on: 41014
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta2+] → [nsbeta2+] blocked by 41014
(Assignee)

Comment 23

18 years ago
I checked in the backend code. Now the libmime charset is accessible from JS 
code. When the charset menu bug is resolved, I can change the JS code to use 
that charset to put a menu check mark.
(Assignee)

Comment 24

18 years ago
Fix checked in.
Here is how the menu gets a check mark.
* If manual override (by menu) or global override (by pref) exists then override 
charset is checked.
* If no override and message main body Content-Type charset is specified then 
that charset is checked. For multipart message, the first message's charset is 
checked.
* If no charset is specified in the message and no override exists then the 
default view charset is checked.
* The result of auto detection is not used. This is because libmime depends on 
line based detection and no simple and efficient way to get that information. 
However, since auto detection is usually applied to attachments and attachment 
charset does not affect menu checkmark, it should not be a problem.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta2+] blocked by 41014 → [nsbeta2+]

Comment 25

18 years ago
** Checked with 7/14/2000 Win32, Mac and Linux builds **

1. MIME-charset exists --> works OK on Win & Linux
2. Existing MIME-charset has been overridden mnauly or
   globally  --> works on Win & Linux
3. No MIME-charset exists --> works OK on Win & Linux

On Mac, there is a problem. The check mark does not get updated
from message to message. This looks like a FE problem. For example,
I sometime see it updated if I come back to the View | Character
Coding menu several times. It generally gets updated if you highlight
any of the charset sub-set menus (without choosing an item within
the subset menu). 

I'm going to mark this bug fix verified and will file a separate
bug for the Mac update problem.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.