Firefox does not follow file: links with one slash in HTTP-served pages, albeit they are displayed and pasted correctly

RESOLVED DUPLICATE of bug 122022

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 122022
13 years ago
13 years ago

People

(Reporter: Sebastiano Vigna, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

A local file URL of the form

file:/some/dir/file.ext

appearing in a link on a page served by an actual server (e.g., not a page that
is has a file: URL itself) is displayed in the status bar as
file:///some/dir/file.ext, and if copied and pasted on the URL input control
works, but clicking on the link produces no effect.

I do not know whether it would be standardwise correct to follow such a link on
the local filesystem, but the current situation is very confusing for the user,
as the link does not work if clicked, but works if copied.

Java generates such links when asked to turn a File object into a URI object,
which is why I ran into the problem in the first place.

Reproducible: Always

Steps to Reproduce:
1. Create a page with a link such as file:/etc/hosts
2. Serve the page with an HTTP server and try to follow the link 
3. Now copy the link and paste it in on the URL input control

Actual Results:  
It works by pasting, not by clicking.

Expected Results:  
Either both, or none should work.
a http:// document is not allowed to link to file://. The user is allowed to
enter whatever they please in the url bar. So it is consistent, really :)

bug 281904, bug 249295, bug 122022, bug 84128 etc.

see also http://www.mozilla.org/releases/mozilla1.7/known-issues.html#psm

*** This bug has been marked as a duplicate of 122022 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.