link highlighting then scroll wheel

VERIFIED DUPLICATE of bug 50511

Status

()

Core
Layout
P3
minor
VERIFIED DUPLICATE of bug 50511
19 years ago
16 years ago

People

(Reporter: Stephen Ostermiller, Assigned: joki (gone))

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Position the mouse over a link such that the link changes color (from red to
blue on cnn).  Then without moving the mouse, use the scroll wheel on the mouse
to scroll the page.  The link which you were over, keeps its changed color until
you move the mouse (it stays red until you move the mouse).
(Reporter)

Comment 1

19 years ago
Also, on a very related note, find a pulldown combo box on some web page.  Click
in the combo box to bring down the list of selections.  Position the mouse over
the selections and use the scroll wheel.  The web page scrolls out from under
the combo box. The selections remain firmly in place under the mouse causing
them to become separated from the rest of the combo box.

Comment 2

19 years ago
I can reproduce this (at least the first part of the bug) with Win98 build
2000-02-22-08. Confirming. Changing OS to "All."

As for the second part of the bug, 1010mozilla@Ostermiller.com: can you give a
specific URL? You might want to submit this as a separate bug report. Also, it
seems like that might be a duplicate.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
(Reporter)

Comment 3

19 years ago
Both parts of this bug can be seen on this page
<http://bugzilla.mozilla.org/show_bug.cgi?id=28934>

Position your mouse over a link (any link on this page will work).  The url for
the link will appear in the status bar.  Scroll with the mouse wheel and the URL
will remain in the status bar until the mouse is moved or clicked.

Go to a combo box at the top of the page (any will do, product, OS, Priority,
Severity, etc.).  Pull it down.  Position the mouse over the pull down list.
Use the scroll wheel.  The page will scroll, but the pull down list will remain
stationary causing it to seperate from its anchor point on the page.

When I did a search for scrollwheel in the bug reports, there were only two bugs
listed, neither of which were in any way similar to this behaviour.
(Reporter)

Comment 4

19 years ago
Upon further reflection, this appears to be a general scrolling bug rather than
a mousewheel bug.  These symptom appear when you position the mouse and then use
the arrow keys to scroll.  They do not depend upon the mousewheel.
(Reporter)

Comment 5

19 years ago
The second part that I submitted is definitly a duplicate of Bug 27661, so
please ignore second part.

Updated

19 years ago
Assignee: cbegle → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: asadotzler → paulmac

Comment 6

19 years ago
this happens also if you move the mouse over a link and scroll using the arrow
keys, as the reporter found out.

Moving ot XP Toolkits/Widgets, could be tree subcategory (Scrolling w/arrow keys
unpredictable in tree)

Also possible related to Stlye Sheets.

Comment 7

19 years ago
I don't see where this has anything to do with trees or any other XPToolkit
widget. It seems like we are not triggering mouseOut when the page moves out
from under the cursor. changing component to layout, reassigning.
Assignee: trudelle → troy
Component: XP Toolkit/Widgets → Layout
QA Contact: paulmac → petersen

Comment 8

19 years ago
Looks like an event/scroll problem
Assignee: troy → joki
(Assignee)

Comment 9

19 years ago
*** Bug 22377 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

19 years ago
Assiging milestone
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Comment 11

18 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration.
Target Milestone: M17 → Future
(Reporter)

Comment 12

18 years ago
Created attachment 19316 [details]
Distilled test document that shows the problem.
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase

Comment 14

18 years ago
I think this is a dup of bug 20022.
(Reporter)

Comment 15

18 years ago
It appears to be similar to bug 20022.  20022 deals with mouse events not
getting to an object when the mouse has snuck over an object without that object
noticing.  This bug deals with the mouse leaving witout the object noticing.
I'll let somebody more familiar with the code determine if they are caused by
the same thing and can be fixed together.  Incidentally, 20022 seems to wfm and
I added comments to that effect, however I can still duplicate this bug easily.
(Reporter)

Comment 16

18 years ago
This bug appears to be a duplicate of bug 50511 which is mostfreq.

Comment 17

18 years ago
I think so, too.
Marking it as DUP

*** This bug has been marked as a duplicate of 50511 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 18

17 years ago
And it's still out there... vfy
Status: RESOLVED → VERIFIED

Comment 19

16 years ago
hmmm this is now not working aqain...

I've opened bug 202159
You need to log in before you can comment on or make changes to this bug.