Attachment QTime movie does not play back/survive

VERIFIED FIXED

Status

P4
major
VERIFIED FIXED
20 years ago
10 years ago

People

(Reporter: glynn, Assigned: bugzilla)

Tracking

({platform-parity})

Trunk
PowerPC
All
platform-parity

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #329246
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=329246
Imported into Bugzilla on 02/04/99 15:20)

Oct 13 NOVA 4.5 build, G3 System 8.5
nsmail-2, IMAP

1.  Launch Communicator into Messenger and open a rich compose window
2.  Address to yourself, add a subject and attach a QTime .MOV movie...I used a
1.2MB movie by drag and drop to attachment pane
3.  Send the mail and read it with attachments set to be read inline.  Movie
shows up as a link, so select the link to play the movie.

• Browser window is opened, movie starts to try to playback, you see QTime icon,
progress bar proceeds, then at apparent load completion you get a broken QTime
movie icon.

If you simply drag the orig movie from Finder to a browser window it plays back
properly.  This is broken in 4.06 as well; in 4.06 you get an alert that the
attachment is not a quicktime movie.  Saving to disk also fails.

Comment 1

20 years ago
Per today's bug triage, moving to TFV 4.51.  Not a 4.5 stopper.

Comment 2

20 years ago
Isn't there a plugin person who would be a more appropriate person to fix this
bug?
(Reporter)

Comment 3

20 years ago
David you can chat with Alex Musil <amusil>, however I think the problem here is
our mail client is affecting the file or the file name such that it cannot be
read/played after being sent as an attachment, so I do not see this as a plugin
bug.

Comment 4

20 years ago
This may be related to bug:  http://scopus/bugsplat/show_bug.cgi?id=90409 ?

Comment 5

20 years ago
I think 5.0 would be a good time to fix this.

Comment 6

20 years ago
I will transfer to bugzilla when I do my moves of bugs later on.

Updated

20 years ago
OS: All

Comment 7

20 years ago
Gerardok used to be a plugin engineer for 4.X

Comment 8

20 years ago
removing myself from cc list. sorry for the extra traffic

Comment 9

20 years ago
removing myself from cc: list

Updated

20 years ago
Assignee: davidm → amusil

Comment 10

20 years ago
Re-assigned to amusil@netscape.com.

Alex, David doesn't work on Mail/News anymore, so do you have any idea who
should get this one?

Updated

20 years ago
Status: NEW → ASSIGNED
Priority: P2 → P4

Comment 11

20 years ago
I'm not sure what the state is of the mail client, but I'm pretty sure this is
untestable for now.

Comment 12

20 years ago
Can we reassign this to whoever is implementing attatchments in the new mail
client?  This cannot be tested until that code is working.

Comment 13

20 years ago
I believe Jeff Tsai or Paul Hangas may have attachments.

Updated

20 years ago
Target Milestone: M9

Comment 14

20 years ago
Reassigning Plugin bugs to Andrei

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M9 → M12

Updated

20 years ago
Summary: Attachment QTime movie does not play back/survive → [PP] Attachment QTime movie does not play back/survive

Comment 15

20 years ago
<adding [PP] to summary line>

Updated

19 years ago
Blocks: 11091

Comment 16

19 years ago
(target milestone is M11 or M12 - add to beta tracking bug)

Updated

19 years ago
Target Milestone: M12 → M13

Updated

19 years ago
Assignee: av → rhp
Status: ASSIGNED → NEW

Comment 17

19 years ago
I cannot get through endless debug assertions in mimetpla.cpp. Reassigning to
MIME owner for investigation. Please bounce it back to me when the problem is
clear.

NTDLL! 77f76148()
nsDebug::Assertion(const char * 0x10093248, const char * 0x10093238, const char
* 0x10093214, int 1127) line 186 + 13 bytes
nsDebug::WarnIfFalse(const char * 0x10093248, const char * 0x10093238, const
char * 0x10093214, int 1127) line 242 + 21 bytes
nsString::Append(const char * 0x07bb3180, int 35) line 1127 + 31 bytes
nsString::Assign(const char * 0x07bb3180, int 35) line 1008
nsString::nsString(const char * 0x07bb3180, int 35) line 78
MimeInlineTextPlain_parse_line(char * 0x07bb3180, int 35, MimeObject *
0x07bb3ba0) line 174
MimeInlineText_rotate_convert_and_parse_line(char * 0x07bb3180, int 35,
MimeObject * 0x07bb3ba0) line 312 + 20 bytes
convert_and_send_buffer(char * 0x011453f8, int 167, int 1, int (char *, unsigned
int, void *)* 0x08d39a20 MimeInlineText_rotate_convert_and_parse_line(char *,
int, MimeObject *), void * 0x07bb3ba0) line 151 + 15 bytes
mime_LineBuffer(const char * 0x07696038, int 37, char * * 0x07bb3bc8, int *
0x07bb3bd0, unsigned int * 0x07bb3bd8, int 1, int (char *, unsigned int, void
*)* 0x08d39a20 MimeInlineText_rotate_convert_and_parse_line(char *, int,
MimeObject *), void * 0x07bb3ba0) line 238 + 29 bytes
MimeInlineText_parse_decoded_buffer(char * 0x07696038, int 37, MimeObject *
0x07bb3ba0) line 241 + 45 bytes
mime_decode_qp_buffer(MimeDecoderData * 0x07bb3a50, const char * 0x07696038, int
0) line 177 + 30 bytes
MimeDecoderWrite(MimeDecoderData * 0x07bb3a50, const char * 0x07696038, int 74)
line 600 + 17 bytes
MimeLeaf_parse_buffer(char * 0x07696038, int 74, MimeObject * 0x07bb3ba0) line
150 + 20 bytes
MimeMultipart_parse_child_line(MimeObject * 0x07bb7370, char * 0x07696038, int
74, int 0) line 541 + 20 bytes
MimeMultipart_parse_line(char * 0x07696038, int 76, MimeObject * 0x07bb7370)
line 220 + 22 bytes
convert_and_send_buffer(char * 0x07696038, int 76, int 1, int (char *, unsigned
int, void *)* 0x08d3adf0 MimeMultipart_parse_line(char *, int, MimeObject *),
void * 0x07bb7370) line 151 + 15 bytes
mime_LineBuffer(const char * 0x075e12e0, int 76, char * * 0x07bb7398, int *
0x07bb73a0, unsigned int * 0x07bb73a8, int 1, int (char *, unsigned int, void
*)* 0x08d3adf0 MimeMultipart_parse_line(char *, int, MimeObject *), void *
0x07bb7370) line 238 + 29 bytes
MimeObject_parse_buffer(char * 0x075e12e0, int 76, MimeObject * 0x07bb7370) line
223 + 49 bytes
MimeMessage_parse_line(char * 0x075e12e0, int 76, MimeObject * 0x0785cf90) line
173 + 20 bytes
convert_and_send_buffer(char * 0x075e12e0, int 76, int 1, int (char *, unsigned
int, void *)* 0x08d3f990 MimeMessage_parse_line(char *, int, MimeObject *), void
* 0x0785cf90) line 151 + 15 bytes
mime_LineBuffer(const char * 0x093e90eb, int 162793, char * * 0x0785cfb8, int *
0x0785cfc0, unsigned int * 0x0785cfc8, int 1, int (char *, unsigned int, void
*)* 0x08d3f990 MimeMessage_parse_line(char *, int, MimeObject *), void *
0x0785cf90) line 238 + 29 bytes
MimeObject_parse_buffer(char * 0x093e5830, int 177316, MimeObject * 0x0785cf90)
line 223 + 49 bytes
mime_display_stream_write(_nsMIMESession * 0x0785cf40, const char * 0x093e5830,
int 177316) line 615 + 20 bytes
nsStreamConverter::OnDataAvailable(nsStreamConverter * const 0x0785aa90,
nsIChannel * 0x07850030, nsISupports * 0x00000000, nsIInputStream * 0x07bf3d18,
unsigned int 0, unsigned int 177316) line 642 + 24 bytes
nsDocumentOpenInfo::OnDataAvailable(nsDocumentOpenInfo * const 0x07854b60,
nsIChannel * 0x07850030, nsISupports * 0x00000000, nsIInputStream * 0x07bf3d18,
unsigned int 0, unsigned int 177316) line 216 + 46 bytes
nsChannelListener::OnDataAvailable(nsChannelListener * const 0x07854a00,
nsIChannel * 0x07850030, nsISupports * 0x00000000, nsIInputStream * 0x07bf3d18,
unsigned int 0, unsigned int 177316) line 1599
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x07bb6d90)
line 370
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x07bb6fd0) line 93 + 12 bytes
PL_HandleEvent(PLEvent * 0x07bb6fd0) line 522 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x01084390) line 483 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x01e7032e, unsigned int 49317, unsigned int 0,
long 17318800) line 947 + 9 bytes
USER32! 77e71250()
01084390()

Updated

19 years ago
Assignee: rhp → av

Comment 18

19 years ago
Ok, I think I know what the problem was here. The stack trace shows that we
were parsing a QT movie with the plain text parser. This is obviously wrong.
The reason for this was a send side reason that I just fixed yesterday. The
problem was that we were sending binary files as text/plain, which would cause
all sorts of problems on the receive side.

Can you test this with a new build by resending a new message.

- rhp

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Target Milestone: M13 → M14

Updated

19 years ago
Keywords: pp

Updated

19 years ago
Target Milestone: M14 → M15

Updated

19 years ago
Summary: [PP] Attachment QTime movie does not play back/survive → Attachment QTime movie does not play back/survive

Comment 19

19 years ago
Since this bug is marked P4, moving to M17.  If you disagree, please let me know.
Target Milestone: M15 → M17

Comment 20

18 years ago
Change QA from pmock to fenella
QA Contact: pmock → fenella

Comment 21

18 years ago
To Esther..
QA Contact: fenella → esther

Comment 22

18 years ago
Milestone 0.8 has beend released. We should either resolve this bug or update
its milestone.

Updated

18 years ago
Target Milestone: M17 → ---

Comment 23

18 years ago
Reassigning to putterman.
Assignee: av → putterman
Status: ASSIGNED → NEW

Comment 24

18 years ago
reassigning to ducarroz
Assignee: putterman → ducarroz

Updated

17 years ago
Keywords: quicktime
(Assignee)

Comment 25

17 years ago
Using today's Mac Debug build, I can correclty play inline a QT movie attached
into an email message. WFM
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

17 years ago
QA Contact: esther → trix

Comment 26

17 years ago
verified on trunk builds 2002022703 on all platforms
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.