Separate help viewer and help content chrome packages

RESOLVED FIXED in mozilla1.8beta2

Status

SeaMonkey
Help Viewer
P1
normal
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: Benjamin Smedberg, Assigned: Benjamin Smedberg)

Tracking

unspecified
mozilla1.8beta2
Dependency tree / graph
Bug Flags:
blocking-aviary1.5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

13 years ago
Currently the help viewer and help content are in the same chrome package. This
is a bad toolkit dependency and needs to be fixed for 1.8 XULRunner.

In addition, we are going to require localizers to localize the help system as
well, so the localized help files need to live in browser/locales with
everything else, and be shipped in en-US.jar.
(Assignee)

Updated

13 years ago
Priority: -- → P2
Target Milestone: --- → mozilla1.8beta2
(Assignee)

Comment 1

13 years ago
Created attachment 180053 [details]
cvsmove help content for l10n
Attachment #180053 - Flags: second-review?(chase)
Attachment #180053 - Flags: first-review?(gandalf)
Ohoho, a few weeks ago you were so against this move before 1.5... Should I
prepare patch for this? :)
Attachment #180053 - Flags: first-review?(gandalf) → first-review+
If we're doing this, shoudn't we just pack the help viewer into toolkit.jar?
(Assignee)

Comment 4

13 years ago
Yes, that is exactly what I plan to do.

Comment 5

13 years ago
Comment on attachment 180053 [details]
cvsmove help content for l10n

sr=chase

Is the app already sufficiently removed from the layout of code in CVS that
moving these files around doesn't require any other changes to point to the new
location?
Attachment #180053 - Flags: second-review?(chase) → second-review+
It does require additional patch. I asked bsmedberg if I should write it, or
he'll do this.
(Assignee)

Comment 7

13 years ago
I'm making the patch, will be up shortly.
Flags: blocking1.8b3?
Flags: blocking-aviary1.1+
Priority: P2 → P1
Whiteboard: [blocks l10n freeze]
(Assignee)

Comment 8

13 years ago
I am going to need to patch some of these copied files after they have been
moved. Can we do the cvs copies now, so that I can prepare that patch?
(Assignee)

Comment 9

13 years ago
Created attachment 180483 [details] [diff] [review]
Conditionally remove help buttons from PSM, rev. 1

During this process, I discovered that PSM is displaying help buttons that
don't do anything functional. Discussion with mconnor decides that these
buttons ought to be hidden since we don't actually have documentation behind
them. Requesting second-review from brendan since I don't know who else to ask,
is PSM still majorly unowned?
Attachment #180483 - Flags: second-review?(brendan)
Attachment #180483 - Flags: first-review?(mconnor)
(Assignee)

Comment 10

13 years ago
Kaie, are you still around? Can you review this?

Updated

13 years ago
Attachment #180483 - Flags: first-review?(mconnor) → first-review+
(In reply to comment #9)
> During this process, I discovered that PSM is displaying help buttons that
> don't do anything functional. Discussion with mconnor decides that these
> buttons ought to be hidden since we don't actually have documentation behind
> them.

On a related note, Thunderbird did this some time ago via a toolkit hack -- see
bug 256915 and attachment 165624 [details] [diff] [review].  There are still other places where help
buttons are used in Thunderbird that aren't in PSM, tho, so the ifdef still
"has" to stay.
Bob Relyea may be willing to help -- IIRC he recently posted a big patch for PSM
for smart-card support.

/be

Comment 13

13 years ago
So I have 2 comments about the PSM patch...

1) I don't have any problems with commenting out the non-functioning help
buttons in PSM until we can get content to turn them on.... however....

2) It appears that the patch is actually commenting out much of the *WORKING*
PSM UI (maybe I'm misunderstanding how xul works, but it appears that the this
patch actually comments out the Cert Manager, for instance). That I would
definately not support (especially since I've been adding patches to fix minor
bugs in the UI).

soo.. r+ on the idea, but r- on the patch unless someone can explain to me how
the  various dialogs still work with their xul packages commented out (or that
the '*' in the jar.nm doesn't comment out the xul content, only linking help to
that content.

bob
(Assignee)

Comment 14

13 years ago
Heehee! The * in the jar.mn is not a comment marker, it means that the XUL files
will be run through the XUL preprocessor. So you needn't worry, the only UI I
removed was the nonfunctional help buttons.

Comment 15

13 years ago
Comment on attachment 180483 [details] [diff] [review]
Conditionally remove help buttons from PSM, rev. 1

comment 14 is sufficient explanation;). r+
Attachment #180483 - Flags: second-review?(brendan) → second-review+
(Assignee)

Updated

13 years ago
Attachment #180483 - Flags: approval1.8b2?
(Assignee)

Comment 16

13 years ago
Created attachment 180702 [details]
cvsmove help content for l10n, rev. 1.1

The first file was malformed due to a regex error on my part, now fixed.
Comment on attachment 180702 [details]
cvsmove help content for l10n, rev. 1.1

Move completed.
(Assignee)

Comment 18

13 years ago
Created attachment 180730 [details] [diff] [review]
Make help content an integral part of the build process, rev. 1

This patch unfortunately contains bits and pieces of bug 289461 and bug 287262,
but it works and is ready for review.
Attachment #180730 - Flags: first-review?(gandalf)
Comment on attachment 180730 [details] [diff] [review]
Make help content an integral part of the build process, rev. 1

sweet :)
Attachment #180730 - Flags: first-review?(gandalf) → first-review+
(Assignee)

Updated

13 years ago
Attachment #180730 - Flags: approval1.8b2?
Comment on attachment 180730 [details] [diff] [review]
Make help content an integral part of the build process, rev. 1

>Index: browser/locales/en-US/chrome/help/firebirdhelp.rdf
>                         nc:emptysearchtext="[No matching items found.]"
>-                        nc:emptysearchlink="chrome://help/locale/welcome.xhtml#search_tips"/>
>+                        nc:emptysearchlink="chrome://browser/locales/help/welcome.xhtml#search_tips"/>
>                 </rdf:li>

welcome.xhtml is in toolkit, so this path is wrong.  That was the only thing I
noticed in five minutes of looking, and it's easily fixable before checkin.

Comment 21

13 years ago
Comment on attachment 180483 [details] [diff] [review]
Conditionally remove help buttons from PSM, rev. 1

a=asa
Attachment #180483 - Flags: approval1.8b2? → approval1.8b2+

Comment 22

13 years ago
Comment on attachment 180730 [details] [diff] [review]
Make help content an integral part of the build process, rev. 1

a=asa
Attachment #180730 - Flags: approval1.8b2? → approval1.8b2+
(Assignee)

Comment 23

13 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 24

13 years ago
This bug caused Bug 291006.
(Assignee)

Comment 25

13 years ago
I had forgotten to check in attachment 180483 [details] [diff] [review]; this is now fixed also.

Updated

13 years ago
Flags: blocking1.8b3?

Comment 26

13 years ago
Options->Security->Revocation Lists still has a Help button. And pressing that
opens two empty Help windows...
This change doesn't seem to work:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=crlManager.xul&branch=&root=/cvsroot&subdir=mozilla/security/manager/pki/resources/content&command=DIFF_FRAMESET&rev1=1.19&rev2=1.20

Comment 27

13 years ago
*** Bug 309052 has been marked as a duplicate of this bug. ***

Comment 28

13 years ago
(In reply to bug 309052 comment #0)
> CRL manager (crlManager.xul) dialog has a Help button that opens empty help
> viewer window. The help button pointer is validation-crl-manage which is not
> defined in Firefox help documentation.

The second patch in this bug missed that. Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 29

13 years ago
Created attachment 198233 [details] [diff] [review]
remove the Help button from crlManager
Attachment #198233 - Flags: first-review?(mconnor)

Updated

13 years ago
Whiteboard: [blocks l10n freeze] → [no l10n impact anymore]
(Assignee)

Comment 30

13 years ago
Please file a new bug for remaining issues.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Attachment #198233 - Attachment is obsolete: true
Attachment #198233 - Flags: first-review?(mconnor)

Updated

13 years ago
Whiteboard: [no l10n impact anymore]
Product: Toolkit → Seamonkey
You need to log in before you can comment on or make changes to this bug.