Toolkit applications sometimes not visible on taskbar

VERIFIED DUPLICATE of bug 246531

Status

()

Firefox
Shell Integration
VERIFIED DUPLICATE of bug 246531
13 years ago
11 years ago

People

(Reporter: Anil Polat, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Sometimes the location on the taskbar will change, or become invisable. Alt-Tab
fixes the problem, however it happens often and randomly.

Reproducible: Didn't try

Comment 1

13 years ago
Happens for me as well [On trunk], a bit less often, though I believe there is
another bug somewhere with this issue (QA-Person, please Search for a dupe
somewhere before confirming this bug).
Version: unspecified → Trunk

Comment 2

13 years ago
this happens to other apps besides thunderbird and I've heard it's a windows
bug, basically.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

13 years ago
I still have this problem with the latest (1.5) version of Thunderbird, however,
for Firefox, sometimes it will disappear completly from the taskbar, only to
reappear again after and Alt+Task.

Comment 5

13 years ago
I see this behavior also, both with 1.0.7 and 1.5b1.  Thunderbird is still
running but disappears from the Windows taskbar.  I can still get to it with
alt-tab.  I haven't noticed any pattern about when it does and doesn't happen. 
FYI, I keep my taskbar vertical along the right side of the screen.

Comment 6

12 years ago
Confirming this bug on TB 1.5 (final build, non-updated RC2) German unter Win XP Pro SP2 German, classic theme, desktop and start menu. Task bar is unlocked and set to default behaviour (screen bottom, keep visible, keep in forground).

TB main window icon disappears at times when 
* an external link (i.e. http:// address) in the mail preview pane is clicked and the launched app window comes into the foreground;
* a compose new mail window is firts launched and comes into the foreground.

Steps to reproduce: none, behaviour is random.

The pattern indicated above seems to link the problem to the main window losing focus (which explains why it reappears when it gets focus back through task switching). As to this being a Windows bug: I've been running nearly every task bar enabled Windows flavour since 1996 (at home and at work, as an admin and as a user) and have never noticed this behaviour in an application window before.
The last days I have seen this bug multiple times on different computers where WinXP is installed. David, it only happens for Firefox and Thunderbird. Both are the latest builds from the 1.8 branch. No other applications are affected. So I don't believe that it is a bug in Windows.

Does anyone use the classic style instead of Luna?

Should bug 345856 (Firefox) be duped to this one? Which component we have to use than?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

12 years ago
Randomly AND frequently!!  Disappears behind other applications, gone from taskbar, so to use it must minimize everything else, one at a time, to get to it.  THEN the icon reappears on the taskbar but at the end, as if it were opened just now.  Cannot use "show desktop" to find it, must minimize others one by one.
(In reply to comment #8)
> Randomly AND frequently!!  Disappears behind other applications, gone from

If this really happens frequently to you please have a closer look what you are doing. Clicking an external link, opening a helper application or something else. I believe some user action or software combination could be the cause.

Summary: Changes places on taskbar or non visable on taskbar-randomly → Thunderbird sometimes not visible on taskbar

Comment 10

12 years ago
NOT Thunderbird!!  I was the one who made the complaint re FIREFOX!!!!

As to what I am doing at the time when it disappears, NOTHING!!

Use FF for a while, then go to calendar app, or email, then look for FF to go back to, and it's GONE!!!!

Have to then minimize all other apps to find it!!!

And why is it so damn SLOW???  When I do find it, can do a few clicks, then it STOPS and sits there for about 2 or 3 MINUTES!!  I get tired of staring at nothing, so go do something else, then have to go through all that AGAIN!!!  The "finding" of it and the WAITING for it to wake up!!!

I read on a blog somewhere that Windows steals memory from FF and that FF has to get it back, thus the wait.  BUT the "fixes" given there were totally incomprehensible and I could not even find WHERE to do the fixes.

What settings can be changed?  (1) To stop it from disappearing, and (2) To stop it from sleeping on the job?

Comment 11

12 years ago
As to this comment:

"...please have a closer look what you are
doing. Clicking an external link, opening a helper application or something
else. I believe some user action or software combination could be the cause."

Am I then not supposed to DO anything?  Actually, it happens when I am NOT doing anything with FF.
> NOT Thunderbird!!  I was the one who made the complaint re FIREFOX!!!!

So product of this bug was initially set as Thunderbird. And there was nothing mentioned about Firefox. So please be objectiv! I will change it to Firefox and OS integration because it will be better suited and enhance the summary.(In reply to comment #10)

> Use FF for a while, then go to calendar app, or email, then look for FF to go
> back to, and it's GONE!!!!
> Have to then minimize all other apps to find it!!!

Why you have to minimize all other applications when Alt+Tab fixes it for you?

What happens in such a state if you close another application and new space gets free on the taskbar? Does the Firefox button comes back?

Please tell us something about your hardware configuration.

Assignee: mscott → nobody
Component: General → OS Integration
Product: Thunderbird → Firefox
QA Contact: os.integration
Summary: Thunderbird sometimes not visible on taskbar → Toolkit applications sometimes not visible on taskbar
Some minutes ago I had the behavior again. The Firefox taskbar button was hidden while Firefox is running and listed within the task manager. It happend with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9pre) Gecko/20071030 BonEcho/2.0.0.9pre

Is there any change or better which way I have to use to track this problem?
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 246531
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.