Windows occasionally disappear from or appear twice in Windows XP's taskbar

RESOLVED WONTFIX

Status

()

Core
Widget: Win32
--
major
RESOLVED WONTFIX
14 years ago
a year ago

People

(Reporter: John Flatness, Unassigned, Mentored)

Tracking

({helpwanted})

1.8 Branch
x86
Windows XP
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=c++])

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; MathPlayer 2.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040608 Firefox/0.8.0+

Sometimes, when I have several browser windows open, but none are minimized, 
all are just on top of each other and maximized so I can only see the top 
window, the windows on the bottom can get "lost" from the taskbar.  And no, 
this is not the XP feature of grouping the buttons, just some of the windows 
are missing.  
This usually happens after I go to do something else than browsing.  I will 
return to the screen, and many times I don't notice the bug until after I 
minimize the top window, and another comes into focus.  Once I can see it on 
the screen, I notice the sliding animation of a button being added to the 
taskbar, and realize that I have less buttons than windows.

Reproducible: Sometimes
Steps to Reproduce:
1.Open several Firefox windows, and maximize them.
2.Do something else on your computer for a while
3.Check taskbar.

Actual Results:  
All but one taskbar button is missing.

Expected Results:  
All buttons should be there.
I've been seeing this a lot over the last day or two on Win XP SP2.  I've been
using recent nightlies.  I have no clue how to reproduce it, it always takes me
by surprise.  (Strange that my problem seems more recent than yours.)
I've also seen this. Taskbar icons for windows just disappear, and sometimes
reappear. The window seems completely gone. It seems to happen after switching
through different windows but I really can't reproduce this at will. It has only
happened for me with multiple windows (and most likely multiple tabs, but that
probably isn't the issue). Next time it happens I will try looking into it further.

This is a hard one to diagnose as it can't be easily reproduced. Further testing
is really needed.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted

Comment 3

14 years ago
i also have this problem many times a day. i only ever have one browser open, i
just use tabs. if i switch to another app the taskbar entry will be gone, until
a time when the actual window should be apearing (ex. minimizing the rest of
your windows) and then the taskbar entry reappears at the end.

Comment 4

14 years ago
I can confirm this as well. It seems to happen frequently with Firefox 1.0 on
WinXP SP1, but I don't know how to reproduce this. I've noticed that even when
it doesn't show up on the taskbar, it is shown in the apps that you see when you
press Alt+Tab. After you alt+tab to it, it gets added to the taskbar again.

Comment 5

14 years ago
I can confirm this as well. Just now I had an instance of Windows Explorer,
Thunderbird 1.0, MS Word 2000, and Firefox 1.0. I did some things in Windows
Explorer (I had not minimized Firefox either) then realized the Firefox Taskbar
icon was gone. I Minimized the other windows I had open and put focus on Firefox
(which was there, though without its Taskbar icon) and its Taskbar icon
reappeared. I remember having this problem with Mozilla 1.7 and earlier too.

Comment 6

14 years ago
anyone feel like running spy++?

Comment 7

14 years ago
I have also experienced this issue, when I move focus to another window and
after using it for a period of time, the taskbar icon for both the Firefox and
Thunderbird applications disappears until focus is returned to it. I haven't
investigated this that much so couldn't give you any detailed accounts but it
definately is an issue.

Comment 8

14 years ago
Also experienced this with WinXP SP2.  Alt-tabbing to select the missing taskbar
button will make it reappear.  My opinion is that this is only a minor
nusciance, as the window is still there, but it should be fixed eventually
(perhaps in the 1.1 release).  Seems fairly random to me.
*** Bug 276606 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
I've seen this happen to Dreamweaver, notepad and MS Word as well. It's a Window
bug.

Comment 11

14 years ago
I have only experienced this with Mozilla products. A temporary fix for this is
just to alt+tab the window into focus. I think it happened to me once when that
window was actually in focus, but I might just be crazy.

Comment 12

13 years ago
(In reply to comment #11)
> I think it happened to me once when that window was actually in focus, but I 
> might just be crazy.

It just happened to me this way again, with thunderbird.

Comment 13

13 years ago
Was just using Adobe Acrobat reader plug-in, and it happened every time with
that, after I clicked on a pdf, it loaded within Mozilla, and lost the taskbar
button.  I'm using Adobe Reader's plug-in version 6.0.2, and it is VERY
reproducable at this link:

http://www.mmdl.org/spring2005/Schedules.html

I scroll down and click on one of the schedule pdf files, and it loads the pdf
file, and then loses the taskbar button.  This is the first time I've heard of
it being reproducable, so please feel free to email me if you have any
questions!!  I'm using Firefox v1.0 on WindowsXP.

Thanks!
Matt Leavitt
actorma@yahoo.com

Comment 14

13 years ago
(In reply to comment #13)
> Was just using Adobe Acrobat reader plug-in, and it happened every time with
> that, after I clicked on a pdf, it loaded within Mozilla, and lost the taskbar
> button.  I'm using Adobe Reader's plug-in version 6.0.2, and it is VERY
> reproducable at this link:
> http://www.mmdl.org/spring2005/Schedules.html

I haven't been able to reproduce it that way. I also use Firefox 1.0 under
WinXP, but with an Acrobat 6.0.3. However, I can also confirm the bug.

Comment 15

13 years ago
(In reply to comment #14)
> (In reply to comment #13)
I'm using Adobe Reader's plug-in version 6.0.2, and it is VERY
> > reproducable at this link:
> > http://www.mmdl.org/spring2005/Schedules.html
> 
> I haven't been able to reproduce it that way. I also use Firefox 1.0 under
> WinXP, but with an Acrobat 6.0.3. However, I can also confirm the bug.

Maybe only my slightly older version of Acrobat (6.0.2 vs. 6.0.3) does it. 
Maybe it's the OS - I have WinXP SP2.  Not sure.  Do know mine is reproducable.
 Hmm...

Comment 16

13 years ago
I was able to reproduce it pretty consistently today using Firefox 1.0.2 and
Acrobat Reader 6.0.0.  I had one window open, and clicked on a link (which I
cannot, unfortunately, provide here), and the PDF popped up in a second window.
 When I closed the PDF window, the task bar icon disappeared for both windows,
leaving NO visible task bar icons.

Comment 17

13 years ago
*** Bug 265348 has been marked as a duplicate of this bug. ***

Comment 18

13 years ago
I have had this problem too, in Fx 1.0.4 and earlier.  I'm running WinXP SP2. 
Although I also cannot reproduce at will, it seems to occur more when I have an
excessive number of windows open in the taskbar (I'm not sure this problem
occurs if you use the 'Group similar taskbar buttons' under Taskbar Properties).
*** Bug 295386 has been marked as a duplicate of this bug. ***

Comment 20

13 years ago
*** Bug 297267 has been marked as a duplicate of this bug. ***

Comment 21

13 years ago
This bug isn't unique to Firefox. It happens in SeaMonkey/Suite as well.

Prog.

Comment 22

13 years ago
Couldn't find a seperate bug, but this same problem also occurs with Thunderbird.
(Reporter)

Comment 23

13 years ago
As far as I can tell, I see this bug with both Firefox and Thunderbird, and I
see reports for the Application Suite, too, but only under Windows XP.
I know I have never seen it on Win98 or Linux.
Component: OS Integration → Widget: Win32
Product: Firefox → Core
Summary: Firefox windows occasionally disappear from taskbar → Windows occasionally disappear from WinXP taskbar
Version: unspecified → 1.0 Branch

Comment 24

13 years ago
*** Bug 306891 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

13 years ago
Assignee: bugs → win32
QA Contact: os.integration → ian
Version: 1.0 Branch → 1.8 Branch
*** Bug 310577 has been marked as a duplicate of this bug. ***

Comment 26

13 years ago
The demo on this site seems to be able to fairly reliably make the window
disappear from the taskbar: www.kiko.com

I'm using firefox 1.0.7 on windows xp sp1.

Steps to reproduce:
1) Close all firefox windows.
2) Open new firefox window
3) Open second tab in firefox
4) Go to www.kiko.com then click on 'Try a demo...'
5) Whilst the 'kiko loading...' message is up the background will go white and
firefox will freeze (maybe that is another bug in firefox?); at that point try
clicking on the other tab in firefox (maybe several times) and firefox will
disappear from the taskbar.

Comment 27

13 years ago
The kiko problem also happens in firefox beta 2, but in beta 2 you get a message
box saying that the script in this webpage may be busy do you wish to continue;
and if you click continue the taskbar button for firefox reappears.
*** Bug 312633 has been marked as a duplicate of this bug. ***
It seems (to the uneducated, such as me) that the window is actually being destroyed and a new one created in its place.

The window freezes and a second taskbar button appears. The two buttons can be independently selected, but the new window doesn't come to the front as the application is still in a state of general unresponsiveness. Then one of the taskbar buttons disappears; the remaining buttons don't slide smoothly as usual, so it's not possible to tell which one disappeared, but I assume it's the original one; the remaining window simultaneously unfreezes.

This happens far more frequently (positively often) on a slow, memory-starved computer.

It seems (i.e. all of the following is subjective) to be triggered most often by switching between tabs or messages, but quick scrolling or lots of clicking (especially on Flash content) also sets it off.
Summary: Windows occasionally disappear from WinXP taskbar → Windows occasionally disappear from or appear twice in Windows XP's taskbar

Comment 30

13 years ago
*** Bug 321348 has been marked as a duplicate of this bug. ***

Comment 31

13 years ago
I can add a reproducable situation with Thunderbird Version 1.5 (20051201). I have tested this on two PCs both with Win XP Sp2 with all updates. One PC is quite new and fast (3.6GHz), the other is quite old and slow (1.5GHz).

1. Open Thunderbird and configure that messages are saved automatically every 1 minute while composing 
2. Compose a new message
3. Open as many other windows programs so that the two Thunderbird icons are grouped to 1 icon
4. Return to the compose window 
5. Add some large attachements (>20MB), so that Thunderbird has something to do while autosaving the new message 
6. Add an email adress to the To field
7. Wait for autosave of the message

When the message is autosaved the compose window disappears and both Thunderbird icons disappear from the task bar. They are still accessible with Alt-Tab.
*** Bug 362853 has been marked as a duplicate of this bug. ***

Comment 33

11 years ago
This happened today with a minimized Firefox window with multiple tabs.
Alt-Tab switching brought back the task bar icon and the window.

Firefox version:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Updated

11 years ago
Duplicate of this bug: 345856
Duplicate of this bug: 380821

Comment 36

11 years ago
Still happening in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Duplicate of this bug: 289560

Comment 38

10 years ago
I just noticed this behavior starting yesterday, I have XP Pro fully updated running Firefox 2.0.0.14. No apparent pattern, just that one of the Firefox buttons disappears from the taskbar if I have multiple Firefox windows open. Minimizing all running applications on the taskbar will bring back the missing button sometimes. I have "group similar taskbar buttons" turned off so it's not related to that.

Comment 39

10 years ago
I may know of a site where this bug might be more reproducible.  I started a site recently at http://ucoz.com.  They use a lot of popups, especially in their "visual editor" and the "file manager".  These popups vanish a lot.

Note: I do happen to have two monitors.  I was putting a lot of those popups into my second monitor, which is to the /left/ of my primary.  That might be related too.  However, I think I have seen this bug back in XP Pro SP1 and Firefox 1.x.  These days, I run XP Pro SP3 and FF 3.0.4.

Updated

9 years ago
Duplicate of this bug: 490821

Comment 41

9 years ago
This is happening on Windows XP x64, single monitor. I've seen this reproduced on various different video cards (ATI and nVidia) and video drivers as well.

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Assignee: win32 → nobody
QA Contact: ian → win32

Updated

9 years ago
Duplicate of this bug: 533198

Comment 43

9 years ago
I've got the 'group similar taskbar buttons' selected and when my firefox disappears from the taskbar it is actually listed in my Windows Explorer 'similar taskbar' group.  

If I use File > New Window to open a bunch of new firefox instances so that they get grouped, they get grouped under a Firefox group - but the original window doesn't 'move' from the Windows Explorer group to join them.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

Updated

9 years ago
Duplicate of this bug: 427169

Comment 45

6 years ago
Still happening to me on XP Pro SP3 with "Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0".

Comment 46

5 years ago
Firefox latest version 24.0 and this is STILL happening with windows XP sp3

Will this ever get fixed?

Comment 47

5 years ago
Windows XP Pro Ver 2002 SP3, machine 1.2GHz 1G Ram, Firefox 25.0.
ONLY the Firefox taskbar button ever disappears (I don't recall this ever happening until I upgraded to ver 25).
No recognized pattern of causation, but I'll be keeping a closer eye on it now.

Comment 48

4 years ago
Same issue here. Sometimes the Firefox tab in the Taskbar just disappears.
The app is still open and operating fine. I am using Firefox 28.0 with 
Windows XP PRO SP3 and all available updates for it. Not really sure when
this started, but it is very annoying. Please try to get this fixed.

Updated

4 years ago
Mentor: jmathies, tabraldes, netzen
Whiteboard: [good first bug][lang=c++]

Comment 49

4 years ago
I would like to work on this bug. Could you please guide on this as this is my first bug and i am new to opensource.
Hi Naveen,

We have some taskbar code here:
http://dxr.mozilla.org/mozilla-central/source/widget/windows/WinTaskbar.cpp

But it only uses IID_ITaskbarList4 which isn to available in Windows XP
There is a ITaskbarList which is available on XP though and it has an AddTab function for adding an item to the taskbar.  It would be possible to make WinTaskbar work with ITaskbarList.

Here's code that uses AddTab:
http://dxr.mozilla.org/mozilla-central/source/widget/windows/TaskbarWindowPreview.cpp#276

But that code is only used when the taskbar preview is enabled. 

I'm not sure if implementing ITaskbarList and using AddTab always would help here or not.  Thoughts Jim?
It seems like the issue is that the window appears but that the taskbar buttond oes not.
Flags: needinfo?(jmathies)

Comment 51

4 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #50)

> I'm not sure if implementing ITaskbarList and using AddTab always would help
> here or not.  Thoughts Jim?
> It seems like the issue is that the window appears but that the taskbar
> buttond oes not.

I'm not sure if this will help, I think we're dealing with a weird bug in XP here. I've tried reproducing using the steps in comment 1 but haven't had any luck.
Flags: needinfo?(jmathies)

Comment 52

a year ago
is this still open? I can take this one.
No longer actively supporting XP.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.