Reply header reads local time, not the original message time/TZ

RESOLVED DUPLICATE of bug 218926

Status

Thunderbird
Preferences
RESOLVED DUPLICATE of bug 218926
13 years ago
10 years ago

People

(Reporter: Kari Suomela, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 1.0.2 (20050317)

// Change the reply header
// 0 - No Reply-Text
// 1 - "[Author] wrote:"
// 2 - "On [date] [author] wrote:"
// 3 - User-defined reply header. Use the prefs below in conjuction with this:
user_pref("mailnews.reply_header_type", 3);

Apparently the time variable is wrong here.

// If you set 3 for the pref above then you may set the following prefs.
user_pref("mailnews.reply_header_authorwrote", "%s said the following");
user_pref("mailnews.reply_header_ondate", "on %s");
user_pref("mailnews.reply_header_separator", " ");
user_pref("mailnews.reply_header_colon", ":"); 
// The end result will be [authorwrote][separator][ondate][colon]

Reproducible: Always
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

13 years ago
Not fixed!!!
TZ must be read from the original message header, NOT the local machine

Comment 3

12 years ago
You have not said WHY.

It can be circumvented by stating the time zone in the header, e.g.

pref("mailnews.reply_header_ondate", "On %s (Central European Time)");
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> You have not said WHY.
> 
> It can be circumvented by stating the time zone in the header, e.g.
> 
> pref("mailnews.reply_header_ondate", "On %s (Central European Time)");

Duh! What good woud that do, when I am in EDT and receive messages from all over the world?! The TZ should be read from the INCOMING message.
> 

Comment 5

12 years ago
(In reply to comment #4)
> Duh! What good woud that do, when I am in EDT and receive messages from all
> over the world?! The TZ should be read from the INCOMING message.

Duh all you like ... but you still haven't given a reason. I disagree. I think it is important to show the recipient when there message was received in local time and not in their time.

So for example, they see it came in at 11pm and understand why it took you quite some time to reply.
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Duh! What good woud that do, when I am in EDT and receive messages from all
> > over the world?! The TZ should be read from the INCOMING message.
> Duh all you like ... but you still haven't given a reason. I disagree. I think
> it is important to show the recipient when there message was received in local
> time and not in their time.
> So for example, they see it came in at 11pm and understand why it took you
> quite some time to reply.

And more "duhs"! Look up in the dictionary what "quote" means. Including message arrival time in the QUOTE HEADER is nonsense. If you'd like a live demonstration of correct operation of the quote header, download a trial copy of PMMail. Too bad the development was stopped. Those guys knew what they were doing.


QA Contact: preferences

Updated

10 years ago
Assignee: mscott → nobody

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 218926
You need to log in before you can comment on or make changes to this bug.