Closed Bug 290836 Opened 16 years ago Closed 15 years ago

option in Safe mode to disable an extension for the normal mode

Categories

(Toolkit :: Add-ons Manager, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: michael.wiktowy, Assigned: bugs)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

There is a flaw in the troubleshooting workflow for faulty extensions:
- I encountered a bug on my recent update to Firefix 1.0.3 where an extension
was causing a default empty firefox window to load but nothing to be drawn and
none of the controls were responsive.
- There are known issues with 1.0.3 and some extensions so I proceeded to
troubleshoot which extension was causing be grief. The problem was, in
safe-mode, there is no option other than uninstalling an extension.
- So to find which extension was causing me a problem, I had to uninstall the
extensions one by one and restart Firefox until the problem went away and then
reinstall the extensions one by one to make sure there were not multiple
extensions that were problematic.

This turned out to be a long and annoying process.
In the end, the problem disappeared after uninstalling/reinstalling User Agent
Switcher.



Reproducible: Always

Actual Results:  
There was only an option to uninstall extensions.

Expected Results:  
Ideally, from safe-mode, the users should be able to selectively enable and
disable extensions for when normal-mode is run as well as being able to
uninstall the extensions.

This would allow for a faster tracking down of problems and, more importantly, a
much faster recovery of extensions that were not found to be problematic.
*** Bug 290856 has been marked as a duplicate of this bug. ***
no dupes found
-> NEW

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: Add an option in safe-mode to disable extension in normal-mode → option in Safe mode to disable an extension for the normal mode
Version: unspecified → Trunk
Interesting that there is a small wave of new CC:'s every new FF release. Leads
me to believe there are some fussy extensions out there.
Are there plans for this feature in the FF 1.1 timeframe?
You can uninstall or disable extensions selectively on the trunk now since the
patch for bug 293548 was checked in.

Also related, bug 294101

This should probably be resolved WFM.
Tested with DeerPark and I am able to disable or uninstall extensions while in
safe mode.
Resolving > WFM
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.