HTMLCanvasElement should no longer be an HTMLImageElement

RESOLVED DUPLICATE of bug 557840

Status

()

P4
normal
RESOLVED DUPLICATE of bug 557840
14 years ago
8 years ago

People

(Reporter: ian, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
HTMLCanvasElement should inherit from HTMLElement.

The old attributes from HTMLImageElement that we used to implement should be
nuked. This includes things like border="" and vspace="" no longer needing to be
attribute mapped.
(Reporter)

Updated

14 years ago
Component: Layout: Misc Code → Layout: Canvas
QA Contact: layout.misc-code → layout.canvas

Comment 1

14 years ago
It seems that the canvas interface already does that:
<http://lxr.mozilla.org/seamonkey/source/dom/public/idl/html/nsIDOMHTMLCanvasElement.idl>

However, there is some attribute handling defined for attributes that should not
be supported:
<http://lxr.mozilla.org/seamonkey/source/content/html/content/src/nsHTMLCanvasElement.cpp>
Priority: -- → P4
Assignee: vladimir → nobody
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
OS: Linux → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 557840
You need to log in before you can comment on or make changes to this bug.