Line wrapping enhancements

VERIFIED FIXED

Status

MailNews Core
Composition
P3
enhancement
VERIFIED FIXED
20 years ago
10 years ago

People

(Reporter: lchiang, Assigned: rhp (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
<transferred from Netscape internal bug database, bugsplat 329733 on 2/4/99>
Commented out the part about customer information.  If you need to see that, go
back to the bugsplat bug report.>

Communicator Professional Edition, Export,
Physical Memory Available to Windows:  65,052 KB, 76% Free
Tested on Windows 95, not on any other platform:

Communicator 4.5 PR2 and M15, Windows 95

------------------------------------------------------------------

1 - I like being able to have long lines in my mail message wrap,
however, found a small side effect which is a little annoying.  If I
save the message with wrapped lines the saved text message is saved
with those lines wrapped.  This has actually caused me to have to
re-write a program that converts an emailed report to a format which I
can easily import into Excel.  The problem is annoying, however if I
must choose between one or the other, I would choose to have long
lines wrap.


------- Additional Comments From shartley  10/19/98 14:39 -------

Additional customer input on line wrapping....... (sorry!)...

I remember a little better the problem I had with Netscape 4.5
pr2 line wrapping.  I would like it if long lines could wrap without
actually inserting newline characters into the message itself.  I would also
like it if the long lines simply wrapped to the width of the window rather than
the line length set in preferences.

In other words, if I view a message with long lines and those lines
are wrapped to make it easier to read, I would like to be able to
stretch the window and the lines adjust accordingly.  Also, I would
like to be able to save or print the message without the extra newline
characters.

Updated

20 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

20 years ago
QA Contact: 4080 → 4495
(Reporter)

Comment 1

20 years ago
qa contact to jeffu
(Reporter)

Updated

19 years ago
QA Contact: 4495 → 4080

Updated

19 years ago
Assignee: ducarroz → rhp
Status: ASSIGNED → NEW
Target Milestone: M9

Comment 2

19 years ago
I think this bug deals with reading messages, not sending them. So it probably
belongs to rhp. M9, though.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Target Milestone: M9 → M12
(Assignee)

Comment 3

19 years ago
Sorry...moving enhancement requests out past B1.

- rhp

Comment 4

19 years ago
I agree that this is a post-PR1 bug.

Updated

19 years ago
Target Milestone: M12 → M14

Comment 5

19 years ago
This could be solved by implementing RFC 2646 as in bug 16398. I think I have a
fully working version of a libmime class for the receiving part of the RFC, but
it still needs some testing and maybe changes in places I don't know of.
(Assignee)

Updated

19 years ago
Target Milestone: M14 → M20

Comment 6

18 years ago
format=flowed now works, which is one solution to the problems presented here.
Marking this fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
Linux ((2000-04-21-08 M16)
Win32 (2000-04-21-09 M16)
Mac (2000-04-21-08 M16)
Mac and Linux :
 HTML: line wraps to fit window size
 Plain text: line width shows 72 chars
Win32: 
 HTML: line wraps to fit window size
 Plain text: line width shows 72 chars in source file but in view message, it
wraps to fit window size (There is a bug to address the window wrap issue in
plain text)
Since line wrap enhancement is fixed. Mark this bug verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.