Last Comment Bug 292093 - l10n CVS account request for Bulgarian (bg-BG) for Ognyan Kulev
: l10n CVS account request for Bulgarian (bg-BG) for Ognyan Kulev
Status: RESOLVED FIXED
sshkey, voucher
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Dave Miller [:justdave] (justdave@bugzilla.org)
: Dave Miller [:justdave] (justdave@bugzilla.org)
Mentors:
Depends on:
Blocks: 297201
  Show dependency treegraph
 
Reported: 2005-04-27 08:15 PDT by Ognyan Kulev
Modified: 2005-06-20 23:15 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
SSH public key (603 bytes, text/plain)
2005-05-11 04:23 PDT, Ognyan Kulev
no flags Details
FF l10n of browser and toolkit (175.47 KB, application/x-gzip)
2005-05-11 04:26 PDT, Ognyan Kulev
no flags Details
Bulgarian l10n of browser (w/o help) (128.83 KB, application/x-bzip)
2005-05-26 04:28 PDT, Ognyan Kulev
no flags Details
Fixed Bulgarian l10n of Firefox 1.1 (w/o help) (231.36 KB, application/x-bzip)
2005-05-31 04:34 PDT, Ognyan Kulev
no flags Details
Fixed Bulgarian l10n of Firefox 1.1 (w/o help) (127.49 KB, application/x-bzip)
2005-05-31 04:43 PDT, Ognyan Kulev
no flags Details

Description Ognyan Kulev 2005-04-27 08:15:18 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; bg-BG; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; bg-BG; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)

I requested for owner of Bulgarian l10n of Mozilla Firefox in #292092 and here I
request CVS account.  I don't have voucher and I haven't sent the CVS
Contributor form yet.

Reproducible: Always

Steps to Reproduce:
Comment 1 Ognyan Kulev 2005-05-05 10:52:31 PDT
I have posted filled contributor form in 30 or 31 April.  Would you confirm when
it gets received?
Comment 2 Ognyan Kulev 2005-05-05 11:18:17 PDT
In addition to already posted contributor form, tomorrow I'll fax another filled
contributor form.

(I'm sorry for the noise made by this second message for today.)
Comment 3 Ognyan Kulev 2005-05-11 04:23:12 PDT
Created attachment 183273 [details]
SSH public key
Comment 4 Ognyan Kulev 2005-05-11 04:26:22 PDT
Created attachment 183275 [details]
FF l10n of browser and toolkit
Comment 5 Ognyan Kulev 2005-05-11 04:29:54 PDT
1. I have posted contributor form and I have faxed it.
2. SSH public key is attached
3. Initial translation of browser/ and toolkit/ (and some little of dom/) is
attached, as should be imported into l10n repository

Is there anything more I should do for getting CVS account and continuing the
translation in CVS?
Comment 6 Zibi Braniecki [:gandalf][:zibi] 2005-05-11 04:32:56 PDT
(In reply to comment #5)
> 3. Initial translation of browser/ and toolkit/ (and some little of dom/) is
> attached, as should be imported into l10n repository

Are you targeting Firefox 1.0.x or 1.1.x line?
Comment 7 Ognyan Kulev 2005-05-11 05:57:20 PDT
My translation is for Mozilla Firefox 1.1.

But if it's possible to add new language in 1.0.x, I would like to do that -- my
translation is based on another one (made by another guy) that is for 1.0:
https://bugzilla.mozilla.org/show_bug.cgi?id=271341
Comment 8 Zibi Braniecki [:gandalf][:zibi] 2005-05-11 06:10:51 PDT
Is there any Bulgarian l10n team? We'd like to avoid any conflicts.

About 1.0.x - you'd have to prepare another dir structure for 1.0.x. For 1.1.x
I'll review it once you're ready.
Comment 9 Ognyan Kulev 2005-05-11 10:39:54 PDT
Milen Ivanov <kerat@mail.bg> who did FF 1.0 l10n in November 2004 seems to give
up on becoming l10n owner.  His translation is in
https://bugzilla.mozilla.org/show_bug.cgi?id=271341

Peter Velikov <velikov@users.sourceforge.net> did translations of Mozilla
Firefox and Mozilla Suite.  Mozilla Suite l10ns can be found in
http://bgmozilla.sourceforge.net/ . Mozilla Firefox l10n is in
http://cvs.sourceforge.net/viewcvs.py/bgmozilla/ (it's old).

I am not aware of any other recent efforts in Bulgarian l10n of Mozilla.  Before
submitting this CVS account request, I have mailed both of them with my
intention to become Bulgarian l10n owner but there was no response.  (This
surprised me.)

There is only one general Bulgarian mailing list for l10n of programs:
http://fsa-bg.org/cgi-bin/mailman/listinfo/dict (It was called recently moved
from dict@linux.zonebg.com) The translation(s) will be reviewed by them.

BTW I just found that pootle prop2po sometimes (always?) replaces : with \: and
 there may be other defects.  I'll investigate what's exactly happening.
Comment 10 Zibi Braniecki [:gandalf][:zibi] 2005-05-11 10:47:39 PDT
Ok. I can vouch for your account once I'll review your full translation.
Comment 11 Axel Hecht 2005-05-11 10:50:46 PDT
Could you translate that bulgarian comment in bug 271341 as a comment in that
bug? It'd ease things on our side if we could at least claim to have read all
comments over there.
Comment 12 Ognyan Kulev 2005-05-11 11:10:16 PDT
Translation of https://bugzilla.mozilla.org/show_bug.cgi?id=271341#c2 :

> Milen, I don't have time and I have stopped to work on Mozilla l10n since a
long time.  There are some enthusiasts in http://bgmozilla.sourceforge.net/ [1].
Unite with them and try again.

> To announce your project as l10n, read
http://www.mozilla.org/projects/l10n/mlp.html

> Contact the group[2] and register as translator.  The people there will
explain you what, why and how.

[1] Peter Velikov has done the translation there.
[2] Probably he means bgmozilla.sf.net?

Translation of https://bugzilla.mozilla.org/show_bug.cgi?id=292092#c1 :

> Don't report bugs but go and register in the newsgroup[1] of the translators
and make the translation.

> I have stopped to work on that since a long time because of lack of time and
the bad result.

[1] probably dict@fsa-bg.org

I'll add Cc: to the 2 mentioned above people and the team leader of Translation
team for Bulgarian <http://www.iro.umontreal.ca/translation/registry.cgi?team=bg>.
Comment 13 Pavel Franc - Mozilla.cz 2005-05-16 09:05:07 PDT
> I am not aware of any other recent efforts in Bulgarian l10n of Mozilla.  

I found another CVS reguest bug for Bulgarian guy - bug 284984 - who is
interested in starting Firefox Bulgarian localization.
Comment 14 Ognyan Kulev 2005-05-16 11:08:22 PDT
Yes, I know this bug but there's difference between interest and effort.  I will
be ready this week with complete translation ready for review.

Since Mozilla is careful to avoid duplicated work and two heads for one thing,
I'll contact Dido Chanev in his l10n request bug.
Comment 15 Ognyan Kulev 2005-05-19 12:13:26 PDT
There are some things that have happened behind the scene :-)

Milen Ivanov <kerat@mail.bg>, who did translation of Firefox 1.0 that I use as
base for 1.1, contacted me and we decided that I'll become l10n owner and he'll
be peer.  We'll use newly created project
<https://openfmi.net/projects/mozilla-bg/> where I have just committed complete
translation (w/o the help) of Firefox 1.1
<https://openfmi.net/plugins/scmsvn/cgi-bin/viewcvs.cgi/mozilla-1.1/trunk/?root=mozilla-bg>
(the "mozilla-1.1/trunk" part may change in future). I would like to review it
myself first before letting other review it ;-)

It turns out that he has incomplete Thunderbird 1.1 translation so we'll have it
translated.  But let's first handle Firefox 1.1 :-)  It will be the same for
Thunderbird: I as owner and he as peer.
Comment 16 Pavel Franc - Mozilla.cz 2005-05-20 01:21:45 PDT
I'm glad to hear this news. I added these information about Bulgarian l10n team
to our wiki page - http://wiki.mozilla.org/L10n:Localization_Teams
Comment 17 Ognyan Kulev 2005-05-26 04:28:31 PDT
Created attachment 184574 [details]
Bulgarian l10n of browser (w/o help)

Attached is Bulgarian l10n of Mozilla Firefox 1.1 (w/o help).  Please consider
for review.
Comment 18 Pavel Franc - Mozilla.cz 2005-05-26 08:40:41 PDT
> Attached is Bulgarian l10n of Mozilla Firefox 1.1 (w/o help).  Please consider
> for review.

I made a quick check and I found following:

1) Extra file browser/bookmarks/bookmarks.dtd.po.tmp 
2) Charset in toolkit/installer/windows/install.it and
browser/installer/installer.inc should be IMHO 204 (see
http://www.mozilla.org/projects/firefox/l10n/installer-encodings.html)
3) browser/defines.inc - MOZ_LANGPACK_CREATOR is not Mozilla.org but Bulgarian
l10n team

The rest looks good for me.
Comment 19 Benjamin Smedberg [:bsmedberg] 2005-05-26 08:46:57 PDT
ok, this one looks ready to go for a CVS account and trunk CVS commit.
Comment 20 Ognyan Kulev 2005-05-31 04:34:52 PDT
Created attachment 184915 [details]
Fixed Bulgarian l10n of Firefox 1.1 (w/o help)

Changes:
* Removed browser/chrome/browser/bookmarks/bookmarks.dtd.po.tmp
* Charset in browser/installer/installer.inc and
toolkit/installer/windows/install.it is 240 (CP1251) now
* browser/defines.inc defines our MOZ_LANGPACK_CREATOR
* some improvements in translation
Comment 21 Ognyan Kulev 2005-05-31 04:43:55 PDT
Created attachment 184916 [details]
Fixed Bulgarian l10n of Firefox 1.1 (w/o help)

Previous attachment contained editor/ and mail/ :-\
Comment 22 Ognyan Kulev 2005-06-01 08:51:49 PDT
Since there is no confirmation for received contributor form (post or fax), I've
 sent another fax with filled contributor form.
Comment 23 Marcia Knous [:marcia - use ni] 2005-06-09 09:20:14 PDT
fax form and hard copy received. assigning to justdave - dave this one is okay
to activate per bsmedberg's comment.
Comment 24 Ognyan Kulev 2005-06-17 06:11:31 PDT
This is just a reminder that since more than a week all the requirements for
creating account are met.
Comment 25 Dave Miller [:justdave] (justdave@bugzilla.org) 2005-06-20 23:15:03 PDT
Account created.  If you have any problems connecting, let me know.

Note You need to log in before you can comment on or make changes to this bug.