Last Comment Bug 292124 - Print (and print preview) drops some lines when trying to render a TABLE with a CAPTION
: Print (and print preview) drops some lines when trying to render a TABLE with...
Status: RESOLVED FIXED
: testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: 1.8 Branch
: x86 Windows XP
: -- normal with 3 votes (vote)
: ---
Assigned To: Bernd
:
Mentors:
http://clamen.net/stewart/caption.html
: 307331 (view as bug list)
Depends on: reflow-refactor
Blocks: 294991 302911
  Show dependency treegraph
 
Reported: 2005-04-27 11:56 PDT by Stewart M. Clamen
Modified: 2011-08-08 09:52 PDT (History)
11 users (show)
bernd_mozilla: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (20.57 KB, patch)
2005-04-30 01:29 PDT, Bernd
no flags Details | Diff | Review
patch (1.65 KB, patch)
2005-12-30 04:49 PST, Bernd
roc: review-
roc: superreview-
Details | Diff | Review
testcase (1.38 KB, text/html)
2006-08-02 02:25 PDT, Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( )
no flags Details

Description Stewart M. Clamen 2005-04-27 11:56:15 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

This page renders fine on the screen, but in Print Preview (and when printed)
lines are dropped.  It seems to be related to the height of the CAPTION. 
Problem doesn't appear when there is no CAPTION.

Reproducible: Always

Steps to Reproduce:




Exhibits same behaviour under Windows XP and Linux (Firefox 1.0.3)
Comment 1 Muni Sekhar Reddy 2005-04-27 22:12:22 PDT
Please expalin the problem with specific details. Which lines are getting
dropped on the testpage.
Comment 2 Eugene Kim 2005-04-28 12:51:30 PDT
CAPTION is deprecated (as per w3.org). And what do you mean by "lines are dropped"?
Comment 3 Stewart M. Clamen 2005-04-28 13:15:46 PDT
A number of lines (proportional to the height of the caption) are not displayed
in the Print Preview or on the printed pages, at the page break.  (Which lines
depends on your paper and font size.)

Comment 4 Stewart M. Clamen 2005-04-28 13:24:09 PDT
With font-size 16px, Print Preview (scale: shrink to fit , Portrait Mode,
margins all set to 0.5", standard headers and footers), the 
lines:

26
27
28
29

do not appear. (Page one ending with "25" and page two beginning with "30")
Comment 5 Redmond English 2005-04-28 14:03:45 PDT
I am also having exactly the same problem with firefox, versions:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414
Firefox/1.0.3


In response to post #2, as far as I can tell CAPTION is not deprecated; 
 - not in HTML 4.0.1
   http://www.w3.org/TR/html401/index/elements.html

 - nor in XHTML1
   http://www.w3.org/TR/xhtml1/dtds.html#a_dtd_XHTML-1.0-Strict

 - nor in XHTML2
   http://www.w3.org/TR/xhtml2/elements.html
Comment 6 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2005-04-28 15:45:11 PDT
bernd, this looks like one for you :-)
Comment 7 Bernd 2005-04-30 01:29:46 PDT
Created attachment 182246 [details] [diff] [review]
patch

Yeah Chris left a XXX comment where to do it ;-). But I dont know how to pull
correctly the previously pushed children. So the patch works decent on the
first page, but does not print anything on the second. I believe one needs to
unsplit the table frame before the resize. But I have really no idea how this
is done.
Comment 8 Stewart M. Clamen 2005-12-01 07:41:11 PST
Verified that the problem persists in the Firefox 1.5 distro
Comment 9 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2005-12-29 05:06:35 PST
*** Bug 307331 has been marked as a duplicate of this bug. ***
Comment 10 Bernd 2005-12-30 04:49:34 PST
Created attachment 207172 [details] [diff] [review]
patch
Comment 11 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2006-01-08 13:47:33 PST
+        if ((NS_SIDE_TOP  == captionSide) || (NS_SIDE_BOTTOM != captionSide)) {

This should just be NS_SIDE_TOP == captionSide, right?

Is this just a workaround?
Comment 12 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2006-01-20 00:51:52 PST
Comment on attachment 207172 [details] [diff] [review]
patch

minusing until we get some feedback
Comment 13 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2006-08-02 02:25:06 PDT
Created attachment 231731 [details]
testcase

Attaching testcase to the bug, in case the url becomes 404/disappears/etc.
Comment 14 Bernd 2006-12-16 23:28:44 PST
fixed by the reflow branch
Comment 15 Bernd 2008-08-03 07:25:31 PDT
this is again broken, I was about to create a reftest for it when I noticed it.
Comment 16 Aaron Andersen 2011-01-21 16:03:33 PST
Looks like this is still broken in 4.0b9. I'm surprised at the low interest in this bug--I'd think printing tables with captions would be a somewhat common thing.
Comment 17 Bernd 2011-07-30 02:47:50 PDT
this got probably fixed by bug 642088
Comment 18 Bernd 2011-08-07 23:03:25 PDT
marking as fixed, please reopen if you see this with a current nightly
Comment 19 :aceman 2011-08-08 09:52:12 PDT
Can confirm fix on
Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110804 Firefox/8.0a1 ID:20110804030732

while it is still a problem on today's Aurora 7 (mentioned just to show difference).

Note You need to log in before you can comment on or make changes to this bug.