thuderbird dumps core when compacting IMAP folders

RESOLVED DUPLICATE of bug 309259

Status

--
critical
RESOLVED DUPLICATE of bug 309259
14 years ago
13 years ago

People

(Reporter: bill.shannon, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3
Build Identifier: version 1.0.2 (20050323)

Thunderbird dumps core when compacting IMAP folders.
Here's what it says on the way down:

GConf Error: Bad key or directory name:
"/desktop/gnome/url-handlers/GMT+00/command": `+' is an invalid character in
key/directory names
GConf Error: Bad key or directory name:
"/desktop/gnome/url-handlers/GMT+00/command": `+' is an invalid character in
key/directory names
Segmentation Fault - core dumped

Here's the traceback from dbx:

t@1 (l@1) terminated by signal SEGV (Segmentation Fault)
0xff33d5ec: _lwp_kill+0x0008:           bad opcode
(dbx) w
current thread: t@1
=>[1] _lwp_kill(0x0, 0xb, 0x0, 0xfe532000, 0xffff, 0xffff), at 0xff33d5ec
  [2] raise(0xb, 0xffbfdd78, 0x0, 0xb, 0xffff0000, 0x1), at 0xff2dd884
  [3] nsProfileLock::FatalSignalHandler(0xb, 0x191e4, 0xa, 0x108, 0x8a3a60,
0x0), at 0x22728
  [4] __sighndlr(0xb, 0x0, 0xffbfdee8, 0x225f8, 0x0, 0x1), at 0xff33c52c
  [5] call_user_handler(0xb, 0xffbffeff, 0x0, 0x0, 0xfe532000, 0xffbfdee8), at
0xff331998
  [6] 0xf95e3710(0x2c524f8, 0xf98d8935, 0xf98d8951, 0x2c525dc, 0x2c525e0,
0x2c525e4), at 0xf95e370f
  [7] 0xf95e4934(0x2c524f8, 0xffbfe38c, 0x80004003, 0xf961288c, 0xffbfe27c,
0x0), at 0xf95e4933
  [8] 0xf961293c(0x9824c0, 0x137f0e8, 0x2c54998, 0x8000fc00, 0x0, 0xf9901d04),
at 0xf961293b
  [9] XPTC_InvokeByIndex(0x9825c4, 0x1a, 0x2, 0x744fc0, 0xae518, 0xae510), at
0xff1c9148
  [10] 0xff1b0be0(0x147c010, 0x2b06640, 0x0, 0xc, 0x0, 0x1), at 0xff1b0bdf
  [11] PL_HandleEvent(0x284e5c0, 0xae4d4, 0x0, 0xfeda394c, 0xae4d0, 0x284e5c0),
at 0xff1a7a98
  [12] PL_ProcessPendingEvents(0xae4d0, 0xfab4208c, 0x0, 0xfe8bed88, 0x0,
0xae4d0), at 0xff1a79b0
  [13] nsEventQueueImpl::ProcessPendingEvents(0x75bb8, 0xff000000, 0x0, 0x0,
0x0, 0x257db0), at 0xff1a9a8c
  [14] 0xfafb564c(0x216418, 0xff1a9a6c, 0x75bb8, 0x1, 0x1, 0xff215c74), at
0xfafb564b
  [15] g_main_dispatch(0x70208, 0xfe8bec00, 0x0, 0x0, 0xfffffffd, 0xffffffef),
at 0xfe855a40
  [16] g_main_context_dispatch(0x70208, 0x64, 0x0, 0x1, 0xfe8bec00, 0x70208), at
0xfe856f74
  [17] g_main_context_iterate(0x1, 0x1, 0x1, 0x70208, 0x70210, 0x9), at 0xfe857440
  [18] g_main_loop_run(0x29c8b8, 0xfe8bec00, 0xff335de0, 0x10c060, 0xfe8aa800,
0xfe8aa800), at 0xfe857bbc
  [19] gtk_main(0x0, 0x0, 0x29c8b8, 0x143460, 0xfecf2620, 0x4cdc), at 0xfeb2a5b4
 [20] 0xfafb5aac(0x8d780, 0xc1f30000, 0xfafb5a70, 0x0, 0xffbfe840, 0xfafed664),
at 0xfafb5aab
  [21] xre_main(0xfccf8bd8, 0x3d158, 0xffbfe93c, 0xffbfedc4, 0xffbfedcc,
0xffbfede8), at 0x1b37c


Reproducible: Always

Steps to Reproduce:
1. Open IMAP folder (e.g., INBOX)
2. Select File / Compact Folders
3. Wait for core dump

Actual Results:  
core dump

Expected Results:  
folders are compacted

Comment 1

13 years ago
This is not a very goot traceback since it's stripped. Please mark as dup of bug
309259 

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 309259 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.