Documents grow too wide with overflow:auto

VERIFIED FIXED

Status

()

VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: kairo, Assigned: roc)

Tracking

(Depends on: 1 bug, {regression})

Trunk
x86
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
This is a followup to bug 273392 and a regression of bug 240176

In my Linux build from today, the testcases of 273392 stopped jumping around as
expected after the fix for bug 240176 but now all those testcases are too wide
for the screen and show a vertical scrollbar though it's not needed. The
documents have grown in width by approx. the width of a scrollbar.

This is true for those two simplified testcases:
https://bugzilla.mozilla.org/attachment.cgi?id=168031
https://bugzilla.mozilla.org/attachment.cgi?id=168032

as well as for the original page where I saw the other bug happening:
http://www.fynf.at/?vd=3

all of those use overflow:auto along with a padding: 1em; on a div containing
some other blocks.
(Reporter)

Updated

14 years ago
No longer depends on: 273392
(Reporter)

Updated

14 years ago
Depends on: 273392
Keywords: regression
Probably fixed by the patch in bug 47710

Comment 2

14 years ago
You can see a rather extreme case of what appears to be this bug at
http://www.scarygoround.com/ (the document is far too wide). Getting rid of the
div with class="scroll" makes the problem go away.

Comment 3

14 years ago
Created attachment 182222 [details]
Reduced SGR testcase.

This might not be exactly the same bug, but it's probably similar (or at least
it regressed at the same time). Here's a reduced testcase from the above URL,
anyway.
You guys know about bug 292370 (esp. bug 292370 comment 10), right?
Any chance this is a dupe?
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> You guys know about bug 292370 (esp. bug 292370 comment 10), right?
> Any chance this is a dupe?

Could probably be related, but I don't think it's a dupe, those cases look very
different from the HTML/CSS side... even if if might go back to the same pieces
of backend code. roc might know more there...
(Reporter)

Comment 6

14 years ago
(In reply to comment #0)
> ... now all those testcases are too wide
> for the screen and show a vertical scrollbar ...

Sorry for that mistake, I meant a horizantal scrollbar here...
The testcases in comment #0 are fixed by the patch in bug 47710.

The attached testcase is fixed by the patch in bug 292370.
Depends on: 47710, 292370
(Reporter)

Comment 8

14 years ago
Yes, this is fixed now that the patch for bug 47710 is in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Summary: Documents grows too wide with overflow:auto → Documents grow too wide with overflow:auto
This has been fixed a while back; verified with build 2005-05-16-06, Windows XP
using Seamonkey trunk.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.