Last Comment Bug 292799 - canvas need not override GetContentForEvent
: canvas need not override GetContentForEvent
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: All All
: P4 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 373724 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-03 15:41 PDT by Christian :Biesinger (don't email me, ping me on IRC)
Modified: 2011-10-05 11:53 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Christian :Biesinger (don't email me, ping me on IRC) 2005-05-03 15:41:41 PDT
canvas's impl of this function is the same as nsFrame's:
http://lxr.mozilla.org/seamonkey/source/layout/generic/nsHTMLCanvasFrame.cpp#201
http://lxr.mozilla.org/seamonkey/source/layout/generic/nsFrame.cpp#962
Comment 1 Eli Friedman 2007-05-26 01:34:34 PDT
*** Bug 373724 has been marked as a duplicate of this bug. ***
Comment 2 Bas Schouten (:bas.schouten) 2011-10-05 06:43:33 PDT
There's a small difference, http://mxr.mozilla.org/seamonkey/source/layout/generic/nsHTMLCanvasFrame.cpp#260 does an argument check. Is there a reason for this? Or can we just merge them?
Comment 3 Timothy Nikkel (:tnikkel) 2011-10-05 11:53:36 PDT
You're looking at the seamonkey tree, I'm not sure exactly what that is but in mozilla-central nsHTMLCanvasFrame doesn't override GetContentForEvent. So this is fixed.

Note You need to log in before you can comment on or make changes to this bug.