<canvas> not working in beast Installer builds

VERIFIED DUPLICATE of bug 293280

Status

()

Firefox
Installer
--
major
VERIFIED DUPLICATE of bug 293280
13 years ago
10 years ago

People

(Reporter: By, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050507 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050507 Firefox/1.0+

With the zip distributions <canvas> works, in the installer builds it doesn't.

Reproducible: Always
->NEW
->major
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
just to make it clear, it does work in .zip builds

Comment 3

13 years ago
Last time I tested (11 hours earlier) it was due to interface info for
nsIDOMCanvasRenderingContext2D not generated (xpt). Copying this file:
http://mozilla.doslash.org/stuff/nsIDOMCanvasRenderingContext2D.xpt
to firefox\components and restarting fixes the problem.
Summary: <canvas> not implemented in beast Installer builds → <canvas> not working in beast Installer builds
Version: unspecified → Trunk

Comment 4

13 years ago
Is Cairo enabled for installer builds? See also bug 293249 of which this might
be a duplicate.

Comment 5

13 years ago
yes, at least it was 11 hours ago. It's more of build config differences between
installer/zip builds I guess.
a search in prog files/firefox/ for containing word "cairo" gives
firefox.exe , compreg.dat and toolkit.jar
for a .zip

and nothing for an installer build

Comment 7

13 years ago
Per comment 6 I'd say this is a duplicate of bug 291765. Or just invalid.
or component build-config
It was supposed to work, so inva/dupe doesn't seem right.

Comment 9

13 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1115470740.18262.gz&fulltext=1
has --enable-cairo. Peter are you sure you checked the right build?
(In reply to comment #9)
>
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1115470740.18262.gz&fulltext=1
> has --enable-cairo. Peter are you sure you checked the right build?

I did search the .zip build for any file containing the word "cairo"
with 3 files as result.

the reporter did the same for an installer build, with no files found as result.
I did not verify it by installing a build myself

got other confirmation about cairo not being build on FF installer.
What next, change summary , or close this bug as inva and file a new one under 
FF - build-config ?
(Reporter)

Comment 12

13 years ago
Due to user error, I reported the wrong results.  There are actually 10
occurrences of the string "cairo" in firefox.exe.  I did not find it elsewhere
however.  Maybe it's time to make this a build config issue.

Comment 14

13 years ago

*** This bug has been marked as a duplicate of 293280 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.