Wrong layering (paint order?) of <div>s?

VERIFIED DUPLICATE of bug 191830

Status

()

defect
VERIFIED DUPLICATE of bug 191830
15 years ago
15 years ago

People

(Reporter: Biesinger, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

See http://biesi.damowmow.com/acid2/min.html - a somewhat minimized testcase of
a part of the acid2 test (could use more minimizing)

The comments in the source claim that the float is supposed to be rendered below
the <img>.
Thus, the right (black) border of the image should cover the red border of the
#eyes-b div. Additionally, the eyes shouldn't look "blurred" (it's the
background image of the #eyes-b div that causes this).

http://www.w3.org/TR/CSS21/visuren.html#z-index seems to confirm the comments in
the testcase.

seen on current trunk cvs on both windows and linux (gtk2), seamonkey.
hm, is this what bug 289480 comment 17 refers to, and thus a duplicate?

(re that comment, I am working on not creating an object frame for image content
of <object>, and thus the objectframe part of that comment is probably not
needed to fix acid2)
Summary: Wrong layering of <div>s? → Wrong layering (paint order?) of <div>s?
There are already two bugs in bug 289480's dependency tree on paint order:  bug
191830 and bug 290290.  Is this just a duplicate of one of those?
dbaron: It can't be a duplicate of bug 290290, since there is no object frame
involved here. it could be bug 191830. But setting an opacity doesn't seem to
help (http://biesi.damowmow.com/acid2/min2.html), so I don't think it's a duplicate?
It wouldn't help, since it's testing backwards order layering using
block/inline.  Removing the 'fixed'-ness of the background is what should help.

*** This bug has been marked as a duplicate of 191830 ***
No longer blocks: acid2
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
ok, thanks. that does help - http://biesi.damowmow.com/acid2/min3.html

vrfy.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.